Forums for the FreeOrion project
It is currently Sun Mar 18, 2018 10:01 am

All times are UTC

Post new topic Reply to topic  [ 1 post ] 
Author Message
PostPosted: Sun Sep 23, 2012 8:18 pm 
Programming, Design, Admin
User avatar

Joined: Wed Oct 08, 2003 1:33 am
Posts: 12153
Location: Munich
I noticed a bunch of error messages in the AI logs like this
2012-09-23 12:36:52,105 ERROR AI : Variable<double>::Eval unrecognized object property: RootCandidate.Population
I traced this to the scope condition of the Industrial Centre building, which uses the marco [[INFRA_CONDITION_INFRA]] which evaluates to
'''Construction low = RootCandidate.Population * [[INFRA_PRODUCTION_PER_POP]] / ([[INFRA_PRODUCTION_PER_INFRA]])'''
This causes the error message because there's no test that selects only planet earlier in the enclosing And condition, so the scope evaluation is testing the Population of buildings located on planets that match the other conditions in the scope. Whenever such a macro is used, the script should have a Planet condition earlier in the And condition, to exclude buildings and avoid this error message. It looks like a few other buildings use this macro, or similar macros, which are assuming only planets (or only objects with certain other meters) are previously selected.

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC

Who is online

Users browsing this forum: No registered users and 1 guest

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group