FreeOrion

Forums for the FreeOrion project
It is currently Mon Nov 20, 2017 1:58 am

All times are UTC




Post new topic Reply to topic  [ 24 posts ]  Go to page 1, 2  Next
Author Message
PostPosted: Thu Feb 12, 2015 12:12 pm 
Offline
Space Floater

Joined: Fri Jan 30, 2015 11:50 am
Posts: 31
I hope this quest isn't to hard for me. Or for my tutor. :)



At first I read

http://freeorion.org/index.php/Compile

There are hard- and software requirements



Hardware

AMD 8core
8 GB RAM


Software
The easiest way for me to install programms is the package manager. So I looked there, what is in my Knoppix implemented.



GiGi -> no
Boost -> libboost-all-dev installable
Ogre 3D -> no
Bullet -> libbullet-dev installable
FreeType2 -> FreeType2-demos
Python -> 2.7.5-5
OpenAL -> libopenal1
libogg -> libogg0 1.3.0-4
libvorbis -> libvorbis0a

zlib -> zlib1g, 1:1.2.8dfsg-2+b1
libpng -> libpng 12-0 1.1.49-1


My Questions for Software
- are the lib... o.k.? or I have to install the original?
- From where I get
GiGi
Ogre3D
the other, if the libs not o.k.?
- and how I can install these? (I know, there is a "sudo"-way)


By the way: I have compile for every new test version?


Last edited by Själe on Thu Feb 12, 2015 4:41 pm, edited 4 times in total.

Top
 Profile  
 
PostPosted: Thu Feb 12, 2015 2:53 pm 
Offline
Release Manager, Design
User avatar

Joined: Wed Nov 16, 2011 12:56 pm
Posts: 4241
Location: Sol III
Ok, as I'm not on Linux, but Mac, I can only give very limited help here, I'll have to leave that to our Linux folks. But hopefully I can give a few hints...
Själe wrote:
- From where I get
GiGi
You don't need to get that specific library. GiGi's sourcecode has been integrated into FO a long time ago, so it will be build with FO automatically.
Quote:
By the way: I have compile for every new test version?
Well, yes, of course, the binaries don't magically update themselves whenever the sourcecode gets changed. But once you've set up your build environment, it should be as easy as pulling the most recent revision from the repo (usually one command, "svn update"), and then a few commands to execute the build process. With 8GB RAM and an 8 core AMD building shouldn't take too long.


Top
 Profile  
 
PostPosted: Thu Feb 12, 2015 4:45 pm 
Offline
Space Floater

Joined: Fri Jan 30, 2015 11:50 am
Posts: 31
Thanks for GiGi-Information. On toppic killed. :)


I found the program ogre3D.


http://www.ogre3d.org/download


Next Question:
wich from these downloads are the right?
SDK, isn't it?



1. Download a prebuilt SDK

2. Download a source package

3. Retrieve the source from Mercurial



I have to download also some from these?



As well as the core OGRE library, you may also wish to download some related projects:

Demos

Tools

Add-ons


If I have to install the SDK, wich from this versions is the right?


Code:
OGRE 1.9 SDK for Visual C++ 2012 (32-bit)    29. November 2013    143.0 MB    Self-extracting archive
OGRE 1.9 SDK for Visual C++ 2010 (32-bit)    29. November 2013    141.5 MB    Self-extracting archive. Please note – you must have installed VS2010 Service Pack 1.
OGRE 1.9 SDK for Visual C++ 2008 (32-bit)    29. November 2013    141.5 MB    Self-extracting archive. Please note – you must have installed VS2008 Service Pack 1.
OGRE 1.9 SDK for iOS


Top
 Profile  
 
PostPosted: Thu Feb 12, 2015 4:54 pm 
Offline
Juggernaut

Joined: Mon Feb 04, 2013 10:15 pm
Posts: 757
Själe wrote:
Next Question:
wich from these downloads are the right?
SDK, isn't it?


You should be able to install it through the package manager:

http://www.freeorion.org/index.php/Compile_In_Linux#Ogre3D


Top
 Profile  
 
PostPosted: Thu Feb 12, 2015 5:27 pm 
Offline
AI Lead, Programmer
User avatar

Joined: Sat Sep 22, 2012 6:25 pm
Posts: 4374
Själe wrote:
From this and your questions it sounds like you haven't gotten to our page specifically on Compiling in Linux, which Andrew also just linked to, it should be quite helpful to you.

AndrewW wrote:
Själe wrote:
Next Question: wich from these downloads are the right? SDK, isn't it?
You should be able to install it through the package manager:
I just double checked a list of knoppix packages, and rather surprisingly libogre was not on it.

As to the question, the SDK is only for Windows and Mac, for Linux if it's not a regular package offering for you they expect you to build it yourself. So, as mentioned in our guide that Andre linked to, I'd recommend following their instructions here, except that as noted in our guide you may not need to do their step of building OIS.

_________________
If I provided any code, scripts or other content here, it's released under GPL 2.0 and CC-BY-SA 3.0


Top
 Profile  
 
PostPosted: Thu Feb 12, 2015 7:40 pm 
Offline
Space Floater

Joined: Fri Jan 30, 2015 11:50 am
Posts: 31
Dilvish wrote:
... it sounds like you haven't gotten to our page specifically on Compiling in Linux


Uff. Sorry.

For my Knoppix I have to use the debian instructions? (http://freeorion.org/index.php/Compile_In_Linux)

The ogre3D installation writes about and links to the version 1.8. But there is a v1.9. ready for download.
Which shell I take?

There are "Prerequisites" listed.
I think I have to follow the Ubuntu instructions?

Broadly I understand the instructions. But I'm little afraid about the details. And the errors. :?


Think it will be my weekend mission. :)



edit: ffff... Better to look myself. :) thanks for the word "libogre".
My package manager offers me "libogre 1.7, 1.8 and 1.9. Which is recommended?

edit:
Have to install the libogre1.x-dev?


Top
 Profile  
 
PostPosted: Thu Feb 12, 2015 8:38 pm 
Offline
AI Lead, Programmer
User avatar

Joined: Sat Sep 22, 2012 6:25 pm
Posts: 4374
Själe wrote:
For my Knoppix I have to use the debian instructions? (http://freeorion.org/index.php/Compile_In_Linux)
Those instructions were somewhat stale/incomplete. I have now edited them and they now link to some more involved instructions from the person who packages FO for debian. You may find those instructions more helpful and easier that a full Linux compile.

Quote:
Have to install the libogre1.x-dev?
Yes, use a -dev version. I would recommend starting out trying version 1.9-dev, since if it works for you then newer is better. It has worked for some people, but other people have had to drop down to 1.8. I guess there are complications with other system dependencies.

_________________
If I provided any code, scripts or other content here, it's released under GPL 2.0 and CC-BY-SA 3.0


Top
 Profile  
 
PostPosted: Thu Feb 12, 2015 10:08 pm 
Offline
Release Manager, Design
User avatar

Joined: Wed Nov 16, 2011 12:56 pm
Posts: 4241
Location: Sol III
Ogre 1.8 is the version used for the Win and Mac builds.


Top
 Profile  
 
PostPosted: Fri Feb 13, 2015 7:12 pm 
Offline
Dyson Forest

Joined: Sun May 11, 2008 10:50 am
Posts: 231
1.9 works fine for me.

You're really using Knoppix as a distro? Or just the live CD? It's not the typical desktop distro, just wondering...

_________________
Attached patches are released under GPL 2.0 or later.


Top
 Profile  
 
PostPosted: Sat Feb 14, 2015 12:59 am 
Offline
Space Floater

Joined: Fri Jan 30, 2015 11:50 am
Posts: 31
Thanks. So I will install the libogre1-dev 1.9 at first.


Question:
Shell I follow with Knoppix the debian way?



Chriss wrote:
You're really using Knoppix as a distro? Or just the live CD? It's not the typical desktop distro, just wondering...



Ten years ago I started with suse. I failed during the installation of my grafic card und misunderstanding the manual. :)
Later I tried Opensuse and Ubuntu... And failed better.
Then I found an Knoppix on a windows repair DVD. Installation quick and easy. No Problems with hardware - think because a live system.
And the very big bonus - its a german writing support. :)

I hear often from linux specialists thats not good to use knoppix for a desktop distro. But I'm real happy with this stuff. On the way I improved the system step by step and learn something about linux and not at least I improve my English. I think that are enough reasons to keep it.
And I heared sometimes: Never change a running system.


Top
 Profile  
 
PostPosted: Sat Feb 14, 2015 1:14 am 
Offline
AI Lead, Programmer
User avatar

Joined: Sat Sep 22, 2012 6:25 pm
Posts: 4374
Själe wrote:
Ten years ago I started with suse. I failed during the installation of my grafic card und misunderstanding the manual. :)
Later I tried Opensuse and Ubuntu... And failed better. Then I found an Knoppix on a windows repair DVD. Installation quick and easy. No Problems with hardware - think because a live system.
All of the Linux distros have gotten tremendously better with their hardware support over the past decade, particularly regarding graphics cards & their drivers. It seems to me like there was a pretty big jump something like 4 to 5 years ago. So it could be just (or partly) that things had started getting better on that front around the time that you tried Knoppix. But perhaps it's not that at all. I started with Fedora and a few years ago migrated to Ubuntu (in particular, Kubuntu, Ubuntu oriented around KDE instead of Gnome); I like it a lot. But you're right to be wary of changing things that are working fine for you.

_________________
If I provided any code, scripts or other content here, it's released under GPL 2.0 and CC-BY-SA 3.0


Top
 Profile  
 
PostPosted: Mon Feb 16, 2015 1:45 pm 
Offline
Space Floater

Joined: Fri Jan 30, 2015 11:50 am
Posts: 31
Problems

@libogre-1.9-dev

I tried to install it with "Synaptic package manager".
And it tells me, there are conflicts with other programs.

Also it tells me (about "attributes") that it need to install "libogre 1.9.0" at first. I thougt I have to install "libogre-1.9-dev" instead of "libogre-1.9".

Its better to install about the debian way ("apt install build-essential" and so)?
Ignores this way the conflicts?

How many MB amounts the download?


Top
 Profile  
 
PostPosted: Mon Feb 16, 2015 4:45 pm 
Offline
AI Lead, Programmer
User avatar

Joined: Sat Sep 22, 2012 6:25 pm
Posts: 4374
Själe wrote:
Also it tells me (about "attributes") that it need to install "libogre 1.9.0" at first. I thougt I have to install "libogre-1.9-dev" instead of "libogre-1.9".
That's a standard package setup, that libogre-1.9-dev depends on the underlying libogre-1.9

Quote:
I tried to install it with "Synaptic package manager".
And it tells me, there are conflicts with other programs.
Hmm, well that doesn't sound good. You could check if it gives you the same warning if you try to install Ogre 1.8. Otherwise you would probably have to build Ogre yourself (so that it gets built taking into account these other things on your system that conflict with the standard version). My recollection is that it is fairly simple to build, few or none of these extra complications that FO has.

Quote:
Its better to install about the debian way ("apt install build-essential" and so)?
Ignores this way the conflicts? How many MB amounts the download?
I am doubdtful that would automatically get you past the conflicts. But, if you tried applying that debian build process (not the plain debian installation process) to build Ogre and then build FO, I think that would work. But I'm no expert on the debian build process.

_________________
If I provided any code, scripts or other content here, it's released under GPL 2.0 and CC-BY-SA 3.0


Top
 Profile  
 
PostPosted: Tue Feb 17, 2015 3:35 pm 
Offline
Dyson Forest

Joined: Sun May 11, 2008 10:50 am
Posts: 231
In some distributions, the library package like libogre does only provide the binary library files for other executables to use (to link against). It does not provide the header files you need to compile new software which uses the library - those are in the *-dev packages, like the libogre-dev one. This saves some space, as many people may not need the header files, as they do not develop or compile software. So yes, that libogre-dev pulls in libogre as dependency is normal and expected. You need both.

What conflicts are beeing reported? Which packages fails? Due to which other package?

_________________
Attached patches are released under GPL 2.0 or later.


Top
 Profile  
 
PostPosted: Wed Feb 18, 2015 11:27 pm 
Offline
Space Floater

Joined: Fri Jan 30, 2015 11:50 am
Posts: 31
If I mark the libogre-1.9.0 to install the color of the marker turned to red.
If I look under "Attributes" there's no conflict listed. Only the needed other downloads.

I try to repair. Breaks with an error message
(it's a german version. If necessary I could try to change the language.)

Code:
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.
E: Fehler: Unterbrechungen durch pkgProblemResolver::Resolve hervorgerufen; dies könnte durch zurückgehaltene Pakete verursacht worden sein.
E: Auflösen der Abhängigkeiten ist fehlgeschlagen
E: Fehler: Unterbrechungen durch pkgProblemResolver::Resolve hervorgerufen; dies könnte durch zurückgehaltene Pakete verursacht worden sein.
E: Auflösen der Abhängigkeiten ist fehlgeschlagen




The same way with "libogre-1.8.0" is conflictless.

Shell I install 1.8.0?


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 24 posts ]  Go to page 1, 2  Next

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group