FreeOrion

Forums for the FreeOrion project
It is currently Sun Oct 22, 2017 10:50 pm

All times are UTC




Post new topic Reply to topic  [ 4 posts ] 
Author Message
PostPosted: Thu Nov 03, 2016 1:49 am 
Offline
Space Krill

Joined: Thu Nov 03, 2016 1:30 am
Posts: 2
Hey guys

I recently downloaded the new version (0.4.6) and installed it on Windows Xp. I launched the game, and everything was running fine, but as soon as I clicked on the "Options" button, the game crashed. I launched again, and the same thing happened. This happened with even when I clicked the Single Player button. In fact, the only two buttons which worked were the Exit and Multiplayer button, but after the menu came up on multiplayer, once I began hosting a game, I crashed again.

I looked around the internet, and found a solution involving upgrading my OpenGl. I tried that, but it didn't work.

Any idea what's going on here? I'm running 32-bit windows xp, and I have Intel Q963/Q965 Integrated Graphics (sorry, I'm poor). 0.4.5 works fine on it.

Also, here's the log when I clicked on the multiplayer button, but I don't think it'll help.


Top
 Profile  
 
PostPosted: Thu Nov 03, 2016 8:05 am 
Offline
Release Manager, Design
User avatar

Joined: Wed Nov 16, 2011 12:56 pm
Posts: 4226
Location: Sol III
tux wrote:
Also, here's the log
There is no log attached to your post... please try again, without at least the log we can't do anything.

I guess we also need a backtrace to get an idea where the crash happens. Unfortunately I can't tell you how to get that on Windows (I'm on Mac), hopefully someone of our Windows folks can help you out here - anyone? Another approach could be to try to narrow down which change after 0.4.5 caused the program to stop working on your system. As all the test builds that have been provided since 0.4.5 are still available fo download, you could try to install one after another an try to find out which is the first one that doesn't work for you. Of course, that's quite tedious...

All that said, judging by my own experience and the reports we get there seems to be a problem with Intel Integrated Graphics. Apparently OpenGL support for that is not very good... :?


Top
 Profile  
 
PostPosted: Thu Nov 03, 2016 8:48 am 
Offline
Programmer
User avatar

Joined: Fri Mar 01, 2013 9:52 am
Posts: 1040
Location: Germany
Quote:
Q963/Q965


This isn't a graphic card, but a northbridge/memory controller.

Quote:
Apparently OpenGL support for that is not very good... :?


It's literally from a previous millenium (Well, almost. At least from a different decade) and horrible outdated.

_________________
Resident code gremlin
Attached patches are released under GPL 2.0 or later.
Git author: Marcel Metz


Top
 Profile  
 
PostPosted: Fri Nov 11, 2016 1:31 am 
Offline
Space Krill

Joined: Thu Nov 03, 2016 1:30 am
Posts: 2
Vezzra wrote:
tux wrote:
Also, here's the log
There is no log attached to your post... please try again, without at least the log we can't do anything.

I guess we also need a backtrace to get an idea where the crash happens. Unfortunately I can't tell you how to get that on Windows (I'm on Mac), hopefully someone of our Windows folks can help you out here - anyone? Another approach could be to try to narrow down which change after 0.4.5 caused the program to stop working on your system. As all the test builds that have been provided since 0.4.5 are still available fo download, you could try to install one after another an try to find out which is the first one that doesn't work for you. Of course, that's quite tedious...

All that said, judging by my own experience and the reports we get there seems to be a problem with Intel Integrated Graphics. Apparently OpenGL support for that is not very good... :?


Right, sorry. It's down below now.

adrian_broher wrote:
Quote:
Q963/Q965


This isn't a graphic card, but a northbridge/memory controller.

Quote:
Apparently OpenGL support for that is not very good... :?


It's literally from a previous millenium (Well, almost. At least from a different decade) and horrible outdated.


I see. Well that's a bummer.


Attachments:
freeorion.log [7.2 KiB]
Downloaded 25 times
Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group