FreeOrion

Forums for the FreeOrion project
It is currently Sat Dec 16, 2017 5:16 am

All times are UTC




Post new topic Reply to topic  [ 5 posts ] 
Author Message
PostPosted: Tue Dec 12, 2017 11:26 am 
Offline
Space Floater

Joined: Wed Apr 13, 2016 12:57 pm
Posts: 20
Location: UK
Hi

Tried a game as Egassem and found that after turn 6 the pop on my HW started to decline. There was no Kraken sitting on the HW; AFAIK Kraken are the only 'normal' monster to kill lithic species.

Looking at the planet data shows a continual prediction of pop dropping after turn 6. PP drops in parallel with the pop so it's unlikely to be a bug in the graphing or whatever - the pop really does seem to vanish.

I have screen shots of the planet pop at different turns, and of the pop and production curves for turns 1 to 10. I have kept the first 10 .sav files which I could upload if desired.

System: Win 7 Pro 64 SP1 on 500 GB 850 EVO; game install on 1TB WD Black. Asus P8Z77 Pro, Intel i7-3770K @ stock 3.5GHz, 16GB Vengeance Red 2300MHz. Windows updated this morning before installing the FO build.


Game parameters: elliptical, age medium, 200 systems, starlanes medium, monsters low, specials low, natives high, planet density high. Player Egassem plus 6 AI races, maniacal. Seed: 2102.

Thanks for your excellent hard work on this brilliant game.


Top
 Profile  
 
PostPosted: Tue Dec 12, 2017 4:50 pm 
Offline
Programming, Design, Admin
User avatar

Joined: Wed Oct 08, 2003 1:33 am
Posts: 12042
Location: Munich
Screenshot illustrating the issue and a save that reproduces it would be appreciated.


Top
 Profile  
 
PostPosted: Wed Dec 13, 2017 5:42 pm 
Offline
Release Manager, Design
User avatar

Joined: Wed Nov 16, 2011 12:56 pm
Posts: 4303
Location: Sol III
@Heracliton, can you open an issue on github?


Top
 Profile  
 
PostPosted: Wed Dec 13, 2017 6:56 pm 
Offline
Space Dragon
User avatar

Joined: Mon Apr 10, 2017 4:25 pm
Posts: 258
May it have been that biological warfare thing that you can counter with the genome bank building?


Top
 Profile  
 
PostPosted: Fri Dec 15, 2017 8:36 pm 
Offline
Pupating Mass
User avatar

Joined: Sun Nov 19, 2017 6:32 pm
Posts: 93
I believe i'm seeing a similar (or possibly the same) issue. (v0.4.7+ [build 2017-12-14.8693b73] MSVC 2015)

There is an "Unknown" +8.00 (twice planet size) Population on my Egassem homeworld at turn 38 (this is the earliest save i have), which disappears on the next turn, after which the population begins to decline. I can't think of a good explanation of where that +8 is coming from (though it could be some mechanic i'm forgetting or am unaware of).

Logs and save file from turn 38:
Attachment:
EgassemPopBug.zip [399.92 KiB]
Not downloaded yet


Seed and settings are these: viewtopic.php?f=6&t=10513#p90918

Screenshot from turn 38:
Attachment:
EgassemPopBug.jpg
EgassemPopBug.jpg [ 292.12 KiB | Viewed 9 times ]


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group