FreeOrion

Forums for the FreeOrion project
It is currently Fri Oct 31, 2014 4:42 am

All times are UTC




Post new topic Reply to topic  [ 24 posts ]  Go to page 1, 2  Next
Author Message
PostPosted: Thu May 13, 2010 3:05 pm 
Offline
Krill Swarm

Joined: Thu May 13, 2010 2:46 pm
Posts: 12
The game gets stuck at this point every time, but weirdly enough this point comes at different turns whenever it happens. My computer is about 2 years old with parts that were "great" at the time so I don't think its a hardware problem for my computer.


Top
 Profile  
 
PostPosted: Thu May 13, 2010 3:12 pm 
Offline
Graphics Lead Emeritus
User avatar

Joined: Mon Mar 08, 2004 6:17 pm
Posts: 1938
Location: 52°16'N 10°31'E
Please see the announcement.

What version? What platform? Did you compile yourself?


Top
 Profile  
 
PostPosted: Thu May 13, 2010 3:28 pm 
Offline
Krill Swarm

Joined: Thu May 13, 2010 2:46 pm
Posts: 12
Didn't compile myself version 0.3.14-Win32(well this is what it says on the setup exe) Im running it on windows xp.

I cant find my logs or I don't know what they're called(found the config.xml through the announcement).


Top
 Profile  
 
PostPosted: Thu May 13, 2010 3:38 pm 
Offline
Graphics Lead Emeritus
User avatar

Joined: Mon Mar 08, 2004 6:17 pm
Posts: 1938
Location: 52°16'N 10°31'E
They are called freeorion.log, freeoriond.log and ogre.log and they should be in the same directory the config.xml is in. Since you seem to be able to run everything fine until a certain turn, they should be there.


Top
 Profile  
 
PostPosted: Thu May 13, 2010 3:44 pm 
Offline
Krill Swarm

Joined: Thu May 13, 2010 2:46 pm
Posts: 12
Found all 3. 2 are too big to attach can copy and paste if this isnt the right one.

Edit#1 Bottom part of freeorion

2010-05-13 11:17:19,296 DEBUG Client : trying to find stockpile system group... stockpile system has id: 16
2010-05-13 11:17:19,296 DEBUG Client : potential group:
2010-05-13 11:17:19,296 DEBUG Client : ....16
2010-05-13 11:17:19,296 DEBUG Client : ....31
2010-05-13 11:17:19,296 DEBUG Client : ....50
2010-05-13 11:17:19,296 DEBUG Client : MapWnd::RefreshMineralsResourceIndicator found group of systems for stockpile system. size: 3
2010-05-13 11:17:19,296 DEBUG Client : ResourcePool::GroupAvailable(16)
2010-05-13 11:17:19,296 DEBUG Client : ResourcePool::GroupProdeuction(16)
2010-05-13 11:17:19,296 DEBUG Client : minerals available in stockpile group is: 11.5
2010-05-13 11:17:19,296 DEBUG Client : minerals allocation in stockpile group is: 11.5
2010-05-13 11:17:19,296 DEBUG Client : Predicted stockpile is: 0
2010-05-13 11:17:19,296 DEBUG Client : Old stockpile is 0
2010-05-13 11:17:19,296 DEBUG Client : Stockpile change is: 0
2010-05-13 11:17:19,359 DEBUG Client : BuildDesignatorWnd::BuildSelector::Refresh()
2010-05-13 11:17:19,359 DEBUG Client : BuildDesignatorWnd::BuildSelector::PopulateList() : Adding Buildings
2010-05-13 11:17:19,359 DEBUG Client : BuildDesignatorWnd::BuildSelector::PopulateList() : Adding ship designs
2010-05-13 11:17:19,359 DEBUG Client : Selecting Row
2010-05-13 11:17:19,359 DEBUG Client : Done
2010-05-13 11:17:19,375 DEBUG Client : MapWnd::InitTurn m_production_wnd refresh time: 78
2010-05-13 11:17:19,375 DEBUG Client : MapWnd::InitTurn time: 812
2010-05-13 11:17:20,656 DEBUG Client : MapWnd::EndTurn
2010-05-13 11:17:20,656 DEBUG Client : (HumanClientFSM) PlayingTurn.TurnEnded
2010-05-13 11:17:20,656 DEBUG Client : (HumanClientFSM) ~PlayingTurn
2010-05-13 11:17:20,656 DEBUG Client : (HumanClientFSM) WaitingForTurnData
2010-05-13 11:17:20,656 DEBUG Client : (HumanClientFSM) WaitingForTurnDataIdle
2010-05-13 11:17:20,671 DEBUG Client : (HumanClientFSM) WaitingForTurnData.TurnProgress
2010-05-13 11:17:20,687 DEBUG Client : (HumanClientFSM) WaitingForTurnData.TurnProgress
2010-05-13 11:17:20,718 DEBUG Client : (HumanClientFSM) WaitingForTurnData.TurnProgress
2010-05-13 11:17:20,734 DEBUG Client : (HumanClientFSM) WaitingForTurnData.TurnProgress
2010-05-13 11:17:20,734 DEBUG Client : (HumanClientFSM) WaitingForTurnData.TurnProgress
2010-05-13 11:17:20,750 DEBUG Client : (HumanClientFSM) WaitingForTurnData.TurnProgress
2010-05-13 11:17:20,750 DEBUG Client : (HumanClientFSM) WaitingForTurnData.TurnProgress
2010-05-13 11:17:20,765 DEBUG Client : (HumanClientFSM) WaitingForTurnData.TurnProgress
2010-05-13 11:17:20,781 DEBUG Client : (HumanClientFSM) WaitingForTurnData.TurnProgress
2010-05-13 11:17:20,796 DEBUG Client : (HumanClientFSM) WaitingForTurnData.TurnProgress
2010-05-13 11:17:20,812 DEBUG Client : (HumanClientFSM) WaitingForTurnData.TurnProgress
2010-05-13 11:17:20,812 DEBUG Client : (HumanClientFSM) WaitingForTurnData.TurnProgress
2010-05-13 11:17:21,296 DEBUG Client : ClientNetworking::NetworkingThread() : Networking thread will be terminated due to disconnect exception "An existing connection was forcibly closed by the remote host"


Attachments:
ogre.log [16.05 KiB]
Downloaded 53 times
Top
 Profile  
 
PostPosted: Thu May 13, 2010 3:53 pm 
Offline
Graphics Lead Emeritus
User avatar

Joined: Mon Mar 08, 2004 6:17 pm
Posts: 1938
Location: 52°16'N 10°31'E
The ogre.log seems fine, as expected. The repeating "WaitingForTurnData.TurnProgress" is odd. Could you put freeorion.log and freeoriond.log in a zip file and attach that?


Top
 Profile  
 
PostPosted: Thu May 13, 2010 3:58 pm 
Offline
Krill Swarm

Joined: Thu May 13, 2010 2:46 pm
Posts: 12
Ok here they are.


Attachments:
freeoriond.zip [21.62 KiB]
Downloaded 58 times
freeorion.zip [19.21 KiB]
Downloaded 56 times
Top
 Profile  
 
PostPosted: Thu May 13, 2010 4:23 pm 
Offline
Graphics Lead Emeritus
User avatar

Joined: Mon Mar 08, 2004 6:17 pm
Posts: 1938
Location: 52°16'N 10°31'E
Ok, I'm not quite sure what's going on. The repetition of "WaitingForTurnData.TurnProgress" is happening for all turns, except the very first one in the log - turn 21. It starts with turn 22. Did you do anything at this point outside of freeOrion? Could you also check your firewall? The freeorion executables have to be able to communicate with each other.

Geoff will probably have some more useful input.


Top
 Profile  
 
PostPosted: Thu May 13, 2010 4:32 pm 
Offline
Krill Swarm

Joined: Thu May 13, 2010 2:46 pm
Posts: 12
No, I didn't do anything at all.

Also my firewall has freeorion listed as an exception so its not being blocked.


Top
 Profile  
 
PostPosted: Thu May 13, 2010 4:36 pm 
Offline
Programming, Design, and De Facto Lead
User avatar

Joined: Wed Oct 08, 2003 1:33 am
Posts: 10196
Location: Munich
This may be the same issue as in this bug, the report for which doesn't really give any more information, but is reproducible with the provided save file.

Could you clarify what you mean by "this point" coming at different turns? Do you start new games or load a save from just before it happens?

Could you post a save that is immediately before it happens (ie. load and press turn to crash), or (if possible) a save that's a turn or two before it happens where you have to do something specific with a fleet or planets to make it happen?


Top
 Profile  
 
PostPosted: Thu May 13, 2010 4:41 pm 
Offline
Krill Swarm

Joined: Thu May 13, 2010 2:46 pm
Posts: 12
I mean that it happens in all new games I start but not a specific point, theres nothing I can see from my game play that causes it to happen(no research or building such as that).

I haven't installed any patches if there are any.


Top
 Profile  
 
PostPosted: Thu May 13, 2010 4:44 pm 
Offline
Programming, Design, and De Facto Lead
User avatar

Joined: Wed Oct 08, 2003 1:33 am
Posts: 10196
Location: Munich
Could you start a game with no AIs and 10 stars, and play until it happens, and then post the autosave from the turn before?


Top
 Profile  
 
PostPosted: Thu May 13, 2010 4:45 pm 
Offline
Krill Swarm

Joined: Thu May 13, 2010 2:46 pm
Posts: 12
ok I'll try how do i know where to find the auto save? Will it be at the bottom of one of the logs?


Top
 Profile  
 
PostPosted: Thu May 13, 2010 4:52 pm 
Offline
Graphics Lead Emeritus
User avatar

Joined: Mon Mar 08, 2004 6:17 pm
Posts: 1938
Location: 52°16'N 10°31'E
Autosaves are by default done every turn and are saved in the "save" folder, located in the same directory the logs are in.


Top
 Profile  
 
PostPosted: Thu May 13, 2010 5:03 pm 
Offline
Krill Swarm

Joined: Thu May 13, 2010 2:46 pm
Posts: 12
Tried it and now the game is frozen at "resolving combat" although there is nothing to fight, I'll post saves now

I think I know what the problem is, I just went into a game I was running fine for a long time and tried to make a custom ship(where the one Im posting crashes) I think it has to do with me making custom ships.

Edit#1 I checked and it is when I make a custom ship, first file is when I saved right before it is made.


Attachments:
Kens game.zip [13.58 KiB]
Downloaded 56 times
FreeOrion_Dr_Terran_0212.zip [69.22 KiB]
Downloaded 56 times
Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 24 posts ]  Go to page 1, 2  Next

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group