FreeOrion

Forums for the FreeOrion project
It is currently Fri Dec 15, 2017 2:32 am

All times are UTC


Forum rules


Always mention the exact version of FreeOrion you are testing.

When reporting an issue regarding the AI, if possible provide the relevant AI log file and a save game file that demonstrates the issue.



Post new topic Reply to topic  [ 8 posts ] 
Author Message
 Post subject: Ship
PostPosted: Sat Aug 13, 2016 11:41 am 
Offline
Dyson Forest
User avatar

Joined: Fri Jul 29, 2016 10:12 am
Posts: 232
I have been playing the latest test build.
2016-08-09


OK, something strange happened.
Turn 85
I sent an outpost ship to a system.
It would not let me found an outpost.
The system was greyed out.
I left the system and then came back.
When I came back my outpost ship was
destroyed.
It was destroyed by what the game described as "SHIP"
It had a stealth value of 65.5k
Yes that is correct, no mistake on my part, 65.5 THOUSAND.
The info on the 'ship' was 0 attack 0 structure 0 detection
yet it still destroyed my outpost ship.
Is this normal, or is this a bug?
Afterward it disappeared and was apparently replaced by a large Snowflake.
Weird.
Any help?


Top
 Profile  
 
 Post subject: Re: Ship
PostPosted: Sat Aug 13, 2016 2:35 pm 
Offline
Programmer

Joined: Sun Feb 14, 2016 12:08 am
Posts: 359
The 'SHIP' was not visible to you at all (stealth too high). The 65.5k value is the game's way of saying "we don't know".
I am guessing an Ion Storm was passing near the system, which both increases the stealth and reduces the detection of ships/monsters.


Top
 Profile  
 
 Post subject: Re: Ship
PostPosted: Sat Aug 13, 2016 9:42 pm 
Offline
Release Manager, Design
User avatar

Joined: Wed Nov 16, 2011 12:56 pm
Posts: 4296
Location: Sol III
What dbenage said. Your ship has apparently been destroyed by a space monster it could not detect. The ion storm explanation sounds very plausible, it would also account for why you could not place that outpost (planets stealthed due to the storm).

So no bug, everything works as intended.

That said, we need to replace that 65K stealth value display. This obviously causes confusion. The UI should give some clear indication that you've been attacked by something you could not see, you only know something was there (because it blew you up), but don't know what. So, instead of displaying 65k and zeros, maybe display a "?" or "unknown" or something like that?


Top
 Profile  
 
 Post subject: Re: Ship
PostPosted: Sat Aug 13, 2016 10:52 pm 
Offline
Dyson Forest
User avatar

Joined: Fri Jul 29, 2016 10:12 am
Posts: 232
Vezzra wrote:
So, instead of displaying 65k and zeros, maybe display a "?" or "unknown" or something like that?


I agree. This would have been less confusing than what did happen.

It still seems kind of odd that I couldn't create an outpost.
I understand the game mechanic I just don't agree with it. :)


Top
 Profile  
 
 Post subject: Re: Ship
PostPosted: Sat Aug 13, 2016 11:22 pm 
Offline
Creative Contributor
User avatar

Joined: Fri Jun 28, 2013 11:45 pm
Posts: 3291
I think the "Ship" needs to be called "Unknown Ship" as well, immediately clearer.

_________________
Mat Bowles

Any code or patches in anything posted here is released under the CC and GPL licences in use for the FO project.


Top
 Profile  
 
 Post subject: Re: Ship
PostPosted: Sun Aug 14, 2016 5:20 am 
Offline
Krill Swarm

Joined: Mon Aug 08, 2016 3:24 am
Posts: 10
Vezzra wrote:
That said, we need to replace that 65K stealth value display. This obviously causes confusion. The UI should give some clear indication that you've been attacked by something you could not see, you only know something was there (because it blew you up), but don't know what. So, instead of displaying 65k and zeros, maybe display a "?" or "unknown" or something like that?


I think "?" would be a good choice. It will fit everywhere a number would and its meaning is pretty obvious.


Top
 Profile  
 
 Post subject: Re: Ship
PostPosted: Sun Aug 14, 2016 1:00 pm 
Offline
Programming, Design, Admin
User avatar

Joined: Wed Oct 08, 2003 1:33 am
Posts: 12041
Location: Munich
The problem is not what to display for an unknown value; it is how to tell the client that the value is unknown while still telling the client that there is a ship known to be there.


Top
 Profile  
 
 Post subject: Re: Ship
PostPosted: Sun Aug 14, 2016 8:10 pm 
Offline
Release Manager, Design
User avatar

Joined: Wed Nov 16, 2011 12:56 pm
Posts: 4296
Location: Sol III
Wouldn't defining a specific value (e.g. 65535) as indicator for "unknown" work? Any stat that has this value would display whatever text/symbol we want to use for "unknown" instead of the value itself.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 8 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group