FreeOrion

Forums for the FreeOrion project
It is currently Mon Dec 18, 2017 6:37 pm

All times are UTC


Forum rules


Always mention the exact version of FreeOrion you are testing.

When reporting an issue regarding the AI, if possible provide the relevant AI log file and a save game file that demonstrates the issue.



Post new topic Reply to topic  [ 3 posts ] 
Author Message
 Post subject: Fleet selection/use lag
PostPosted: Mon Oct 31, 2016 6:37 am 
Offline
Creative Contributor
User avatar

Joined: Fri Jun 28, 2013 11:45 pm
Posts: 3295
This is new, I wondered if it was a Fighter specific issue so compile purely from master and am getting the same problem.

When I do anything involving a fleet, selecting it, giving a move order, invade order, etc, the game now lags, and this increases as the game progresses. Sound effect wise simply selecting a fleet containing, eg, 3 ships gives me three overlapping selection effects rather than the one I would expect.

The lag is most noticeable and worst when issuing an invade order, even if I have no fleet window open it can take noticeable time to process the order, I perceive this delay to be worse than it used to be if you had the fleet selected and ordered a large invasion, a delay/lag that was reduced enough to be not-noticeable some time ago.

I'm unsure when this started, fairly sure it wasn't in 0.4.6.

It's not a massive problem at the moment, but it's a shame to have massively reduced lag at the end of the last cycle to now have a different form of lag creeping in, I'm hoping it's easily identifiable and fixed.

_________________
Mat Bowles

Any code or patches in anything posted here is released under the CC and GPL licences in use for the FO project.


Top
 Profile  
 
PostPosted: Sat Nov 05, 2016 8:54 am 
Offline
Creative Contributor
User avatar

Joined: Fri Jun 28, 2013 11:45 pm
Posts: 3295
Update, and I'm assuming this is linked to LGM-Doyle's current chain of backend rendering changes, this only happens when I have the planet sidepanel open with one of my production centres selected, it doesn't happen when no systems are selected or when neutral systems are selected.

If it's an enemy production centre there appears to be a delay but it's nowhere near as bad.

_________________
Mat Bowles

Any code or patches in anything posted here is released under the CC and GPL licences in use for the FO project.


Top
 Profile  
 
PostPosted: Sat Nov 05, 2016 8:47 pm 
Offline
Programmer

Joined: Mon Feb 29, 2016 8:37 pm
Posts: 205
MatGB thanks for the specific report.

I am unable to duplicate the problem, with either the Fighter branch rebased to master or master itself. I don't doubt your observations, I just can't duplicate them.

I'm going to hold off on trying to replicate/fix this until after the changes to list windows including both fleet window and the planet tab (hopefully land). Geoff and I are making progress towards landing that PR and it will make orders of magnitude speedup for the FleetWnd with large numbers of fleets. This might hide the problem by being too fast to notice, which I hope will be good enough.

Otherwise, we can put in some SectionedScopedTimers so that the delay is reported to the log and then I can try to improve it even though the delay is too small for me to notice.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group