FreeOrion

Forums for the FreeOrion project
It is currently Mon Dec 11, 2017 4:53 pm

All times are UTC


Forum rules


Always mention the exact version of FreeOrion you are testing.

When reporting an issue regarding the AI, if possible provide the relevant AI log file and a save game file that demonstrates the issue.



Post new topic Reply to topic  [ 2 posts ] 
Author Message
PostPosted: Tue Nov 22, 2016 8:30 am 
Offline
Krill Swarm

Joined: Fri Nov 11, 2016 9:16 am
Posts: 14
Hello. First of all, I really like the changes to the orbital drydocks. It makes conquests harder and gives the defenders an advantage.

Unfortunately, there is a minor bug involving more than one orbital drydock in a system. If there are two orbital drydocks in a system, but the closer planet has no population, the ships still try to repair there, even if the further planet has a fully functional drydock. I don't fully understand the mechanics at this point. I researched Advanced Damage Control, and the ships only seem to be repaired from that. I get the message:
"On Ephyse I: the Orbital Drydock is abandoned, there is no one left to assist in repairs of the ship Deer."

I ran the game a few more turns (avoiding my ships being repaired by Damage Control techs) and I got it to the point where the drydock at Ephyse I was functioning. I sent the ships to be repaired there, and I got this messge:
"On Ephyse II: the Orbital Drydock completed repairs on the Shale"

I don't understand the mechanics enough to attempt to diagnose anything.

I would attach the save file, but it is too big.

I am running FreeOrion v0.4.6 [build 2016-09-16.49f9123] MSVC 2013 on Windows 10.


Top
 Profile  
 
PostPosted: Tue Nov 22, 2016 10:55 am 
Offline
Programmer

Joined: Mon Feb 29, 2016 8:37 pm
Posts: 203
zarquan,
Thanks for the bug report. I have created an issue on github for this using your own words. Please comment there.

Also in future, if you have a github account, you can create issues directly. You did all of the leg work, checking the forums, listing OS and build version etc. required to produce a perfect bug report.

Thanks again.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group