FreeOrion

Forums for the FreeOrion project
It is currently Sat Nov 18, 2017 9:21 pm

All times are UTC


Forum rules


Always mention the exact version of FreeOrion you are testing.

When reporting an issue regarding the AI, if possible provide the relevant AI log file and a save game file that demonstrates the issue.



Post new topic Reply to topic  [ 3 posts ] 
Author Message
PostPosted: Wed Jun 14, 2017 12:05 am 
Offline
AI Lead, Programmer
User avatar

Joined: Sat Sep 22, 2012 6:25 pm
Posts: 4374
It seems I am now unable to run a multiplayer game with myself set as either moderator or as observer (plus 1 or 2 AIs)-- the game just sits there with the multiplayer setup screen still showing, and does nothing. I am not seeing anything helpful in the logs (just some seemingly fairly typical lines about invalid TurnProgress event for current state of FSM). I tried a number of different commits, going back about a month in the code, to commit 622177367912b9dd982119511d0110815fd8126c, but still the same problem. Starting a single player game or a multiplayer game with me as a regular player works fine.

Before putting more time into looking into this or opening an issue I wanted to see if anyone else has the same trouble.

_________________
If I provided any code, scripts or other content here, it's released under GPL 2.0 and CC-BY-SA 3.0


Top
 Profile  
 
PostPosted: Wed Jun 14, 2017 6:21 am 
Offline
Programming, Design, Admin
User avatar

Joined: Wed Oct 08, 2003 1:33 am
Posts: 12013
Location: Munich
Looks like part of the code in NewGameInitVerifyJoiners

https://github.com/freeorion/freeorion/ ... p.cpp#L732

assumes no non-empire-controlling player types, or at least that the host controls an empire?

Code:
08:17:53.924919 [error] server : ServerApp.cpp:754 : ServerApp::NewSPGameInit skipping unsupported client type in player setup data
08:18:40.770645 [error] server : ServerApp.cpp:766 : NewGameInitVerifyJoiners : Host id 1 is not a valid player id.


Maybe related to https://github.com/freeorion/freeorion/ ... daa98660d1

Edit: https://github.com/freeorion/freeorion/ ... d7a3d681f2 hopefully resolves it, at least temporarily. A more careful reconsideration of the relevant checks might be good.


Top
 Profile  
 
PostPosted: Wed Jun 14, 2017 9:03 pm 
Offline
Programmer

Joined: Mon Feb 29, 2016 8:37 pm
Posts: 198
That is my bug.

I never tested the case of a non-empire controlling host.

Thanks for fixing it.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group