FreeOrion

Forums for the FreeOrion project
It is currently Fri Dec 15, 2017 4:14 am

All times are UTC


Forum rules


Always mention the exact version of FreeOrion you are testing.

When reporting an issue regarding the AI, if possible provide the relevant AI log file and a save game file that demonstrates the issue.



Post new topic Reply to topic  [ 3 posts ] 
Author Message
PostPosted: Thu Nov 23, 2017 10:15 pm 
Offline
Space Dragon
User avatar

Joined: Mon Apr 10, 2017 4:25 pm
Posts: 254
Hi,

I think there is something wrong (efficiency-wise) in the calculation of the values that the "Planet suitability" pedia entry shows for a planet.

Often, when I click to open such entries (to check the expected populations of each of my species for a given planet) my system freezes for 2-3 secs (sometimes more) before opening that window. If then I close and open it again it responds immediately as normal. It may be that only new planets which I haven't checked before clog the system, but I would say that some of the times when this freezing happened it happened in a planet that had checked before (although new growth techs had been researched since first check). Checking a planet for first time not necessariry clogs the system.

This kind of short-time freezes are not that rare in many applications, and FO have me used to it too. But usually it happens when passing a turn and because of the serialization and saving in the background. I'm reporting this because for the past few weeks I only see these freezings when opening the mentioned pedia entry.

IMO this is a minor issue, not game-breaking at all, which requires no attention at the moment.

However, does this happen to anyone else or is it my own system and configuration the cause?


Top
 Profile  
 
PostPosted: Thu Nov 23, 2017 10:30 pm 
Offline
Space Squid
User avatar

Joined: Sun Nov 19, 2017 6:32 pm
Posts: 86
My suitability panel opens quite snappily.


Top
 Profile  
 
PostPosted: Fri Nov 24, 2017 2:07 am 
Offline
Programmer

Joined: Sun Feb 14, 2016 12:08 am
Posts: 359
I've noticed a delay recently as well, though maybe not as long.
I prepped a branch to improve readability with some performance improvement (pending resolution of more immediate bug fix), probably the largest gain is reduction in calls to ExpensiveParseFromTextToTextElements.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC


Who is online

Users browsing this forum: AhrefsBot and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group