FreeOrion

Forums for the FreeOrion project
It is currently Thu May 24, 2018 10:21 am

All times are UTC


Forum rules


Always mention the exact version of FreeOrion you are testing.

When reporting an issue regarding the AI, if possible provide the relevant AI log file and a save game file that demonstrates the issue.



Post new topic Reply to topic  [ 10 posts ] 
Author Message
PostPosted: Sun Jan 14, 2018 1:41 am 
Offline
Space Krill

Joined: Sun Jan 15, 2017 3:21 pm
Posts: 6
Location: USA
I have a problem with saving games.

I played the latest build (FreeOrion v0.4.7+ [Build 2018-01-09.4b45d52]). After I resigned the first game (without closing the program) and started a new game, I found that the game could not be saved either manually or automatically. Therefore, I cannot provide any save game file or autosaves for you. :(

If you want to learn more about the problem, feel free to instruct me to get the information you want. Sorry, I am not an expert programmer, so I don't know about underlying issues about this problem.

Best,
Goddog

ps. I am playing a game about Egassem vs Monsters with no AI and native to put Egassem to the most difficult situation. If this problem was solved, I would consider writing a review of that game. :D


Top
 Profile  
 
PostPosted: Sun Jan 14, 2018 11:13 am 
Offline
Release Manager, Design
User avatar

Joined: Wed Nov 16, 2011 12:56 pm
Posts: 4486
Location: Sol III
We need a bit more specifics to be able to help:

First, some information about your system would be appreciated: OS, hardware specs?

Also, can you be a bit more specific about the not being able to save thing? What exactly happens when you try to save a game? Do you get error messages, or does the game seem to save, but no savegame file gets created, or are you unable to load the savegames?

Does the issue also occur with earlier test builds? Which test build introduced the issue?


Top
 Profile  
 
PostPosted: Sun Jan 14, 2018 7:22 pm 
Offline
Space Krill

Joined: Sun Jan 15, 2017 3:21 pm
Posts: 6
Location: USA
Here is more detail about OS, hardware, and the problem itself.

OS:
System: Windows 10 Home Single Language
Version: 1709
OS Build: 16299.192)


Hardware specification:
Model: Dell Vostro 5468
Processor: Intel(R) Core(TM) i5-7200U CPU @ 2.50Ghz 2.70GHz
RAM: 4.00 GB
System Type: 64-but operating system, x64-based processor
Disk Space: 918 GB (used 161 GB)

Game Test Build: 2018-01-09.4b45d52 (Windows version on sourceforge)

More problem detail:
First, I tried to save a game on turn 177. I named it "EvN2_Turn177_Test_Saving"
Image

but nothing happened
Image

Savegame file was not shown when I look at the savegame folder.
Image

It was not shown in file explorer either. Note that I saved the game on Jan 13, 2018 at about 20:20:00 which was after the newest savegame shown in the folder.
Image

Similarly, no autosave was created.
Image
Image

Here was autosave configuration.
Image

Right now I am trying to reproduce this situation on this build as well as the earlier test build. I will update if I get more information.

Best,
Goddog


Top
 Profile  
 
PostPosted: Sun Jan 14, 2018 7:50 pm 
Offline
Programming, Design, Admin
User avatar

Joined: Wed Oct 08, 2003 1:33 am
Posts: 12188
Location: Munich
In the folder that contains the save folder you showed screenshots of, there should be .log files. Please reproduce the issues, then immediately after failing to save, zip all those log files and post them in a reply.


Top
 Profile  
 
PostPosted: Sun Jan 14, 2018 10:45 pm 
Offline
Programmer

Joined: Sun Feb 14, 2016 12:08 am
Posts: 389
So just had this issue or something similar. Seems HumanClientApp::m_game_saves_in_progress is preventing further saves from being attempted.
Still looking through it, but not sure where all it should be cleared/reset yet (or why I don't find any error/warnings for a previously failed save).


Top
 Profile  
 
PostPosted: Mon Jan 15, 2018 1:50 am 
Offline
Programmer

Joined: Sun Feb 14, 2016 12:08 am
Posts: 389
Finally found a semi-reliable way to reproduce (start game with 20+ AI, exit during save, cancel dialog).
Posted logs into #1944, accompanied with a potential fix.


Top
 Profile  
 
PostPosted: Fri Jan 19, 2018 1:01 am 
Offline
Vacuum Dragon

Joined: Wed Aug 26, 2015 6:15 pm
Posts: 536
This sounds similar to what I was experiencing:

http://www.freeorion.org/forum/viewtopic.php?f=28&t=10828

I still have it happening, and I believe that the "second game" condition is usually what I see as well.


Top
 Profile  
 
PostPosted: Sat Feb 03, 2018 12:20 am 
Offline
Vacuum Dragon

Joined: Wed Aug 26, 2015 6:15 pm
Posts: 536
In a game the other day, auto-save was working fine initially. Then at about 290 turns or so it stopped.


Top
 Profile  
 
PostPosted: Sat Feb 03, 2018 9:21 am 
Offline
Programming, Design, Admin
User avatar

Joined: Wed Oct 08, 2003 1:33 am
Posts: 12188
Location: Munich
defaultuser wrote:
In a game the other day, auto-save was working fine initially. Then at about 290 turns or so it stopped.
Autosave specifically, or all saves? If the latter, switch to binary save files. Especially if that doesn't work, but probably in general if reporting an issue, post the .log files from immediately after having the problem. Also, be more specific than "it stopped [working]".


Top
 Profile  
 
PostPosted: Sat Feb 03, 2018 10:52 pm 
Offline
Vacuum Dragon

Joined: Wed Aug 26, 2015 6:15 pm
Posts: 536
All saves. My current game is showing the same, the last auto-save was turn 281, I'm on 359. There's not really any further problem description. No error messages on the console, no save files. With this latest permutation, it's not easy to grab logs because unless I check every turn I won't know when it starts.

Most of the trouble-shooting, including binary save, was tried in the previous thread:

viewtopic.php?f=28&t=10828


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 10 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group