FreeOrion

Forums for the FreeOrion project
It is currently Tue May 22, 2018 6:14 am

All times are UTC


Forum rules


Always mention the exact version of FreeOrion you are testing.

When reporting an issue regarding the AI, if possible provide the relevant AI log file and a save game file that demonstrates the issue.



Post new topic Reply to topic  [ 4 posts ] 
Author Message
PostPosted: Fri Jan 19, 2018 5:41 pm 
Offline
Vacuum Dragon
User avatar

Joined: Mon Apr 10, 2017 4:25 pm
Posts: 512
Playing compiled version from github, with tweaks to self-containment and subterranean habitation techs performed "by hand" with no git use (I have no idea yet of how to commit changes, manage branches, etc.).
Version: Not sure if this is it:
~/FreeOrion/freeorion$ git rev-parse HEAD
5266024dd56ac679ec6f7d091cdd6b9ae1d583a6
OS: Ubuntu 16.04.

I was playing a new game (has loaded previous saves two times during the game session, last one around turn 50).
In turn 81 I saw an enemy outpost ship went missing in one of my systems (Godel alpha). Due to freezed FO after taking screenshot, I have to restart FO.
I loaded turn 80 save, clicked next turn and saw how the outpost ship stoped in Godel Alpha and then disappeared.
I attach screenshots, saved games and logs. Saved games are from before the screenshot freezing, logs are from turn 81 after having loaded turn 80 and clicked next turn.


Attachments:
ship_went_missing_no_sitrep.zip [4.06 MiB]
Downloaded 6 times
Top
 Profile  
 
PostPosted: Thu Feb 01, 2018 1:09 pm 
Offline
Release Manager, Design
User avatar

Joined: Wed Nov 16, 2011 12:56 pm
Posts: 4484
Location: Sol III
I haven't been around much recently, so if there has already been (or still is) an issue and/or fix on github dealing with this I haven't noticed yet. However, if there hasn't been any issue opened or fix, can you open an issue on github?


Top
 Profile  
 
PostPosted: Thu Feb 01, 2018 3:54 pm 
Offline
Vacuum Dragon
User avatar

Joined: Mon Apr 10, 2017 4:25 pm
Posts: 512
I was about to submit the issue, right now, when I realised that ship could have been a flux bubble outpost that once got into the system became undetectable. Well, most probably it was a flux bubble. Can't load that game to check it.
This is related to another missing sitrep I saw a week earlier, involving a warship (that could not be a flux bubble hull, but I couldn't tell if that was some weird spatial flux armed ship) getting to one of my systems, but back then I confused the save files when reporting it here in the forum and could not reproduce it.

So lets forget about this unless it happens again and after double-checking that it's not a ship going invisible after arrival.


Related: Would it be reasonable to ask for a sitrep when an enemy ship goes invisible in an owned empire? or to leave a ghost icon in place?
Edit: I meant "in an owned system".


Last edited by Oberlus on Thu Feb 01, 2018 4:44 pm, edited 1 time in total.

Top
 Profile  
 
PostPosted: Thu Feb 01, 2018 4:26 pm 
Offline
Release Manager, Design
User avatar

Joined: Wed Nov 16, 2011 12:56 pm
Posts: 4484
Location: Sol III
Oberlus wrote:
Related: Would it be reasonable to ask for a sitrep when an enemy ship goes invisible in an owned empire? or to leave a ghost icon in place?
I been wondering about that myself already. IMO such a sitrep actually would make sense... at least I would like to get a notice if something I could detect suddenly vanishes (and not because it moved out of my detection range).


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group