Search found 390 matches

by o01eg
Fri Jun 14, 2019 8:52 am
Forum: General Discussion
Topic: Multiplayer slow game server
Replies: 257
Views: 5343

Re: Multiplayer slow game server

Could you apply https://github.com/freeorion/freeorion/pull/2477 and https://github.com/freeorion/freeorion/pull/2478, enable trace log, and try to login again? Result is here: 10:26:17.681200 {0x00004744} [debug] client : techtreewnd.cpp:1914 : Tech List Box Populating Done, Creation time = 631ms ...
by o01eg
Thu Jun 13, 2019 7:53 pm
Forum: General Discussion
Topic: Multiplayer slow game server
Replies: 257
Views: 5343

Re: Multiplayer slow game server

The Silent One wrote:
Thu Jun 13, 2019 9:15 am
Did you create new designs for this game? It looks like you get exception in the design window.
Definitely, no.
Could you apply https://github.com/freeorion/freeorion/pull/2477 and https://github.com/freeorion/freeorion/pull/2478, enable trace log, and try to login again?
by o01eg
Thu Jun 13, 2019 9:07 am
Forum: General Discussion
Topic: Multiplayer slow game server
Replies: 257
Views: 5343

Re: Multiplayer slow game server

Could you also try to enable trace log? Here is the last couple of lines from the log (log itself is ~80mb): 10:52:47.570459 [debug] client : TechTreeWnd.cpp:1427 : Tech Tree Layout Done 10:52:47.570459 [debug] client : TechTreeWnd.cpp:1899 : Tech List Box Populating 10:52:48.190018 [debug] client ...
by o01eg
Thu Jun 13, 2019 6:55 am
Forum: General Discussion
Topic: Multiplayer slow game server
Replies: 257
Views: 5343

Re: Multiplayer slow game server

The Silent One wrote:
Mon Jun 03, 2019 6:05 am
When logging in into multiplayer, I see the lobby window, then the game crashes. Don't have an idea what's going on, log is attached.
Could you also try to enable trace log?
by o01eg
Thu Jun 13, 2019 6:18 am
Forum: General Discussion
Topic: Multiplayer slow game server
Replies: 257
Views: 5343

Re: Multiplayer slow game server

I've been using bbb72e1 since it came out with no problems, but tonight I have an error: "Server cannot properly read messages from your client, most likely due to incompatible game versions." I've got this error in log: 2019-06-12 21:06:34.862501 [trace] network : ServerNetworking.cpp:301 : Server...
by o01eg
Thu Jun 13, 2019 4:30 am
Forum: General Discussion
Topic: Multiplayer slow game server
Replies: 257
Views: 5343

Re: Multiplayer slow game server

Magnate wrote:
Wed Jun 12, 2019 9:21 pm
Ah ok - is that as in stopped permanently, or paused pending fixes?
The game was fully disclosed so I'll start new game. The server is open to catch bugs.
by o01eg
Tue Jun 11, 2019 7:06 pm
Forum: General Discussion
Topic: Multiplayer slow game server
Replies: 257
Views: 5343

Re: Multiplayer slow game server

..., what could The Silent One or I do to help hunt down this issuing orders bug? I'm really sorry I haven't been more help yet to hunt down this bug; I probably will have some time on thursday, then I could try to use the MSCV debugger. Beware though that I have little to no experience with that. ...
by o01eg
Tue Jun 11, 2019 3:13 pm
Forum: General Discussion
Topic: Multiplayer slow game server
Replies: 257
Views: 5343

Re: Multiplayer slow game server

The game FO0001 ceased. The server is still running, and I've opened server so anyone could connect to the server and try to catch bug. The server asks for password but accepts any string. Players name are: Magnate o01eg Oberlus TheSilentOne I've also attached save files of last turns. I will say wh...
by o01eg
Tue Jun 11, 2019 6:30 am
Forum: General Discussion
Topic: Multiplayer slow game server
Replies: 257
Views: 5343

Re: Multiplayer slow game server

Following is, maybe, the first catch from ExtractGameStartMessageData. I can't assure it because it throws dozens of exceptions from start, all from libstdc++.so.6, and at some point I stopped calling bt after continuing, just hitting up arrow and return as if I was playing Bubble Bubble. And this ...
by o01eg
Tue Jun 11, 2019 3:43 am
Forum: General Discussion
Topic: Multiplayer slow game server
Replies: 257
Views: 5343

Re: Multiplayer slow game server

I attach the log with the changes you said. It's heavy. The catch throw, I dunno if I did it right: I first did run, then the catch throw (that said something about "catch 1" and nothing else) and then continue (which crashed the program). I've anticipated it fails on orders but it looks like there...
by o01eg
Mon Jun 10, 2019 5:14 pm
Forum: General Discussion
Topic: Multiplayer slow game server
Replies: 257
Views: 5343

Re: Multiplayer slow game server

Oberlus wrote:
Mon Jun 10, 2019 5:05 pm
o01eg wrote:
Mon Jun 10, 2019 4:55 pm
enable trace for logging.execs.client?
How do I do that?
I'll try later, I'm leaving now.
fo.png
fo.png (289.74 KiB) Viewed 205 times
by o01eg
Mon Jun 10, 2019 4:55 pm
Forum: General Discussion
Topic: Multiplayer slow game server
Replies: 257
Views: 5343

Re: Multiplayer slow game server

Could you also apply https://github.com/freeorion/freeorion/pull/2472 and enable trace for logging.execs.client?
by o01eg
Mon Jun 10, 2019 4:15 pm
Forum: General Discussion
Topic: Multiplayer slow game server
Replies: 257
Views: 5343

Re: Multiplayer slow game server

Yes, it helpful. Could you enter gdb command catch throw and find source of this rethrowed exception?
I suppose it could be caused boost.serialize incompatibility between versions.
by o01eg
Mon Jun 10, 2019 12:05 pm
Forum: General Discussion
Topic: Multiplayer slow game server
Replies: 257
Views: 5343

Re: Multiplayer slow game server

It looks strange. What cmake version you use? freeorion$ cmake --version cmake version 3.5.1 Also, now I can't compile. After having use "-DCMAKE_BUILD_TYPE=Debug", that variable is set to Debug even if I don't write it, and using "-DCMAKE_BUILD_TYPE=Release" (should it be Test or something else?) ...
by o01eg
Mon Jun 10, 2019 11:46 am
Forum: General Discussion
Topic: Multiplayer slow game server
Replies: 257
Views: 5343

Re: Multiplayer slow game server

It looks strange. What cmake version you use? freeorion$ cmake --version cmake version 3.5.1 Also, now I can't compile. After having use "-DCMAKE_BUILD_TYPE=Debug", that variable is set to Debug even if I don't write it, and using "-DCMAKE_BUILD_TYPE=Release" (should it be Test or something else?) ...