Search found 344 matches

by kroddn
Tue May 26, 2009 8:04 pm
Forum: Programming
Topic: Statically linked Linux-version
Replies: 111
Views: 84540

Re: Statically linked Linux-version

Release V0.3.13 positive feedbacks:
  • Vector Linux 6.0 (Slackware 12.2-based), 32-bit, nVidia 8600GT with 185.25 drivers.
by kroddn
Tue May 26, 2009 11:16 am
Forum: Support
Topic: Problems running on Ubuntu 9.04
Replies: 35
Views: 4750

Re: Problems running on Ubuntu 9.04

I released a new version of FreeOrion, which now has that Ogre stuff linked in statically. I tested it on a Ubuntu 9.04 chroot.

Please let me know if v0.3.13 Linux runs successfully on Ubuntu 9.04 systems:

https://sourceforge.net/project/showfil ... _id=111134
by kroddn
Mon May 25, 2009 10:20 pm
Forum: Support
Topic: Problems running on Ubuntu 9.04
Replies: 35
Views: 4750

Re: Problems running on Ubuntu 9.04

OndrejR is right. Of course, you need ati drivers that support open GL for an ATI card instead of that nvidia stuff.

But ATI cards are known to make problems - we cannot say, which ATI cards are working for now - if somebody is able to run FreeOrion with an ATI card, please report that!
by kroddn
Wed May 20, 2009 4:39 pm
Forum: Support
Topic: Problems running on Ubuntu 9.04
Replies: 35
Views: 4750

Re: Problems running on Ubuntu 9.04

I compiled a version ONLY FOR Ubuntu 9.04 - please try out that: http://freeorion.psitronic.de/download/ (choose the latest ubuntu version) When trying out, it is possible that some libraries are missing - these have to be installed with Ubuntu packet manager or with apt: As far as i remember, those...
by kroddn
Fri May 15, 2009 4:02 pm
Forum: Support
Topic: Help
Replies: 8
Views: 1007

Re: Help

Your graphic card does not support openGL 2.0. That's the reason FreeOrion is not working.
by kroddn
Thu May 07, 2009 5:37 pm
Forum: Support
Topic: Problems running on Ubuntu 9.04
Replies: 35
Views: 4750

Re: Problems running on Ubuntu 9.04

That does not matter, links can fallow a very long path to the target.
by kroddn
Thu May 07, 2009 12:22 pm
Forum: Support
Topic: Problems running on Ubuntu 9.04
Replies: 35
Views: 4750

Re: Problems running on Ubuntu 9.04

I installed a ubuntu chroot now - and I also installed nvidia drivers. But one thing is strange: the openGL libs are NOT from nvidia. Maybe that's a problem. Please do: dpkg -S /usr/lib/libGL.so And vdir /usr/lib/libGL.so On my Lenny system: /usr/lib/libGL.so.1 -> libGL.so.180.51 This means, my open...
by kroddn
Thu May 07, 2009 11:46 am
Forum: Support
Topic: Ogre assert on startup, linux static rev3009.
Replies: 3
Views: 928

Re: Ogre assert on startup, linux static rev3009.

The problem is discussed in this thread:
viewtopic.php?f=25&t=2651

Currenctly, I am am not able to fix this problem, as I don't know what is causing it.
by kroddn
Wed May 06, 2009 9:41 pm
Forum: Support
Topic: Problems compiling freeorion on FreeBSD
Replies: 56
Views: 7087

Re: Problems compiling freeorion on FreeBSD 7

libGiGiOgrePlugin_OIS.so is part of gigi.
by kroddn
Wed May 06, 2009 1:44 pm
Forum: Support
Topic: Problems running on Ubuntu 9.04
Replies: 35
Views: 4750

Re: Problems running on Ubuntu 9.04

The linux-version of FreeOrion supports a parameter "--strace". This can be used to create an strace. Call it like this $HOME/freeorion/freeorion --strace I then creats a logfile in /tmp/freeorion.trace - this file can be uploaded here. Of course the programm "strace" needs to be installed on the sy...
by kroddn
Mon May 04, 2009 10:10 pm
Forum: Support
Topic: Problems running on Ubuntu 9.04
Replies: 35
Views: 4750

Re: Problems running on Ubuntu 9.04

Seems that I could fix this problem... but I am not able to test functionality, for I have no openGL 2.0 support on my ubuntu 9.04 virtual machine. I linked libOgreMain into the freeorion binary statically. This does not affect the ogre modules used by GiGi at all, but the error does not appear. Som...
by kroddn
Mon May 04, 2009 5:57 pm
Forum: Support
Topic: Problems running on Ubuntu 9.04
Replies: 35
Views: 4750

Re: Problems running on Ubuntu 9.04

I cannot ship X11, because it differs from system to system. If I would do that, I could create a complete distribution for FreeOrion :-)

I don't want to do this work all again on an ubuntu system. There must be another solution... one is to build Ogre statically.
by kroddn
Mon May 04, 2009 2:33 pm
Forum: Support
Topic: Problems running on Ubuntu 9.04
Replies: 35
Views: 4750

Re: Problems running on Ubuntu 9.04

I now was able to reproduce this error on an ubuntu virtual machine. The problem is as fallows: The library "libOgreMain-1.6.2.so" in freeorion needs a function _xcb_lock_io, which is delivered in lib libxcb.so.1 from Debian Lenny. I ship this lib with FreeOrion in the application/lib directory. But...
by kroddn
Fri Apr 24, 2009 10:05 am
Forum: FreeOrion Project
Topic: Is a portable version of FreeOrion in the works?
Replies: 7
Views: 2781

Re: Is a portable version of FreeOrion in the works?

I'll try installing it on a USB key. I definitely can't install it on a Windows PC where I don't have administrator privileges, so a standalone .exe or a portableapp.com installer would still be a great idea for the future. Why aren't you able to install it without admin privs? Did you test that? I...
by kroddn
Thu Apr 23, 2009 9:35 pm
Forum: Support
Topic: Problems running on Ubuntu 9.04
Replies: 35
Views: 4750

Re: Intel 965GM on Linux

Thats not sufficient ;-) Change into the "application" directory, as done bore and do: export LD_LIBRARY_PATH=./lib ldd ./freeorion And please execute: ldd /usr/lib32/libX11.so.6 It seems to me that an update of a lib removed a function which is needed by freeorion... or Ubuntu 9.04 introduced a bug...