Search found 344 matches

by kroddn
Tue Mar 24, 2009 9:22 am
Forum: Support
Topic: FreeOrion SegFaults -- New and Improved!
Replies: 9
Views: 1374

Re: FreeOrion SegFaults -- New and Improved!

Does the latest statically linked version run? https://sourceforge.net/project/showfiles.php?group_id=75752&package_id=111134&release_id=660507 Can you append your ogre.log? /Edit: Maybe I didn't make clear. I did not solve this problem when it occured in my version - I just did a clean build of eve...
by kroddn
Mon Mar 23, 2009 9:10 pm
Forum: General Discussion
Topic: freeorion RPM-packages
Replies: 18
Views: 7859

Re: freeorion RPM-packages

See http://www.freeorion.org/index.php/Compile#Tarballs * FreeOrion v0.3.12 for Windows is SVN revision 2807: http://freeorion.svn.sourceforge.net/viewvc/freeorion/trunk/?pathrev=2807 with GiGi revision 710 http://gigi.svn.sourceforge.net/viewvc/gigi/?pathrev=710 * FreeOrion v0.3.12.1 for Linux is S...
by kroddn
Mon Mar 23, 2009 8:34 pm
Forum: Support
Topic: FreeOrion SegFaults -- New and Improved!
Replies: 9
Views: 1374

Re: FreeOrion SegFaults -- New and Improved!

So, then do (in both GG and FreeOrion main dir)

Code: Select all

scons --clean
scons --config=force configure
scons
sudo scons install
by kroddn
Mon Mar 23, 2009 6:13 pm
Forum: Support
Topic: FreeOrion SegFaults -- New and Improved!
Replies: 9
Views: 1374

Re: FreeOrion SegFaults -- New and Improved!

IConrad wrote:
kroddn wrote:Do NOT use CPPFLAGS=-DOGRE_STATIC_LIB in Ogre or FreeOrion.
Okay, I'll bite -- how would I go about this?
I used those parameters once to support static linking of ogre modules - and that leaded to errors.
by kroddn
Mon Mar 23, 2009 7:51 am
Forum: Support
Topic: FreeOrion SegFaults -- New and Improved!
Replies: 9
Views: 1374

Re: FreeOrion SegFaults -- New and Improved!

I had this error some time ago and thought I had posted about it - but now I cannot find any thread about it...

The problem was a temporary one - my solution was: do a clean build on Ogre, GG and FreeOrion.
Do NOT use CPPFLAGS=-DOGRE_STATIC_LIB in Ogre or FreeOrion.
by kroddn
Fri Mar 20, 2009 5:43 pm
Forum: Support
Topic: libGiGiOgre segmentation fault
Replies: 8
Views: 1231

Re: libGiGiOgre segmentation fault

I said "as far as I remember"... I did not know that this code is located at GG, I thought it was Ogre itself. I wonder why my current version does not have debugging symbols in GiGiOgre... /Edit: and as I stated in another thread, I am not able to debug effectively, because FreeOrion fetches the mo...
by kroddn
Fri Mar 20, 2009 5:38 pm
Forum: Programming
Topic: Statically linked Linux-version
Replies: 111
Views: 87092

Re: Statically linked Linux-version

It's already up there (since march 17th).
by kroddn
Fri Mar 20, 2009 5:22 pm
Forum: Support
Topic: libGiGiOgre segmentation fault
Replies: 8
Views: 1231

Re: libGiGiOgre segmentation fault

The crash happens INDISE OgreGUI::Enter2DMode(). Those openGL calls are never executed at all.
by kroddn
Fri Mar 20, 2009 7:23 am
Forum: Support
Topic: libGiGiOgre segmentation fault
Replies: 8
Views: 1231

Re: libGiGiOgre segmentation fault

As far as I remember the line in GG::OgreGUI::Enter2DMode () calls OGRE::Enter2DMode(). To deeper debug the problem a debug version of Ogre is needed at that point.
by kroddn
Wed Mar 18, 2009 1:27 pm
Forum: Compile
Topic: TechTreeWnd.cpp: 'ND_coord_i' was not declared in this scope
Replies: 14
Views: 3517

Re: TechTreeWnd.cpp: 'ND_coord_i' was not declared in this scope

You may also try to deactivate loading of that plugin by commenting out or deleting that line in ogre_plugins.cfg. The nvidia toolkit can be downlaoded here: http://developer.nvidia.com/object/cg_toolkit.html After that, you MUST recompile and install OGRE. You may also just wan't to try the FreeOri...
by kroddn
Tue Mar 17, 2009 9:24 pm
Forum: Compile
Topic: TechTreeWnd.cpp: 'ND_coord_i' was not declared in this scope
Replies: 14
Views: 3517

Re: TechTreeWnd.cpp: 'ND_coord_i' was not declared in this scope

Of course thats the problem ;-)

Delete this line and do again a "scons configure", scons and scons install.

Nevertheless, if GiGi has compiled without errors, doing "export LD_LIBRARY_PATH=GG" should work. Those GiGi libs should be in GG.
by kroddn
Tue Mar 17, 2009 8:51 pm
Forum: Compile
Topic: TechTreeWnd.cpp: 'ND_coord_i' was not declared in this scope
Replies: 14
Views: 3517

Re: TechTreeWnd.cpp: 'ND_coord_i' was not declared in this scope

/freeorion: error while loading shared libraries: libGiGiOgre.so: cannot open shared object file: No such file or directory Maybe after compiling GiGiOgre you forgot to install it. Change into directory GG and do "scons install" or do the following: export LD_LIBRARY_PATH=GG ./freeorion This means ...
by kroddn
Mon Mar 16, 2009 11:50 pm
Forum: Support
Topic: Plugin_CgProgramManager needed?
Replies: 10
Views: 1447

Re: Plugin_CgProgramManager needed?

I'll compile a debug version of OGRE to debug the problem in detail. For now, I only know that it crashes when executing OgreGUI::Enter2DMode() in HumanClientApp::Enter2DMode() - the debugger was not able to debug into the ogre code.
by kroddn
Mon Mar 16, 2009 11:00 pm
Forum: Support
Topic: Plugin_CgProgramManager needed?
Replies: 10
Views: 1447

Re: Plugin_CgProgramManager needed?

Are you sure that ogre demos even make usage of this plugin?
by kroddn
Mon Mar 16, 2009 6:24 pm
Forum: Support
Topic: FreeOrion|linux grabs mouse focus - how to release?
Replies: 6
Views: 1046

Re: FreeOrion|linux grabs mouse focus - how to release?

It works. Should me mentioned somewhere INSIDE the tech-demo.

What is the techdemo supposed to do? It just keeps my cpu at 100%, but nothing moves there...

I must admit that "normal" users won't run the techdemo.