Search found 34 matches

by obgr_seneca
Tue Dec 16, 2008 9:19 pm
Forum: Compile
Topic: Scons can't find boost serialization
Replies: 81
Views: 16333

Re: Scons can't find boost serialization

This error don't affect GiGi and is known. You can install it with command: scons install I can't because rpmbuild won't let me. I have to use scons configure scons and then install it manually file by file, because GiGi's installation-routine seems not to support installing into a buildroot direct...
by obgr_seneca
Tue Dec 16, 2008 6:17 pm
Forum: Compile
Topic: Scons can't find boost serialization
Replies: 81
Views: 16333

Re: Scons can't find boost serialization

I'm having a similar problem. After trying some fixes for other things (thanks to Zach), I gave up, cause I was running out of time... Now I tried again, I built boost-1.37.0, since 1.36.0 didn't work for me, now I'm getting the following error message: /usr/include/boost/serialization/access.hpp:10...
by obgr_seneca
Tue Oct 28, 2008 11:55 am
Forum: Compile
Topic: free orion and gigi wont compile with boost 1.36
Replies: 3
Views: 1272

Re: free orion and gigi wont compile with boost 1.36

unfortuantly from older posts i read it seems the devs prefare to use their libs, instead of trying to install newer onec on their comp and adapt :/ Yes, that's unfortunate. But when you are trying to build packages for a distro, providing new versions of those libs (like Mandriva) you don't have m...
by obgr_seneca
Tue Oct 28, 2008 11:31 am
Forum: Compile
Topic: free orion and gigi wont compile with boost 1.36
Replies: 3
Views: 1272

Re: free orion and gigi wont compile with boost 1.36

Thanks for the patch, that helped one step further. But now I have another problem. There seems to be an incompatibility with devil-version 1.7.1...
But that's another matter...

Oliver
by obgr_seneca
Mon Jul 14, 2008 9:20 pm
Forum: General Discussion
Topic: freeorion RPM-packages
Replies: 18
Views: 8000

Re: freeorion RPM-packages

New packages available. svn-Revision 2642 for Mandrivalinux2008.1. gigi and boost packages in the latest versions are also on the server. Momentarily only x86_64-packages are online, i586 should follow in the next few days. The packages can be found on the mandrivauser.de-ftp-Server ftp://ftp.mandri...
by obgr_seneca
Mon Jul 14, 2008 5:42 pm
Forum: Compile
Topic: Problem to compil freeorion with boost 1.35
Replies: 12
Views: 3294

Re: Problem to compil freeorion with boost 1.35

It's working now.

Thanks!

Oliver
by obgr_seneca
Mon Jul 14, 2008 12:39 pm
Forum: Compile
Topic: Problem to compil freeorion with boost 1.35
Replies: 12
Views: 3294

Re: Problem to compil freeorion with boost 1.35

Using gcc4.3 does seem to create other problems: + scons configure prefix=/usr CC=gcc4.3 CXX=g++4.3 scons: Reading SConscript files ... Configuring for POSIX system... Checking for Py_Initialize() in C library python2.5... yes Checking for pkg-config... yes Checking for GiGiSDL >= 0.6.0... yes Check...
by obgr_seneca
Mon Jul 14, 2008 10:23 am
Forum: Compile
Topic: Problem to compil freeorion with boost 1.35
Replies: 12
Views: 3294

Re: Problem to compil freeorion with boost 1.35

kroddn wrote: Using gcc 4.3.1 Compilation is successful.
How did you get scons to use gcc4.3?

Oliver
by obgr_seneca
Mon Apr 21, 2008 3:52 pm
Forum: Compile
Topic: Problems Compiling freeorion (from svn)
Replies: 27
Views: 6428

Re: Problems Compiling freeorion (from svn)

By the way, using the above patch it's compiling and working with graphviz-2.16.1, rpm-packages of revision 2511 will be available on the mandrivauser.de ftp server tomorrow for Mandriva-2008.1

Oliver
by obgr_seneca
Mon Apr 21, 2008 9:00 am
Forum: Compile
Topic: Problems Compiling freeorion (from svn)
Replies: 27
Views: 6428

Re: Problems Compiling freeorion (from svn)

In short, graphviz changes a lot, and you should only use the version known to work with FO (as indicated in build_config.py). If you change your graphviz version to something else, you're on your own. What a remarkable opinion... Is there any distro that is going to keep old versions of graphviz b...
by obgr_seneca
Wed Apr 02, 2008 7:09 pm
Forum: Compile
Topic: new revisions won't compile
Replies: 2
Views: 1085

Re: new revisions won't compile

Thanks, you solved it...
The problem were missing read-permissions form the .h-Files in include/GG/
I have to rebuild the GG-rpm I built, changing the permissions and all should be well...

Oliver
by obgr_seneca
Wed Apr 02, 2008 12:36 pm
Forum: Compile
Topic: new revisions won't compile
Replies: 2
Views: 1085

new revisions won't compile

Hi, I'm having problems compilig the new revisions of freeorion. revision 2422 built against gigi revision 637 was no problem. Then I tried a rebuild against the gigi-0.7.0 release available at the sourceforge-download-page, which didn't work, so I updated freeorion to revision 2245, I tried to buil...
by obgr_seneca
Tue Apr 01, 2008 7:32 am
Forum: General Discussion
Topic: freeorion RPM-packages
Replies: 18
Views: 8000

freeorion RPM-packages

I built rpm-packages of freeorion for Mandrivalinux 2008.0! Anyone interested can download them out of our repository at ftp://ftp.mandrivauser.de/rpm/GPL/2008.0 . All dependencies, that are not part of the Mandrivalinux distribution, can be found there, too. Packages are available for i586, x86_64 ...
by obgr_seneca
Thu Mar 13, 2008 7:48 am
Forum: General Discussion
Topic: Fonts partly not readable
Replies: 2
Views: 1310

Fonts partly not readable

Hi,
I have a little problem with freeorion. Some of the fonts are not readable, there's just some chaos where the fonts should be.
I made a screenshot to show, what I mean.
Does anyone have a solution on how to fix it?

Oliver

Image
by obgr_seneca
Wed Mar 12, 2008 6:53 pm
Forum: Compile
Topic: building rpm-package of gigi fails
Replies: 8
Views: 1213

Re: building rpm-package of gigi fails

It's done, I have RPM-packages of gigi and of freeorion, In the next few days I will load them into our repositories at mandrivauser.de.
This may take some time since my internet-connection is a bit unstable...
I will tell you, when I'm ready...

Oliver