Sound crackles / solution

Samples of sound/music, ideas or suggestions related to the development of audio assets for FreeOrion.
Post Reply
Message
Author
phonon
Space Krill
Posts: 2
Joined: Mon Dec 31, 2007 6:52 pm

Sound crackles / solution

#1 Post by phonon » Mon Dec 31, 2007 7:08 pm

After compilation (Ubuntu Linux), i had sound crackles during game play. They appeared irregularly around 3Hz. I have a sound Blaster 24 as well as onboard sound. Problems appeared with sound blaster. After a while, I found a solution on: http://ubuntuforums.org/showthread.php?t=580726
I just used gedit to make .openalrc with the following line
(define devices '(native))
saved it in my home directory as .openalrc
After that, the sound had been switched to onboard and the crackles / noise had dissapeared.

regards, phonon

User avatar
utilae
Cosmic Dragon
Posts: 2175
Joined: Fri Jun 27, 2003 12:37 am
Location: Auckland, New Zealand

Re: Sound crackles / solution

#2 Post by utilae » Mon Dec 31, 2007 8:52 pm

I had a sound blaster 24 bit and everytime I'd play any game, I'd get crackling.

The solution, get a better sound card, cause it's most likely that that sound card is crap :)

User avatar
MareviQ
Space Kraken
Posts: 100
Joined: Tue Aug 09, 2005 6:47 pm
Location: Somewhere in Poland

Re: Sound crackles / solution

#3 Post by MareviQ » Tue Jan 22, 2008 12:18 pm

Actually, this problem appears only with SoundBlaster sound cards (Audigy Ex here) on Linux with ALSA drivers (OSS seems fine... not OSS via ALSA though). Never discovered what exactly caused the problem.
abs(imag(ME) / abs(ME)) = exp(PI) - PI - 19;

krum
Creative Contributor
Posts: 244
Joined: Thu Jun 26, 2003 12:58 pm
Location: Bulgaria

Re: Sound crackles / solution

#4 Post by krum » Tue Jan 22, 2008 4:17 pm

phonon wrote:After compilation (Ubuntu Linux), i had sound crackles during game play. They appeared irregularly around 3Hz. I have a sound Blaster 24 as well as onboard sound. Problems appeared with sound blaster. After a while, I found a solution on: http://ubuntuforums.org/showthread.php?t=580726
I just used gedit to make .openalrc with the following line
(define devices '(native))
saved it in my home directory as .openalrc
After that, the sound had been switched to onboard and the crackles / noise had dissapeared.

regards, phonon
This _mostly_ solved the problem for me too. I've had to manually add to my alsa configuration "options snd_hda_intel model=3stack" manually too :) Nothing works out of the box with this damn thing...

Post Reply