Page 4 of 37

Re: Multiplayer slow game server

Posted: Thu May 16, 2019 11:03 pm
by o01eg
Magnate wrote:
Thu May 16, 2019 9:10 pm
Magnate wrote:
Thu May 16, 2019 8:42 pm
Magnate wrote:
Thu May 16, 2019 8:39 pm

I am getting a black screen when I try to join the -lt server. I can join the -test server fine, but not the -lt one. No dialog box, no error, nothing. Just endless black.
Oh crap it's because I'm not using the right build. Hang on.
Ok I'm now getting the password prompt but no password is arriving by email. Is it sent?
Yes, it was sent.

Re: Multiplayer slow game server

Posted: Fri May 17, 2019 5:23 pm
by Magnate
o01eg wrote:
Thu May 16, 2019 11:03 pm
Magnate wrote:
Thu May 16, 2019 9:10 pm
Magnate wrote:
Thu May 16, 2019 8:42 pm

Oh crap it's because I'm not using the right build. Hang on.
Ok I'm now getting the password prompt but no password is arriving by email. Is it sent?
Yes, it was sent.
Ok I found it in spam - my problem is that Thunderbird does not replicate Gmail's folders so I had to log in on a browser to see the right spam folder.

I have connected and turned. Thanks for all the help!

Re: Multiplayer slow game server

Posted: Sat May 18, 2019 11:58 am
by o01eg
Looks like it was my time to catch bugs. All my orders from turn 1 somehow weren't executed. I don't want to restart server if I'm only one affected, so tell if you has your orders missing too.
Also I have to restart server if I get solution.

Re: Multiplayer slow game server

Posted: Sat May 18, 2019 4:37 pm
by Oberlus
o01eg wrote:
Sat May 18, 2019 11:58 am
Looks like it was my time to catch bugs. All my orders from turn 1 somehow weren't executed. I don't want to restart server if I'm only one affected, so tell if you has your orders missing too.
Also I have to restart server if I get solution.
My orders went on just fine. I'm the proud owner of an empty spot in deep space and now heading to the next one at some 100 parsecs.

Re: Multiplayer slow game server

Posted: Sat May 18, 2019 5:44 pm
by The Silent One
My orders were executed as well, reached some empty space too. Proud to have established my first colony though :D

Re: Multiplayer slow game server

Posted: Sun May 19, 2019 12:06 am
by Oberlus
o01eg wrote:
Sat May 18, 2019 11:58 am
Looks like it was my time to catch bugs.
Maybe some more: I was connected during last turn pass, from 2 to 3. My orders were issued since a previous connection. The turn button read "Revise 2" (or something like that). When the count down got to 0:00 the button changed to Turn 2 (instead of Turn 3), the ships didn't move (the orders were still there), no research advanced... So I hit resign, and connect againt to see if it refreshes then, but I'm not getting the login window for th OTP, just a blank screen (had to close it with the X after several minutes).

Edit: One hour later I've reconnected and everything was fine, turn 3. I had a glance of the chat window (I can only see it for an instant when joining the server) and I think it says I left several times in a row.

Re: Multiplayer slow game server

Posted: Sun May 19, 2019 10:31 am
by o01eg
Oberlus wrote:
Sat May 18, 2019 4:37 pm
o01eg wrote:
Sat May 18, 2019 11:58 am
Looks like it was my time to catch bugs. All my orders from turn 1 somehow weren't executed. I don't want to restart server if I'm only one affected, so tell if you has your orders missing too.
Also I have to restart server if I get solution.
My orders went on just fine. I'm the proud owner of an empty spot in deep space and now heading to the next one at some 100 parsecs.
This time my orders successfully executed. I suppose that bug was happened because I edited my orders after server restart.

Re: Multiplayer slow game server

Posted: Sun May 19, 2019 3:26 pm
by Magnate
No bugs for me so far, all works fine. I connect, do my turn, click submit orders, and then close freeorion. Game on!

Re: Multiplayer slow game server

Posted: Sun May 19, 2019 5:23 pm
by The Silent One
Is there already some kind of documentation about how to set up a (slow-game or other) server? This would likely be something to increase our player base, and might even help to attract additional developers.

Re: Multiplayer slow game server

Posted: Sun May 19, 2019 6:52 pm
by o01eg
The Silent One wrote:
Sun May 19, 2019 5:23 pm
Is there already some kind of documentation about how to set up a (slow-game or other) server? This would likely be something to increase our player base, and might even help to attract additional developers.
All my modification to freeorion code for both existing servers are open. Configuration is distributed in deb package exclude logins and passwords. Also I have a PUBLIC_SERVER.md to setup Postgresql database.

The 0.4.8 public server has a very little attendance so I'm not sure if new server will increase player base.

Re: Multiplayer slow game server

Posted: Mon May 20, 2019 6:38 pm
by Magnate
I think it will eventually be a huge draw, don't be disheartened!

A couple of tiny buglets to report from me:

1. Every time I close freeorion after submitting my turn, Windows says "freeorion.exe has stopped working" instead of closing cleanly. This is when I click the x button in the top-right corner of the window.

2. Every time I connect to start my turn, all the subwindows are back in the default positions. How can I keep them the size and place I want them?

Thanks

Re: Multiplayer slow game server

Posted: Mon May 20, 2019 6:49 pm
by o01eg
Magnate wrote:
Mon May 20, 2019 6:38 pm
I think it will eventually be a huge draw, don't be disheartened!
Thanks a lot.
Magnate wrote:
Mon May 20, 2019 6:38 pm
A couple of tiny buglets to report from me:

1. Every time I close freeorion after submitting my turn, Windows says "freeorion.exe has stopped working" instead of closing cleanly. This is when I click the x button in the top-right corner of the window.
It's definitely a bug deserved to be reported.
Magnate wrote:
Mon May 20, 2019 6:38 pm
2. Every time I connect to start my turn, all the subwindows are back in the default positions. How can I keep them the size and place I want them?

Thanks
I think subwindows positions are sent to server when you press Turn button and then server sends them back to you. Do you press it?

Re: Multiplayer slow game server

Posted: Mon May 20, 2019 8:08 pm
by o01eg
o01eg wrote:
Sat May 18, 2019 11:58 am
Looks like it was my time to catch bugs. All my orders from turn 1 somehow weren't executed. I don't want to restart server if I'm only one affected, so tell if you has your orders missing too.
Also I have to restart server if I get solution.
I've reproduced it: https://github.com/freeorion/freeorion/issues/2451. Looks like client clears orders after revise orders button. I wonder how to fix it. At least I could propose to reconnect to server to ensure if server has your orders.

Re: Multiplayer slow game server

Posted: Tue May 21, 2019 6:46 pm
by o01eg
As there no breaking changes in 2019-05-21.1a3d315 the server is compatible with current weekly test build.

Re: Multiplayer slow game server

Posted: Wed May 22, 2019 12:06 pm
by Oberlus
o01eg wrote:
Mon May 20, 2019 6:49 pm
I think subwindows positions are sent to server when you press Turn button and then server sends them back to you. Do you press it?
I have the same problem. Every time I exit FreeOrion after disconnecting from the multiplayer server, my game preferences (all of them) are reset to default. It does not matter if I connect, press Turn and disconnect or if I connect, do nothing and disconnect. In fact, it is enough to get to the OTP pass window, if I then click cancel and exit FO next time I start it options are reset again. Seems like the server systematically deletes the local configuration file. Should I open an issue somewhere?