Multiplayer slow game server

For topics that do not fit in another sub-forum.

Moderator: Oberlus

Post Reply
Message
Author
o01eg
Programmer
Posts: 909
Joined: Sat Dec 10, 2011 5:46 am

Re: Multiplayer slow game server

#61 Post by o01eg »

Oberlus wrote: Wed May 22, 2019 12:06 pm I have the same problem. Every time I exit FreeOrion after disconnecting from the multiplayer server, my game preferences (all of them) are reset to default. It does not matter if I connect, press Turn and disconnect or if I connect, do nothing and disconnect. In fact, it is enough to get to the OTP pass window, if I then click cancel and exit FO next time I start it options are reset again. Seems like the server systematically deletes the local configuration file. Should I open an issue somewhere?
Do you login to server by IP? If so I've already open issue: https://github.com/freeorion/freeorion/issues/2449
Try to use DNS name instead.
Gentoo Linux x64, gcc-9.2, boost-1.72.0
Ubuntu Server 18.04 x64, gcc-7.4, boost-1.65.1
Welcome to the slow multiplayer game at freeorion-lt.dedyn.io.Version 0.4.10.
Donations are welcome: BTC:14XLekD9ifwqLtZX4iteepvbLQNYVG87zK

User avatar
The Silent One
Graphics
Posts: 1049
Joined: Tue Jul 01, 2003 8:27 pm

Re: Multiplayer slow game server

#62 Post by The Silent One »

o01eg wrote: Wed May 22, 2019 12:30 pmTry to use DNS name instead.
That's what I do and my config is deleted as well.
If I provided any images, code, scripts or other content here, it's released under GPL 2.0 and CC-BY-SA 3.0.

o01eg
Programmer
Posts: 909
Joined: Sat Dec 10, 2011 5:46 am

Re: Multiplayer slow game server

#63 Post by o01eg »

The Silent One wrote: Wed May 22, 2019 12:59 pm
o01eg wrote: Wed May 22, 2019 12:30 pmTry to use DNS name instead.
That's what I do and my config is deleted as well.
It looks very strange. FreeOrion deletes config if version in it couldn't be read or differs from freeorion application.
Gentoo Linux x64, gcc-9.2, boost-1.72.0
Ubuntu Server 18.04 x64, gcc-7.4, boost-1.65.1
Welcome to the slow multiplayer game at freeorion-lt.dedyn.io.Version 0.4.10.
Donations are welcome: BTC:14XLekD9ifwqLtZX4iteepvbLQNYVG87zK

User avatar
Oberlus
Cosmic Dragon
Posts: 2933
Joined: Mon Apr 10, 2017 4:25 pm

Re: Multiplayer slow game server

#64 Post by Oberlus »

o01eg wrote: Wed May 22, 2019 1:04 pm
The Silent One wrote: Wed May 22, 2019 12:59 pm
o01eg wrote: Wed May 22, 2019 12:30 pmTry to use DNS name instead.
That's what I do and my config is deleted as well.
It looks very strange. FreeOrion deletes config if version in it couldn't be read or differs from freeorion application.
Using DNS seems to work for me. I've changed my settings, exited FO and run it again (settings were fine, changed), then connected using the DNS, disconnected, exited FO, relaunched it, and settings were still fine.

User avatar
The Silent One
Graphics
Posts: 1049
Joined: Tue Jul 01, 2003 8:27 pm

Re: Multiplayer slow game server

#65 Post by The Silent One »

o01eg wrote: Wed May 22, 2019 1:04 pmIt looks very strange. FreeOrion deletes config if version in it couldn't be read or differs from freeorion application.
Sorry, I have to correct myself. It's not the whole configuration, but only the science screen that doesn't keep the layout. My bad.
If I provided any images, code, scripts or other content here, it's released under GPL 2.0 and CC-BY-SA 3.0.

o01eg
Programmer
Posts: 909
Joined: Sat Dec 10, 2011 5:46 am

Re: Multiplayer slow game server

#66 Post by o01eg »

There weren't compatibility breaks in 2019-05-23.a3a0980 so the game will continue.
Gentoo Linux x64, gcc-9.2, boost-1.72.0
Ubuntu Server 18.04 x64, gcc-7.4, boost-1.65.1
Welcome to the slow multiplayer game at freeorion-lt.dedyn.io.Version 0.4.10.
Donations are welcome: BTC:14XLekD9ifwqLtZX4iteepvbLQNYVG87zK

User avatar
Oberlus
Cosmic Dragon
Posts: 2933
Joined: Mon Apr 10, 2017 4:25 pm

Re: Multiplayer slow game server

#67 Post by Oberlus »

I'm on a trip and I've used my laptop to connect to the game for first time. Before, I was using a Windows 7 with precompiled FO, and right now I've pulled master and compiled in this Ubuntu 16 machine. It has connected, showed to me the multiplayer chat for quite longer than usual (maybe 5 seconds instead of 0.5), and FO has crashed to desktop.

Code: Select all

G771-U16:~/Projects/FreeOrion/freeorion-build$ ./freeorion
terminate called after throwing an instance of 'std::exception'
  what():  std::exception
Aborted (core dumped)
What should I do now to help troubleshooting this?
Or should I just install latest precompiled version?

Edit: I connected to the multiplayer server just fine with the latest windows build on a Windows 8.1

o01eg
Programmer
Posts: 909
Joined: Sat Dec 10, 2011 5:46 am

Re: Multiplayer slow game server

#68 Post by o01eg »

Oberlus wrote: Fri May 31, 2019 7:37 am I'm on a trip and I've used my laptop to connect to the game for first time. Before, I was using a Windows 7 with precompiled FO, and right now I've pulled master and compiled in this Ubuntu 16 machine. It has connected, showed to me the multiplayer chat for quite longer than usual (maybe 5 seconds instead of 0.5), and FO has crashed to desktop.

Code: Select all

G771-U16:~/Projects/FreeOrion/freeorion-build$ ./freeorion
terminate called after throwing an instance of 'std::exception'
  what():  std::exception
Aborted (core dumped)
What should I do now to help troubleshooting this?
Or should I just install latest precompiled version?

Edit: I connected to the multiplayer server just fine with the latest windows build on a Windows 8.1
I myself on a holyday trip. Do you have a logs? Could you use coredump to debug issue? Could you try PPA version?
Gentoo Linux x64, gcc-9.2, boost-1.72.0
Ubuntu Server 18.04 x64, gcc-7.4, boost-1.65.1
Welcome to the slow multiplayer game at freeorion-lt.dedyn.io.Version 0.4.10.
Donations are welcome: BTC:14XLekD9ifwqLtZX4iteepvbLQNYVG87zK

User avatar
Oberlus
Cosmic Dragon
Posts: 2933
Joined: Mon Apr 10, 2017 4:25 pm

Re: Multiplayer slow game server

#69 Post by Oberlus »

o01eg wrote: Fri May 31, 2019 3:34 pmI myself on a holyday trip. Do you have a logs? Could you use coredump to debug issue? Could you try PPA version?
I realised there are some personal changes (some new parts) in the freeorion I used to connect. I shall try with a right build and report back.

Edit: I did a hard reset to upstream/master (got "Building v0.4.8+ build 2019-05-23.a3a0980") but the issue persists. I can't find the core dump. I've seen I need to enable apport (sudo service apport start), did it and tried to connect again to the multiplayer server, got the crash, but I still can't find the core dump (supposed to be at /var/crash). What should I do next?

o01eg
Programmer
Posts: 909
Joined: Sat Dec 10, 2011 5:46 am

Re: Multiplayer slow game server

#70 Post by o01eg »

Oberlus wrote: Fri May 31, 2019 11:31 pm
o01eg wrote: Fri May 31, 2019 3:34 pmI myself on a holyday trip. Do you have a logs? Could you use coredump to debug issue? Could you try PPA version?
I realised there are some personal changes (some new parts) in the freeorion I used to connect. I shall try with a right build and report back.

Edit: I did a hard reset to upstream/master (got "Building v0.4.8+ build 2019-05-23.a3a0980") but the issue persists. I can't find the core dump. I've seen I need to enable apport (sudo service apport start), did it and tried to connect again to the multiplayer server, got the crash, but I still can't find the core dump (supposed to be at /var/crash). What should I do next?
Do you have a ~/.local/share/freeorion/freeorion.log? If you use PPA version you get the same error?
Gentoo Linux x64, gcc-9.2, boost-1.72.0
Ubuntu Server 18.04 x64, gcc-7.4, boost-1.65.1
Welcome to the slow multiplayer game at freeorion-lt.dedyn.io.Version 0.4.10.
Donations are welcome: BTC:14XLekD9ifwqLtZX4iteepvbLQNYVG87zK

User avatar
Oberlus
Cosmic Dragon
Posts: 2933
Joined: Mon Apr 10, 2017 4:25 pm

Re: Multiplayer slow game server

#71 Post by Oberlus »

o01eg wrote: Sat Jun 01, 2019 5:45 amDo you have a ~/.local/share/freeorion/freeorion.log? If you use PPA version you get the same error?
Haven't tried the PPA yet. I attach the log from a fresh start.
Attachments
freeorion.log
(41.84 KiB) Downloaded 28 times

User avatar
The Silent One
Graphics
Posts: 1049
Joined: Tue Jul 01, 2003 8:27 pm

Re: Multiplayer slow game server

#72 Post by The Silent One »

When logging in into multiplayer, I see the lobby window, then the game crashes. Don't have an idea what's going on, log is attached.
Attachments
freeorion.log
(40.13 KiB) Downloaded 30 times
If I provided any images, code, scripts or other content here, it's released under GPL 2.0 and CC-BY-SA 3.0.

User avatar
Oberlus
Cosmic Dragon
Posts: 2933
Joined: Mon Apr 10, 2017 4:25 pm

Re: Multiplayer slow game server

#73 Post by Oberlus »

The Silent One wrote: Mon Jun 03, 2019 6:05 am When logging in into multiplayer, I see the lobby window, then the game crashes. Don't have an idea what's going on, log is attached.
I can connect using the windows builds.

User avatar
Oberlus
Cosmic Dragon
Posts: 2933
Joined: Mon Apr 10, 2017 4:25 pm

Re: Multiplayer slow game server

#74 Post by Oberlus »

o01eg wrote: Sat Jun 01, 2019 5:45 amIf you use PPA version you get the same error?
Using latest snap (2019-05-21) it also crashes.

Edit: in both cases for me (compiled form master and snap) it crashes with this message in the log:

Code: Select all

13:21:55.414276 [debug] client : Message.cpp:864 : ExtractGameStartMessage universe deserialization time 17.785
13:21:55.429124 [error] client : Message.cpp:885 : ExtractGameStartMessageData(...) failed!  Message probably long, so not outputting to log.
Error: input stream error
But he message for The Silent One is another one, a bad allocation.
Attachments
freeorion.log
(29.86 KiB) Downloaded 23 times

User avatar
The Silent One
Graphics
Posts: 1049
Joined: Tue Jul 01, 2003 8:27 pm

Re: Multiplayer slow game server

#75 Post by The Silent One »

I downloaded latest version (2019-05-23.a3a0980), fresh install, connect and crash. End of log:

Code: Select all

13:46:25.098419 [debug] timer : ScopedTimer.cpp:34 : parse_file "SP_TRENCHERS.focs.txt" time:       33 ms
13:46:25.133634 [debug] timer : ScopedTimer.cpp:34 : parse_file "SP_TRITH.focs.txt" time:       35 ms
13:46:25.167363 [debug] timer : ScopedTimer.cpp:34 : parse_file "SP_UGMORS.focs.txt" time:       33 ms
13:46:25.200599 [debug] timer : ScopedTimer.cpp:34 : parse_file "SP_VOLP.focs.txt" time:       33 ms
13:46:32.105176 [debug] client : HumanClientApp.cpp:1085 : HumanClientApp::HandleFocusChange(Lost Focus)
13:47:19.174398 [debug] client : HumanClientApp.cpp:1085 : HumanClientApp::HandleFocusChange(Gained Focus)
13:47:20.402760 [debug] client : HumanClientApp.cpp:1116 : HumanClientApp::HandleAppQuitting()
13:47:20.402760 [debug] client : HumanClientApp.cpp:1409 : HumanClientApp::ExitApp
13:47:20.403282 [debug] client : HumanClientApp.cpp:380 : HumanClientApp exited cleanly.
13:47:20.417787 [debug] client : Universe.cpp:161 : Reset id allocators with highest object id = -1 and highest design id = -1
13:47:20.417787 [debug] client : chmain.cpp:322 : Human client main exited cleanly.
If I provided any images, code, scripts or other content here, it's released under GPL 2.0 and CC-BY-SA 3.0.

Post Reply