Scons can't find boost serialization

Questions, problems and discussion about compiling FreeOrion.

Moderators: Oberlus, Oberlus

Message
Author
User avatar
OndrejR
Space Dragon
Posts: 339
Joined: Thu Oct 02, 2008 11:00 pm
Location: Slovakia

Re: Scons can't find boost serialization

#76 Post by OndrejR » Sun Jan 25, 2009 7:26 pm

physix wrote:There is no change whether I use the -mt suffix option or not. LD_LIBRARY_PATH contains the right path to boost.
Any ideas? Has this been resolved yet?
I and francys have Debian and there is no problem with compiling FreeOrion. But on Ubuntu there is this error and we don't know why. The only difference which we found is version of libc6.

But you can play FreeOrion with official version, which is statically linked.

physix
Space Krill
Posts: 2
Joined: Mon Mar 24, 2008 10:59 pm

Re: Scons can't find boost serialization

#77 Post by physix » Mon Jan 26, 2009 2:09 pm

thanks, but I am more interested in looking at the code and play around with it tbh :)

So if there is no solution to this I guess I have to play the download version until there will be an new boost in the ubuntu repositories... As far as I remember the downloaded version crashed on creating a new game though...

User avatar
OndrejR
Space Dragon
Posts: 339
Joined: Thu Oct 02, 2008 11:00 pm
Location: Slovakia

Re: Scons can't find boost serialization

#78 Post by OndrejR » Mon Jan 26, 2009 2:30 pm

physix wrote:So if there is no solution to this I guess I have to play the download version until there will be an new boost in the ubuntu repositories... As far as I remember the downloaded version crashed on creating a new game though...
Boost 1.37 is already in ubuntu, but only in Jaunty repository. IConrad tried also boost 1.37 from debian, but it didn't help. Crashing on creating a new game is already fixed in official version.

User avatar
kroddn
Static Linker
Posts: 347
Joined: Thu Jun 28, 2007 10:28 am

Re: Scons can't find boost serialization

#79 Post by kroddn » Mon Jan 26, 2009 2:58 pm

physix wrote:thanks, but I am more interested in looking at the code and play around with it tbh :)

So if there is no solution to this I guess I have to play the download version until there will be an new boost in the ubuntu repositories... As far as I remember the downloaded version crashed on creating a new game though...
Today I fixed a bug which causes the game to crash if you use a kernel smaller than 2.6.22.

If you have such a kernel on your system, try this new version here:
freeorion_rev2771_i386_static.tar.gz
on
http://www.psitronic.de/div/FO/ (will have finished uploading in 30 minutes)

User avatar
OndrejR
Space Dragon
Posts: 339
Joined: Thu Oct 02, 2008 11:00 pm
Location: Slovakia

Re: Scons can't find boost serialization

#80 Post by OndrejR » Thu Jan 29, 2009 1:43 pm

IConrad: I updated wiki compile linux howto dependecies. Install it and try again. And if it didn't help, try also this:

Code: Select all

sudo apt-get install bison flex automake autoconf

johnnygp
Space Krill
Posts: 2
Joined: Sat Mar 14, 2009 4:46 am

Re: physix and anyone exping boost_system lib errors

#81 Post by johnnygp » Sat Mar 14, 2009 5:04 am

ignore this post, read the next one.
Last edited by johnnygp on Sat Mar 14, 2009 5:07 am, edited 1 time in total.

johnnygp
Space Krill
Posts: 2
Joined: Sat Mar 14, 2009 4:46 am

Re: physix and anyone exp'ing boost_system or like lib errors

#82 Post by johnnygp » Sat Mar 14, 2009 5:05 am

physix wrote:Hey there,

I finally want to take a look at FreeOrion, but I seem to be stuck in the same mess this thread is about.

I am running Ubuntu 8.10 and manually installed boost 1.37 today (ubuntu comes with 1.35). When I try to build GIGI I get:

Code: Select all

sudo scons
scons: Reading SConscript files ...
--some code deleted here for brevity--
Looking for boost lib boost_system... 
Checking for boost::system::get_system_category() in C++ library boost_system... no
Checking for boost::system::get_system_category() in C++ library boost_system-mt... no
Boost configuration... (cached) no
There is no change whether I use the -mt suffix option or not. LD_LIBRARY_PATH contains the right path to boost.
Any ideas? Has this been resolved yet?
I know this is an old thread, but I had the identical problem and found this discussion while trying to solve it.

The solution: the '-mt' suffix was not sufficient. Because I had multiple versions of boost installed (?), scons needed to be directed to the full suffix of the library. In my case, it required: '-gcc43-mt-1_38' (as I was using version 1.38).

To get an idea of the suffixes your version of the library might be using, try typing at the command line:

locate --regex libboost.*\.a$

(That's if you use locate regularly. You might need to type 'sudo updatedb' first to bring the database up to date.)

You will see a list of different components of the boost library, from which you should be able to deduce the suffix:

/usr/local/lib/libboost_signals-gcc43-mt-1_37.a
/usr/local/lib/libboost_signals-gcc43-mt-1_38.a
/usr/local/lib/libboost_signals-gcc43-mt.a
/usr/local/lib/libboost_system-gcc43-mt-1_37.a
/usr/local/lib/libboost_system-gcc43-mt-1_38.a
/usr/local/lib/libboost_system-gcc43-mt.a

Add the following line to your options.cache file like this:

boost_lib_suffix = '-gcc43-mt-1_38'

I did this, and boost configured properly. I am currently building (but have not yet run) the final product.

-j

Post Reply