ogre problem when building

Questions, problems and discussion about compiling FreeOrion.

Moderators: Oberlus, Oberlus

Message
Author
User avatar
francys
Space Squid
Posts: 54
Joined: Sat Oct 25, 2008 8:53 pm
Location: Victoria, BC

Re: ogre problem when building

#46 Post by francys » Sat Feb 14, 2009 7:01 am

OndrejR wrote:In last revision 2814 I can turn off fullscreen mode from Options(via custom mode) or comment it in config.xml cause FO run in window mode, but I can't leave FO window. Problem with debugging is that when segfault occurs debugger switch to gdb console. But mouse and keyboard can't leave FO window and that is the problem.
I'm sorry. I forgot to mention that I'm not running FO in fullscreen mode. Any ideas how to unhook the keyboard?

User avatar
OndrejR
Space Dragon
Posts: 339
Joined: Thu Oct 02, 2008 11:00 pm
Location: Slovakia

Re: ogre problem when building

#47 Post by OndrejR » Sat Feb 14, 2009 7:06 am

Geoff the Medio wrote:
OndrejR wrote:...mouse and keyboard can't leave FO window and that is the problem
Is that always the case, or just when the segfault occurs?
EDIT: only via alt-tab it is possible to leave FO window(not from fullscreen).

User avatar
francys
Space Squid
Posts: 54
Joined: Sat Oct 25, 2008 8:53 pm
Location: Victoria, BC

Re: ogre problem when building

#48 Post by francys » Sat Feb 14, 2009 7:26 am

With gdb I managed to get till chmain.cpp:145 app() before keyboard and mouse were hooked up. At that point there was no segfault, but I couldn't do anything useful. :?

Edit (15 feb 2009): freeorion.log only prints

Code: Select all

2009-02-15 19:39:10,020 DEBUG Client : OpenAL initialized. Version 1.1Renderer OpenAL SoftVendor OpenAL Community
Extensions: AL_EXT_EXPONENT_DISTANCE AL_EXT_FLOAT32 AL_EXT_IMA4 AL_EXT_LINEAR_DISTANCE AL_EXT_MCFORMATS AL_EXT_OFFSET AL_LOKI_quadriphonic
2009-02-15 19:39:11,270 DEBUG Client : Limited FPS to 60

User avatar
kroddn
Static Linker
Posts: 347
Joined: Thu Jun 28, 2007 10:28 am

Re: ogre problem when building

#49 Post by kroddn » Tue Feb 17, 2009 7:26 am

Could these runtime segfaults be discussed in a separate thread? This thread here is getting out of control...

Post Reply