No rule to make target `/usr/local/lib/'

Questions, problems and discussion about compiling FreeOrion.

Moderators: Oberlus, Oberlus

Post Reply
Space Krill
Posts: 4
Joined: Fri Dec 18, 2009 10:06 pm

No rule to make target `/usr/local/lib/'

#1 Post by bobdobbs » Fri Dec 18, 2009 10:40 pm


I'm building on ubuntu karmic koala.

Most everything goes smoothly up until the end of the make process for freeorion.

I have installed all the pre-requisites. I installed the bullet and bullet-dev libraries with apt-get.

When I run 'make' in trunk/FreeOrion, I get this:
[100%] Building CXX object client/human/CMakeFiles/freeorion.dir/__/__/log4cpp/src/PThreads.cpp.o
make[2]: *** No rule to make target `/usr/local/lib/', needed by `freeorion'. Stop.
make[1]: *** [client/human/CMakeFiles/freeorion.dir/all] Error 2
make: *** [all] Error 2
How do I get past this error ?


User avatar
Geoff the Medio
Programming, Design, Admin
Posts: 12629
Joined: Wed Oct 08, 2003 1:33 am
Location: Munich

Re: No rule to make target `/usr/local/lib/'

#2 Post by Geoff the Medio » Sat Dec 19, 2009 2:06 am

Did you work around this problem already? (Since you posted about having compiled and having a seemingly unrelated problem)? If so, what was the fix?

If not, presumably there's an entry in the cmake configuration with which to specify the location of bullet or libbulletdynamics. Have you tried that?

User avatar
Space Dragon
Posts: 339
Joined: Thu Oct 02, 2008 11:00 pm
Location: Slovakia

Re: No rule to make target `/usr/local/lib/'

#3 Post by OndrejR » Sat Dec 19, 2009 12:09 pm

If you install package, then location is not:

Code: Select all

but probably

Code: Select all


Post Reply