new Mac SDK

Questions, problems and discussion about compiling FreeOrion.

Moderators: Oberlus, Oberlus

Post Reply
Message
Author
User avatar
.Id
Space Squid
Posts: 76
Joined: Fri Feb 06, 2009 6:54 pm

new Mac SDK

#1 Post by .Id » Wed Mar 03, 2010 12:30 am

There's a new Mac OS X SDK available at SourceForge meant for revision 3358 and later.

Please download the SDK if you plan on doing your own FreeOrion builds on Macs. The SDK comes with a checkout of revision 3358.

Changes:

- Ogg/Vorbis framework renaming to fix build on case sensitive filesystems
- libfreetype/Ogre conflicting symbols resolved by upgrading to Ogre 1.7.0 and using the libfreetype provided in the Ogre dependencies
- alut/OpenAL conflicting symbols resolved by renaming appropriate symbols in the freealut library
- graphviz, libpng, and libpython were previously accidentally compiled against the OS X 10.5 SDK which didn't allow the 10.4 ld to link against them. They are now compiled against the 10.4 SDK. (graphviz is still version 2.20.3, png is still 1.2.34, but python is 2.6.4 instead of 2.5)
- I also discovered that the included libpython.a was not really a static library despite the naming convention. It was a dynamic library that pointed to the location of the Python 2.5 Framework that is available in OS X 10.5, but not in 10.4. This would have caused the AI client to fail in 10.4
- Xcode 2.5 will not autocompile a .xib into .nib in the application's "copy files" build phase, so a .nib has been precompiled with ibtool

User avatar
.Id
Space Squid
Posts: 76
Joined: Fri Feb 06, 2009 6:54 pm

Re: new Mac SDK

#2 Post by .Id » Wed Mar 03, 2010 1:58 pm

Update: There will probably need to be another slight change to the SDK to fix an issue just brought to my attention (concerning OS X 10.4 runtime failure w/ the AI client). If you haven't downloaded it already, I recommend waiting until I post back with more news.

User avatar
.Id
Space Squid
Posts: 76
Joined: Fri Feb 06, 2009 6:54 pm

Re: new Mac SDK

#3 Post by .Id » Sun Mar 07, 2010 4:55 pm

.Id wrote:Update: There will probably need to be another slight change to the SDK to fix an issue just brought to my attention (concerning OS X 10.4 runtime failure w/ the AI client). If you haven't downloaded it already, I recommend waiting until I post back with more news.
This has now been addressed in the latest SDK available at SourceForge now.

A Python 2.5.5 framework is now included in the SDK and will be fully embed-able in the compiled Mac application bundle.

Post Reply