[solved] 3511: not compiling on OS X

Questions, problems and discussion about compiling FreeOrion.

Moderators: Oberlus, Oberlus

Post Reply
Message
Author
jsena
Space Floater
Posts: 36
Joined: Tue Feb 16, 2010 4:12 pm

[solved] 3511: not compiling on OS X

#1 Post by jsena » Sat Apr 17, 2010 3:15 am

The latest versions of FO are not compiling for me. It seems to have something to do with the math libraries...
'::acos' has not been declared, '::asin' has not been declared, etc.

Please see the attached for the errors.
Attachments
XCode Errors.txt
(16.92 KiB) Downloaded 99 times
Last edited by jsena on Sun Apr 25, 2010 4:57 am, edited 1 time in total.

User avatar
Geoff the Medio
Programming, Design, Admin
Posts: 12676
Joined: Wed Oct 08, 2003 1:33 am
Location: Munich

Re: 3511: not compiling on OS X

#2 Post by Geoff the Medio » Sat Apr 17, 2010 3:57 am

The XCode project hasn't been updated since several files were added and one file was removed recently. I can't fix this, but .Id could, or you can add the missing files yourself. If I remember correctly, Serialize.cpp has been removed, and several new cpp files with Serialize at the start of their names have been added. Math.cpp has also been added. All those files need to be added to the build for freeorion, freeorionca and freeoriond (the human client, AI client and server, in case they're called something different in the XCode project).

There is also a CMake setup file from which you should be able to generate some complete project files, but I don't think it's been tested on OSX.

jsena
Space Floater
Posts: 36
Joined: Tue Feb 16, 2010 4:12 pm

Re: 3511: not compiling on OS X

#3 Post by jsena » Sun Apr 18, 2010 3:02 am

I tried adding the files to XCode (and I think I even did it correctly), but I still get the same kind of errors from cmath. Hopefully .ld can address the issue.

User avatar
.Id
Space Squid
Posts: 76
Joined: Fri Feb 06, 2009 6:54 pm

Re: 3511: not compiling on OS X

#4 Post by .Id » Sat Apr 24, 2010 12:53 am

I just committed a new Xcode project that fixed this for me.

I think the issue was with the "Always Search User Paths" build setting. The default is on, it's now off.

User avatar
Bigjoe5
Designer and Programmer
Posts: 2058
Joined: Tue Aug 14, 2007 6:33 pm
Location: Orion

Re: 3511: not compiling on OS X

#5 Post by Bigjoe5 » Sat Apr 24, 2010 2:06 am

Works great, thanks.
Warning: Antarans in dimensional portal are closer than they appear.

jsena
Space Floater
Posts: 36
Joined: Tue Feb 16, 2010 4:12 pm

Re: [solved] 3511: not compiling on OS X

#6 Post by jsena » Sun Apr 25, 2010 4:57 am

Problem Solved. Thanks .ld!

Post Reply