Page 1 of 1

Possible game-breaking bug in FreeOrion_2017-11-20 Win exe

Posted: Tue Nov 21, 2017 12:30 pm
by Heracliton
'Possible' since there are some oddities seemingly specific to my installation; however:

The fleets window, after 2 or 3 closures ('X' button or clicking on map), disappeared and there was no way to recover it. Closing the game, restarting and loading the save was no help. Regenerated the universe and the same bug appeared. Going through the Pedia list locates a ship but again no fleet pane.

FreeOrion_2017-11-20.e6848d8_Test_Win32_Setup.exe; fresh install.

There is no way to access the fleet list/ship pane. Reverting to 2017-11-13.

Incidentally in both the latter release and the current one, on opening the build queue the Pedia window pops up - an old feature that was killed off long ago. Please terminate with extreme prejudice :P

Another bug (?): cycling through seeds I notice that every other gen the game reactivates Experimentors and Supertesters (first of no interest at present, second none at all).

System:

Asus P8Z77 V Pro, Intel 3770K @ stock, 16GB Vengeance Red 2300MHz DDR3; OS on Samsung 850 EVO 512 GB, game on secofd partition of WD Caviar Black 1TB. Win 7 Pro 64, updated last Saturday. Gigabyte Windforce HD 7950 3GB, AMD Crimson Relive (awful name) v17.7.2.

Re: Possible game-breaking bug in FreeOrion_2017-11-20 Win e

Posted: Tue Nov 21, 2017 2:25 pm
by Geoff the Medio
https://github.com/freeorion/freeorion/issues/1859

Workaround: press escape a few times.

Re: Possible game-breaking bug in FreeOrion_2017-11-20 Win e

Posted: Tue Nov 21, 2017 3:27 pm
by Heracliton
Thanks, Geoff :)

My bad, should have checked GitHub firs., Still, at least there's now a helpful post for others who encounter it.