Page 1 of 1

Save game button stuck in disabled state

Posted: Fri Jul 20, 2018 3:06 am
by duckstab
I'm about 450 turns into my first real game (single player) and really enjoying it. However, I cannot save my game anymore because the button is always disabled.

Looking at the "Empires" window I can see that two of my opponents (one of whom I've completely eliminated) have the green checks indicating that they're still saving. However, if I restart and load an autosave or an earlier save from several turns back, it doesn't help. After a few seconds the green checks appear again and once again I can't save.

Windows 10 64 bit
FreeOrion v0.4.7.1 [build 2017-09-03.139ffd9] MSVC 2015

Log files attached.

Re: Save game button stuck in disabled state

Posted: Fri Jul 20, 2018 6:20 am
by Dilvish
duckstab wrote:...450 turns...two of my opponents (one of whom I've completely eliminated) have the green checks indicating that they're still saving. However, if I restart and load an autosave or an earlier save from several turns back, it doesn't help. After a few seconds the green checks appear again and once again I can't save.
The green checks indicate that they have finished entering any orders they have. It's the ones' who don't yet have green checks that are preventing you from saving (at least according to my recollection). At turn 450+, the turns can be pretty slow. In the future you might want to play smaller galaxies, and/or with a lower monster rate.

Re: Save game button stuck in disabled state

Posted: Sat Jul 21, 2018 12:53 am
by duckstab
You're right, thanks!

Glad it was a false alarm. I don't mind waiting for a while for the AI to finish their turn, as long as I know what to expect.