Slightly outdated Linux

Problems and solutions for installing or running FreeOrion, including discussion of bugs if needed before posting a bug report. For problems building from source, post in Compile.

Moderators: Oberlus, Oberlus

Post Reply
Message
Author
Corbeau
Space Krill
Posts: 1
Joined: Mon Jul 15, 2019 6:52 am

Slightly outdated Linux

#1 Post by Corbeau » Mon Jul 15, 2019 8:40 am

Hello. I'm new one here and, of course, I have a problem.

I have a bit oldish Linux Mint (17 32-bit) and when trying to use Snap, I get this:

Code: Select all

error: system does not fully support snapd: you need to reboot into a 4.4
       kernel to start using snapd
Yes, the best thing to do would be to upgrade the system. I know. Apart from that, does anyone know of a shortcut that could help me run the game?

One stupid idea: has anyone ever tried to run a Windows version on Linux using Wine?

User avatar
Oberlus
Cosmic Dragon
Posts: 1410
Joined: Mon Apr 10, 2017 4:25 pm

Re: Slightly outdated Linux

#2 Post by Oberlus » Mon Jul 15, 2019 4:55 pm

I use Ubuntu 16.04 and compile from source (although the snaps also work for me, and I guess o01eg's ppa too).
Never used Mint, I assume you can't use Ubuntu PPAs, but have you tried compiling from source? Less burden than updating the system I guess.

o01eg
Programmer
Posts: 412
Joined: Sat Dec 10, 2011 5:46 am

Re: Slightly outdated Linux

#3 Post by o01eg » Mon Jul 15, 2019 6:45 pm

Corbeau wrote:
Mon Jul 15, 2019 8:40 am
Hello. I'm new one here and, of course, I have a problem.

I have a bit oldish Linux Mint (17 32-bit) and when trying to use Snap, I get this:

Code: Select all

error: system does not fully support snapd: you need to reboot into a 4.4
       kernel to start using snapd
Yes, the best thing to do would be to upgrade the system. I know. Apart from that, does anyone know of a shortcut that could help me run the game?

One stupid idea: has anyone ever tried to run a Windows version on Linux using Wine?
Minimum supported boost version is 1.58 which provided by Ubuntu 16.04 Xenial and Mint 18.

Moreover there is a plan for python3 migration which requires Ubuntu 18.04 Bionic and Mint 19.
Gentoo Linux x64, gcc-8.3, boost-1.65.0
Ubuntu Server 18.04 x64, gcc-7.4, boost-1.65.1
Welcome to slow multiplayer game at freeorion-lt.dedyn.io. Version 2019-07-30.587d1c0.
Donates are welcome: BTC:14XLekD9ifwqLtZX4iteepvbLQNYVG87zK

Post Reply