Ogre assert on startup, linux static rev3009.

Problems and solutions for installing or running FreeOrion, including discussion of bugs if needed before posting a bug report on GitHub. For problems building from source, post in Compile.

Moderator: Oberlus

Locked
Message
Author
joevenzon
Space Krill
Posts: 2
Joined: Wed May 06, 2009 4:44 pm

Ogre assert on startup, linux static rev3009.

#1 Post by joevenzon »

I downloaded the rev3009_i386_static.tar.gz distribution and here's what's written to stdout/stderr:

Code: Select all

[email protected]:~/downloads/freeorion$ ./freeorion
Following into my basedir
CWD: /home/joe/downloads/freeorion/application
python2.5 found. Using it.
freeorion: OgreRoot.cpp:103: static Ogre::Root& Ogre::Root::getSingleton(): Assertion `ms_Singleton' failed.
Aborted

User avatar
Geoff the Medio
Programming, Design, Admin
Posts: 12770
Joined: Wed Oct 08, 2003 1:33 am
Location: Munich

Re: Ogre assert on startup, linux static rev3009.

#2 Post by Geoff the Medio »

kroddn's been trying to get Ogre to link statically, but there are some issues unresolved, which I suspect this is an example of. You might try the revision he's got up prior to that, as long as you're not using Ubuntu 9.04.

joevenzon
Space Krill
Posts: 2
Joined: Wed May 06, 2009 4:44 pm

Re: Ogre assert on startup, linux static rev3009.

#3 Post by joevenzon »

I'm on ubuntu 9.04. I compiled freeorion from source and it works fine, so *shrug*

User avatar
kroddn
Static Linker
Posts: 347
Joined: Thu Jun 28, 2007 10:28 am

Re: Ogre assert on startup, linux static rev3009.

#4 Post by kroddn »

The problem is discussed in this thread:
viewtopic.php?f=25&t=2651

Currenctly, I am am not able to fix this problem, as I don't know what is causing it.

Locked