FreeOrion-0.3.13 won't launch on Mac OS X 10.5.7

Problems and solutions for installing or running FreeOrion, including discussion of bugs if needed before posting a bug report. For problems building from source, post in Compile.

Moderators: Oberlus, Oberlus

Post Reply
Message
Author
User avatar
agorski
Krill Swarm
Posts: 12
Joined: Wed May 27, 2009 7:46 pm

FreeOrion-0.3.13 won't launch on Mac OS X 10.5.7

#1 Post by agorski » Wed May 27, 2009 7:56 pm

Just downloaded the 5-26-09 release. Tried to launch in both admin and standard accounts. Don't have the Developer Tools installed (needed?).

Trying to launch, nothing happens. Console log consistently returns the same message:

com.apple.launchd[116] ([0x0-0xc40c4].org.FreeOrion[1274]) posix_spawnp("/Users/agorski/Applications/FreeOrion.app/Contents/MacOS/FreeOrion", ...): Permission denied
com.apple.launchd[116] ([0x0-0xc40c4].org.FreeOrion[1274]) Exited with exit code: 1

TIA for your help.

User avatar
kroddn
Static Linker
Posts: 347
Joined: Thu Jun 28, 2007 10:28 am

Re: FreeOrion-0.3.13 won't launch on Mac OS X 10.5.7

#2 Post by kroddn » Wed May 27, 2009 8:36 pm

Does the binary "/Users/agorski/Applications/FreeOrion.app/Contents/MacOS/FreeOrion" exist and is executable?

User avatar
agorski
Krill Swarm
Posts: 12
Joined: Wed May 27, 2009 7:46 pm

Re: FreeOrion-0.3.13 won't launch on Mac OS X 10.5.7

#3 Post by agorski » Wed May 27, 2009 9:40 pm

I chmod'ed the binary to 766 and that helped (thanks!), so there is one problem with the Mac download that needs to be fixed. However, upon launch I get "The application FreeOrion quit unexpectedly" dialog.

The console log now says:

[0x0-0x114114].org.FreeOrion[1592] dyld: Library not loaded: @executable_path/../SharedSupport/libBulletCollision.dylib
[0x0-0x114114].org.FreeOrion[1592] Referenced from: /Users/agorski/Applications/FreeOrion.app/Contents/MacOS/FreeOrion
[0x0-0x114114].org.FreeOrion[1592] Reason: image not found
com.apple.launchd[1391] ([0x0-0x114114].org.FreeOrion[1592]) Exited abnormally: Trace/BPT trap

There's no SharedSupport folder in the application bundle.

I remember getting a message about a missing dylib with the last version download, and had to use an installer someone else created special that I found a link for in the forum. Is something missing in the download?

User avatar
Geoff the Medio
Programming, Design, Admin
Posts: 12487
Joined: Wed Oct 08, 2003 1:33 am
Location: Munich

Re: FreeOrion-0.3.13 won't launch on Mac OS X 10.5.7

#4 Post by Geoff the Medio » Wed May 27, 2009 9:48 pm

Issues with dylib were discussed here: viewtopic.php?p=36253#p36253

User avatar
agorski
Krill Swarm
Posts: 12
Joined: Wed May 27, 2009 7:46 pm

Re: FreeOrion-0.3.13 won't launch on Mac OS X 10.5.7

#5 Post by agorski » Thu May 28, 2009 8:06 pm

Geoff the Medio wrote:Issues with dylib were discussed here: viewtopic.php?p=36253#p36253
Thanks. Looks like folks are aware of the issue. I'll just wait to see if a new installer is released.

User avatar
.Id
Space Squid
Posts: 76
Joined: Fri Feb 06, 2009 6:54 pm

Re: FreeOrion-0.3.13 won't launch on Mac OS X 10.5.7

#6 Post by .Id » Fri May 29, 2009 8:29 pm

agorski wrote:I chmod'ed the binary to 766 and that helped (thanks!), so there is one problem with the Mac download that needs to be fixed. However, upon launch I get "The application FreeOrion quit unexpectedly" dialog.

The console log now says:

[0x0-0x114114].org.FreeOrion[1592] dyld: Library not loaded: @executable_path/../SharedSupport/libBulletCollision.dylib
[0x0-0x114114].org.FreeOrion[1592] Referenced from: /Users/agorski/Applications/FreeOrion.app/Contents/MacOS/FreeOrion
[0x0-0x114114].org.FreeOrion[1592] Reason: image not found
com.apple.launchd[1391] ([0x0-0x114114].org.FreeOrion[1592]) Exited abnormally: Trace/BPT trap

There's no SharedSupport folder in the application bundle.

I remember getting a message about a missing dylib with the last version download, and had to use an installer someone else created special that I found a link for in the forum. Is something missing in the download?
It looks like some things got lost on the upload to sourceforge. I checked myself and verified:
1) the execute permission got stripped
2) there's ~40MB missing

Thus, it doesn't work.

Someone will need to try uploading again. Would that be tzlaine?

But maybe before that happens, you can try my own upload that works for me at least and let me know if you find any other problems.
Here is my upload.
The zipfiles can be unzipped & combined with the `unpack-FO` bash script example.

User avatar
agorski
Krill Swarm
Posts: 12
Joined: Wed May 27, 2009 7:46 pm

Re: FreeOrion-0.3.13 won't launch on Mac OS X 10.5.7

#7 Post by agorski » Sat May 30, 2009 12:26 am

.Id wrote:But maybe before that happens, you can try my own upload that works for me at least and let me know if you find any other problems.
Here is my upload.
The zipfiles can be unzipped & combined with the `unpack-FO` bash script example.
That works. Thanks very much!

User avatar
kroddn
Static Linker
Posts: 347
Joined: Thu Jun 28, 2007 10:28 am

Re: FreeOrion-0.3.13 won't launch on Mac OS X 10.5.7

#8 Post by kroddn » Sat May 30, 2009 8:26 am

Can you provide md5sums of that files?

Why did you split those files? It would be much easier for users to have just one ZIP to extract, which then works out of the box.

I downloaded the files to my server and upload them.

/Edit: files are uploaded here https://sourceforge.net/project/showfil ... _id=685272

User avatar
.Id
Space Squid
Posts: 76
Joined: Fri Feb 06, 2009 6:54 pm

Re: FreeOrion-0.3.13 won't launch on Mac OS X 10.5.7

#9 Post by .Id » Sat May 30, 2009 6:55 pm

kroddn wrote:Can you provide md5sums of that files?
I have:

MD5 (FreeOri1.zip) = 4f16ce0eb8185c1175916fedf89cd503
MD5 (FreeOri2.zip) = 2ef6545a11009bc7a8b9c7891c0770fc
kroddn wrote: Why did you split those files? It would be much easier for users to have just one ZIP to extract, which then works out of the box.
I agree that it's preferable to have a single zip file.

I split them for these reasons:
1) reluctance to start using my own machine as a webserver.
2) not a member of the FO project on sourceforge yet, and can't directly upload.
3) not wanting to pay for file hosting, and mediafire only does up to 100mb files for free.

Maybe its less of a hassle if #2 is no longer an excuse. Do you think think can be arranged?
kroddn wrote: I downloaded the files to my server and upload them.

/Edit: files are uploaded here https://sourceforge.net/project/showfil ... _id=685272
And those appear fine, if split files is the solution everyone wants for now. Thanks, kroddn.

User avatar
kroddn
Static Linker
Posts: 347
Joined: Thu Jun 28, 2007 10:28 am

Re: FreeOrion-0.3.13 won't launch on Mac OS X 10.5.7

#10 Post by kroddn » Sat May 30, 2009 7:07 pm

.Id wrote: 2) not a member of the FO project on sourceforge yet, and can't directly upload.
3) not wanting to pay for file hosting, and mediafire only does up to 100mb files for free.

Maybe its less of a hassle if #2 is no longer an excuse. Do you think think can be arranged?
You don't need to be a FO project member to upload files on sourceforge. You can upload if you have a sourceforge account, and we then can release the file shortly after your upload.

Its quite easy, read http://apps.sourceforge.net/trac/source ... %20service

User avatar
.Id
Space Squid
Posts: 76
Joined: Fri Feb 06, 2009 6:54 pm

Re: FreeOrion-0.3.13 won't launch on Mac OS X 10.5.7

#11 Post by .Id » Sun May 31, 2009 2:12 pm

kroddn wrote: You don't need to be a FO project member to upload files on sourceforge. You can upload if you have a sourceforge account, and we then can release the file shortly after your upload.

Its quite easy, read http://apps.sourceforge.net/trac/source ... %20service
It's "Developer web content" that I want right?
http://apps.sourceforge.net/trac/source ... oper%20web says:
"Developer web is available to members of projects hosted on SourceForge.net."

I tried both my SSH and web access, and it doesn't authorize me. So I think I need to be a member of at least one project, which I am not. Do I just start my own or get added as a developer on FreeOrion?
Correct me if I'm doing something wrong.

User avatar
Geoff the Medio
Programming, Design, Admin
Posts: 12487
Joined: Wed Oct 08, 2003 1:33 am
Location: Munich

Re: FreeOrion-0.3.13 won't launch on Mac OS X 10.5.7

#12 Post by Geoff the Medio » Fri Jun 05, 2009 4:30 am

.Id wrote:I split them for these reasons:
1) reluctance to start using my own machine as a webserver.
2) not a member of the FO project on sourceforge yet, and can't directly upload.
3) not wanting to pay for file hosting, and mediafire only does up to 100mb files for free.

Maybe its less of a hassle if #2 is no longer an excuse. Do you think think can be arranged
Check your forum private messages.

Post Reply