Segmentation Fault / Ubuntu 9.10 / 2005 Radeon Card

Problems and solutions for installing or running FreeOrion, including discussion of bugs if needed before posting a bug report. For problems building from source, post in Compile.

Moderators: Oberlus, Oberlus

Message
Author
User avatar
Geoff the Medio
Programming, Design, Admin
Posts: 12381
Joined: Wed Oct 08, 2003 1:33 am
Location: Munich

Re: Segmentation Fault / Ubuntu 9.10 / 2005 Radeon Card

#16 Post by Geoff the Medio » Sun Nov 28, 2010 11:58 am

Perpetuum_Mobile wrote:Plugin=Plugin_CgProgramManager
OndrejR wrote:Loading Cg is not necessary
Also, since Cg is not necessary, the command to load it has been removed from the SVN version of ogre_plugins.cfg. Since you still have that line in your version, I'm wondering if you've got messed up / mixed up versions of some source files that you're trying to compile?

Perpetuum_Mobile
Space Krill
Posts: 6
Joined: Wed Nov 24, 2010 5:36 am
Location: Ukraine

Re: Segmentation Fault / Ubuntu 9.10 / 2005 Radeon Card

#17 Post by Perpetuum_Mobile » Sun Nov 28, 2010 12:14 pm

ok then, but how about
mobil% less ~/.freeorion/ogre.log|grep EXCEPTION
14:10:02: OGRE EXCEPTION(6:FileNotFoundException): Cannot locate resource GLX_icon.png in resource group General or any other group. in ResourceGroupManager::openResource at OgreResourceGroupManager.cpp (line 763)

User avatar
Geoff the Medio
Programming, Design, Admin
Posts: 12381
Joined: Wed Oct 08, 2003 1:33 am
Location: Munich

Re: Segmentation Fault / Ubuntu 9.10 / 2005 Radeon Card

#18 Post by Geoff the Medio » Sun Nov 28, 2010 12:29 pm

Perpetuum_Mobile wrote:ok then, but how about
mobil% less ~/.freeorion/ogre.log|grep EXCEPTION
14:10:02: OGRE EXCEPTION(6:FileNotFoundException): Cannot locate resource GLX_icon.png in resource group General or any other group. in ResourceGroupManager::openResource at OgreResourceGroupManager.cpp (line 763)
Some people seem to have issues with GLX_icon.png for some reason. I don't know what the deal is with it, but it's discussed on this thread, with some changes that reportedly fix it: viewtopic.php?p=41056#p41056

Perpetuum_Mobile
Space Krill
Posts: 6
Joined: Wed Nov 24, 2010 5:36 am
Location: Ukraine

Re: Segmentation Fault / Ubuntu 9.10 / 2005 Radeon Card

#19 Post by Perpetuum_Mobile » Sun Nov 28, 2010 7:43 pm

# patched ./client/human/chmain.cpp.orig
# changed ./default/data/art/combat/resources.cfg
# copied GLX_icon.png to ./default/data/art
# compiled the game
rm CMakeCache.txt
make clean
cmake .
make
# ran the game
Linking CXX executable ../../freeorion
[100%] Built target freeorion
mobil% ./freeorion
main() caught exception(std::exception): OGRE EXCEPTION(6:FileNotFoundException): '/home/mobil/temp/freeorion/FreeOrion/resources.cfg' file not found! in ConfigFile::load at OgreConfigFile.cpp (line 84)
# copied ./default/data/art/combat/resources.cfg to FreeOrion/
cp ./default/data/art/combat/resources.cfg ./
# ran the game
mobil% ./freeorion
zsh: segmentation fault ./freeorion
~/.freeorion/ogre.log in attachment
Attachments
ogre.log
(9.25 KiB) Downloaded 53 times

Perpetuum_Mobile
Space Krill
Posts: 6
Joined: Wed Nov 24, 2010 5:36 am
Location: Ukraine

Re: Segmentation Fault / Ubuntu 9.10 / 2005 Radeon Card

#20 Post by Perpetuum_Mobile » Sun Nov 28, 2010 7:56 pm

Also, since Cg is not necessary, the command to load it has been removed from the SVN version of ogre_plugins.cfg. Since you still have that line in your version, I'm wondering if you've got messed up / mixed up versions of some source files that you're trying to compile?
the first time i was trying to compile version from svn
the next time i downloaded revisions, that relates to last release & compiled them

User avatar
Geoff the Medio
Programming, Design, Admin
Posts: 12381
Joined: Wed Oct 08, 2003 1:33 am
Location: Munich

Re: Segmentation Fault / Ubuntu 9.10 / 2005 Radeon Card

#21 Post by Geoff the Medio » Sun Nov 28, 2010 10:38 pm

Perpetuum_Mobile wrote:~/.freeorion/ogre.log in attachment
The ogre.log you posted seems to just end abruptly in the middle of the listing of framebuffer objects that are supported. This doesn't appear to be due to something specific FreeOrion is doing, but rather is happening in the middle of a series of other sucessful checks during initialization. So, I'm inclined to assume this is some sort of driver bug or incompatibility with OGRE...

You might try using a newer version of OGRE if you can get it or compile it. You appear to be using 1.6.4, and 1.7.2 is available on the OGRE website.

User avatar
OndrejR
Space Dragon
Posts: 339
Joined: Thu Oct 02, 2008 11:00 pm
Location: Slovakia

Re: Segmentation Fault / Ubuntu 9.10 / 2005 Radeon Card

#22 Post by OndrejR » Mon Nov 29, 2010 6:29 am

Perpetuum_Mobile wrote:the first time i was trying to compile version from svn
the next time i downloaded revisions, that relates to last release & compiled them
There were fixed bugs since last release. It is important to use latest svn with specific Gigi revision 853.

Post Reply