0.3.14 crashes while mouse-moving (Win32)

Problems and solutions for installing or running FreeOrion, including discussion of bugs if needed before posting a bug report. For problems building from source, post in Compile.

Moderators: Oberlus, Oberlus

Post Reply
Message
Author
hacky
Space Krill
Posts: 2
Joined: Sat Jul 17, 2010 7:34 pm

0.3.14 crashes while mouse-moving (Win32)

#1 Post by hacky » Sat Jul 17, 2010 9:09 pm

After successfully starting a new singleplayer game
while moving the mouse cursor over stars there should be a single sound but frequently there will be a sound loop repeatedly playing for about 2 seconds and then the game exits back to desktop without an error message.
The same happens (frequently) even by pointing at fleets.
Clicking around in the tech tree does not crash the game.


I have tried to switch off all sounds in the option menu which did not stop this crash.
I also tried running the game using 1600x1050 full screen mode and later 1024x768 windowed but the problem does not disappear.



OS: XP prof 32 bit SP3
freeorion 0.3.14 (Rev 3571)
ATI Radeon HD 5770 27.05.2010 / 8.741.0.0

(freeoriond.log):
2010-07-17 22:49:26,375 DEBUG Server : (ServerFSM) Idle
2010-07-17 22:49:26,375 DEBUG Server : FreeOrion server waiting for network events
2010-07-17 22:49:26,765 DEBUG Server : (ServerFSM) Idle.HostSPGame
2010-07-17 22:49:26,765 DEBUG Server : (ServerFSM) ~Idle
2010-07-17 22:49:26,765 DEBUG Server : (ServerFSM) WaitingForSPGameJoiners
2010-07-17 22:49:29,390 DEBUG Server : InitializeSystemGraph(-1) system_ids: (461)
2010-07-17 22:49:29,390 DEBUG Server : starting E:\Programme\FreeOrion\freeorionca.exe
2010-07-17 22:49:29,406 DEBUG Server : done starting E:\Programme\FreeOrion\freeorionca.exe
2010-07-17 22:49:29,406 DEBUG Server : starting E:\Programme\FreeOrion\freeorionca.exe
2010-07-17 22:49:29,406 DEBUG Server : done starting E:\Programme\FreeOrion\freeorionca.exe
2010-07-17 22:49:29,406 DEBUG Server : starting E:\Programme\FreeOrion\freeorionca.exe
2010-07-17 22:49:29,406 DEBUG Server : done starting E:\Programme\FreeOrion\freeorionca.exe
2010-07-17 22:49:29,406 DEBUG Server : starting E:\Programme\FreeOrion\freeorionca.exe
2010-07-17 22:49:29,406 DEBUG Server : done starting E:\Programme\FreeOrion\freeorionca.exe
2010-07-17 22:49:29,406 DEBUG Server : starting E:\Programme\FreeOrion\freeorionca.exe
2010-07-17 22:49:29,406 DEBUG Server : done starting E:\Programme\FreeOrion\freeorionca.exe
2010-07-17 22:49:29,406 DEBUG Server : starting E:\Programme\FreeOrion\freeorionca.exe
2010-07-17 22:49:29,406 DEBUG Server : done starting E:\Programme\FreeOrion\freeorionca.exe
2010-07-17 22:49:29,406 DEBUG Server : starting E:\Programme\FreeOrion\freeorionca.exe
2010-07-17 22:49:29,421 DEBUG Server : done starting E:\Programme\FreeOrion\freeorionca.exe
2010-07-17 22:49:29,421 DEBUG Server : starting E:\Programme\FreeOrion\freeorionca.exe
2010-07-17 22:49:29,421 DEBUG Server : done starting E:\Programme\FreeOrion\freeorionca.exe
2010-07-17 22:49:29,421 DEBUG Server : starting E:\Programme\FreeOrion\freeorionca.exe
2010-07-17 22:49:29,421 DEBUG Server : done starting E:\Programme\FreeOrion\freeorionca.exe
2010-07-17 22:49:29,421 DEBUG Server : starting E:\Programme\FreeOrion\freeorionca.exe
2010-07-17 22:49:29,437 DEBUG Server : done starting E:\Programme\FreeOrion\freeorionca.exe
2010-07-17 22:49:29,437 DEBUG Server : starting E:\Programme\FreeOrion\freeorionca.exe
2010-07-17 22:49:29,437 DEBUG Server : done starting E:\Programme\FreeOrion\freeorionca.exe
2010-07-17 22:49:29,437 DEBUG Server : starting E:\Programme\FreeOrion\freeorionca.exe
2010-07-17 22:49:29,437 DEBUG Server : done starting E:\Programme\FreeOrion\freeorionca.exe
2010-07-17 22:49:29,437 DEBUG Server : (ServerFSM) WaitingForSPGameJoiners.CheckStartConditions
~~~~~~~~
2010-07-17 22:52:45,171 DEBUG Server : (ServerFSM) WaitingForTurnEnd.TurnOrders
2010-07-17 22:52:45,171 DEBUG Server : WaitingForTurnEnd.TurnOrders : Received orders from player 2
2010-07-17 22:52:45,171 DEBUG Server : ServerApp::AllOrdersReceived()
2010-07-17 22:52:51,625 DEBUG Server : ServerFSM::HandleNonLobbyDisconnection : Host player disconnected; server terminating.
2010-07-17 22:52:53,625 FATAL Server : Initiating Exit (code 1 - error termination)

(freeorion.log):
2010-07-17 22:49:21,796 DEBUG Client : OpenAL initialized. Version 1.1Renderer SoftwareVendor Creative Labs Inc.
Extensions: EAX EAX2.0 EAX3.0 EAX4.0 EAX5.0 EAX3.0EMULATED EAX4.0EMULATED AL_EXT_OFFSET AL_EXT_LINEAR_DISTANCE AL_EXT_EXPONENT_DISTANCE

2010-07-17 22:49:21,921 DEBUG Client : BuildDesignatorWnd::BuildSelector::Refresh()
2010-07-17 22:49:21,921 DEBUG Client : BuildDesignatorWnd::BuildSelector::PopulateList() : Adding Buildings
2010-07-17 22:49:21,984 DEBUG Client : BuildDesignatorWnd::BuildSelector::PopulateList() : Adding ship designs
2010-07-17 22:49:21,984 DEBUG Client : Selecting Row
2010-07-17 22:49:21,984 DEBUG Client : Done
2010-07-17 22:49:22,015 DEBUG Client : Disabled FPS limit
~~~
2010-07-17 22:52:42,625 DEBUG Client : trying to find stockpile system group... stockpile system has id: 269
2010-07-17 22:52:42,625 DEBUG Client : potential group:
2010-07-17 22:52:42,625 DEBUG Client : ....269
2010-07-17 22:52:42,625 DEBUG Client : ....284
2010-07-17 22:52:42,625 DEBUG Client : MapWnd::RefreshMineralsResourceIndicator found group of systems for stockpile system. size: 2
2010-07-17 22:52:42,625 DEBUG Client : ResourcePool::GroupAvailable(269)
2010-07-17 22:52:42,625 DEBUG Client : ResourcePool::GroupProdeuction(269)
2010-07-17 22:52:42,625 DEBUG Client : minerals available in stockpile group is: 7.68859
2010-07-17 22:52:42,625 DEBUG Client : minerals allocation in stockpile group is: 7.68859
2010-07-17 22:52:42,625 DEBUG Client : Predicted stockpile is: 0
2010-07-17 22:52:42,625 DEBUG Client : Old stockpile is 0
2010-07-17 22:52:42,625 DEBUG Client : Stockpile change is: 0
2010-07-17 22:52:42,625 DEBUG Client : BuildDesignatorWnd::BuildSelector::Refresh()
2010-07-17 22:52:42,625 DEBUG Client : BuildDesignatorWnd::BuildSelector::PopulateList() : Adding Buildings
2010-07-17 22:52:42,625 DEBUG Client : BuildDesignatorWnd::BuildSelector::PopulateList() : Adding ship designs
2010-07-17 22:52:42,625 DEBUG Client : Selecting Row
2010-07-17 22:52:42,625 DEBUG Client : Done
2010-07-17 22:52:42,625 DEBUG Client : MapWnd::InitTurn m_production_wnd refresh time: 0
2010-07-17 22:52:42,625 DEBUG Client : MapWnd::InitTurn time: 250

User avatar
Geoff the Medio
Programming, Design, Admin
Posts: 12457
Joined: Wed Oct 08, 2003 1:33 am
Location: Munich

Re: 0.3.14 crashes while mouse-moving (Win32)

#2 Post by Geoff the Medio » Sat Jul 17, 2010 11:06 pm

Hmm. I've never heard (no pun intended) of this problem before. I'd guess it's a driver issue and/or incompatibility with OpenAL, which will make it difficult for us to fix. You could try making sure your audio drivers are fully up to date, if possible.

What happens if you delete all the .wav files in FreeOrion\default\data\sound ?

hacky
Space Krill
Posts: 2
Joined: Sat Jul 17, 2010 7:34 pm

Re: 0.3.14 crashes while mouse-moving (Win32)

#3 Post by hacky » Sun Jul 18, 2010 12:03 am

I moved all the *wav files from
\FreeOrion\default\data\sound
\FreeOrion\default\data\sound\combat
and kept only those artificial_intelligence_v3.ogg

But.. even without those *wav files AND without those *.ogg the game crashes.

This doesn't work so my computer will be cleaned and newly installed tomorrow :evil: .

it could be a problem with the onboard sound chip (VIA VT1708S)
Strange enough, i disabled the onboard sound using the bios setup but most the time when I tried to move a fleet (just clicking on it!!) I was looking at the desktop again :(

Those automatically save every turn was a VERY good idea ;)
BTW: Sorting the savefiles BACKwards would be a little help ..
What a pity! This game is -as far I have seen it by now- very good. This must be the reason why I still try those painful reload again and again :wink:

I will tell you, if (or if not) something helped but before Monday evening i wont be back.

User avatar
MareviQ
Space Kraken
Posts: 100
Joined: Tue Aug 09, 2005 6:47 pm
Location: Somewhere in Poland

Re: 0.3.14 crashes while mouse-moving (Win32)

#4 Post by MareviQ » Mon Jul 19, 2010 10:27 am

The sound loop does not have to indicate a sound problem - the sound system updates sound buffers at each frame (it's not in a separate thread). Anything that would crash the game could cause this effect (buffer not updated in time and played repeatedly). As far as I remember the sound system is quite careful as to what it plays and it should spew error messages if anything goes wrong. I'll take a look at it today.
abs(imag(ME) / abs(ME)) = exp(PI) - PI - 19;

Post Reply