pcm_params.c OpenAL PulseAudio Crash

Problems and solutions for installing or running FreeOrion, including discussion of bugs if needed before posting a bug report. For problems building from source, post in Compile.

Moderators: Oberlus, Oberlus

Post Reply
Message
Author
tashlan
Space Krill
Posts: 2
Joined: Sun Jul 25, 2010 9:56 pm

pcm_params.c OpenAL PulseAudio Crash

#1 Post by tashlan » Sun Jul 25, 2010 11:53 pm

First of all, that you to everyone involved in creating, designing, and supporting this 'libre' game. It looks promising and is something I look forward to spending many nights playing. That said, I ran into a problem I'd like some basic help with.

I downloaded the statically linked version of 3.14.1, ran the installer as root with no errors, but receive the following error when I attempt to start the game as any user:

Code: Select all

$ freeorion-start 
I am Symlink. Following into my targets basedir
CWD: /usr/local/games/freeorion/application
python2.5 found. Using it.
freeorion: pcm_params.c:2333: sndrv_pcm_hw_params: Assertion `err >= 0' failed.
/usr/local/bin/freeorion-start: line 143:  3167 Aborted                 ${FO_TRACE} ${FO_GDB_ARGS} ./freeorion --resource-dir ./default $@
At the moment, I'm running Fedora 8 (2.6.26.8-57.fc8) with pulse-audio. Alsa is also installed and working.

I looked for a switch allowing me to start the game without sound, hoping to still get to test the game out a bit, but all I found was the -m switch (no music) and that does not help. Is there a hidden switch to start the game without sound for some quick testing before committing to getting the sound working properly?
Linux, helping you separate the wheat from the shaft.

User avatar
Geoff the Medio
Programming, Design, Admin
Posts: 12457
Joined: Wed Oct 08, 2003 1:33 am
Location: Munich

Re: Does not start on Linux

#2 Post by Geoff the Medio » Mon Jul 26, 2010 12:05 am

There is a "--UI.sound.enabled" command line switch, but I don't believe it will solve your problem with v0.3.14.1 on Linux. The SVN version might work better with that option set to false ("0"), in that it should actually not attempt to play any non-music sounds, but I think the OpenAL initialization code will still be run even with sound not enabled. Some code tweaks could probably be done to actually fully disable sound, though in either case some compiling would likely be required.

tashlan
Space Krill
Posts: 2
Joined: Sun Jul 25, 2010 9:56 pm

Re: Does not start on Linux

#3 Post by tashlan » Mon Jul 26, 2010 3:33 am

Thanks for the advise and quick reply. I tried it and you are correct, I get the same results.

I am going to be migrating soon to Fedora 13 and will try again in that environment rather than burn cycles in FC8. I wanted to test it in my old environment first since the game is an out-of-repository and non-rpm install. I didn't want to clutter up my brand-new setup with an untested "self-service" install if it could be helped.

Thanks again for your help.
Linux, helping you separate the wheat from the shaft.

User avatar
MareviQ
Space Kraken
Posts: 100
Joined: Tue Aug 09, 2005 6:47 pm
Location: Somewhere in Poland

Re: Does not start on Linux

#4 Post by MareviQ » Fri Jul 30, 2010 9:04 am

This is a problem on ALSA-pulseaudio level. It's a known bug (googling it shows mainly Ekiga and ALSA bugtrackers). It should help if we can get it to try to use pulseaudio oss emulation first, but as I can see from OpenAL IRC logs the config file syntax has changed, so it'll take me some time to work this out.

Edit: But first, let's try if the old one still works.
Try creating a .openalrc file in your home directory and paste this into it:

Code: Select all

(define devices '(dsp native null))
Then check if FreeOrion still crashes.
abs(imag(ME) / abs(ME)) = exp(PI) - PI - 19;

Post Reply