Mouse and Rendering issues

Problems and solutions for installing or running FreeOrion, including discussion of bugs if needed before posting a bug report. For problems building from source, post in Compile.

Moderators: Oberlus, Oberlus

Post Reply
Message
Author
schm0
Space Krill
Posts: 3
Joined: Tue Dec 07, 2010 2:02 am

Mouse and Rendering issues

#1 Post by schm0 » Tue Dec 07, 2010 2:18 am

Hello there,

I'm completely brand new, but I did my due diligence and checked out the bugtracker and support forums before posting.

So, when I launch the game, I'm getting this strange garbledness behind the mouse cursor:

Image

Inside the game:

Image

Image

Any ideas?

User avatar
Geoff the Medio
Programming, Design, Admin
Posts: 12422
Joined: Wed Oct 08, 2003 1:33 am
Location: Munich

Re: Mouse and Rendering issues

#2 Post by Geoff the Medio » Tue Dec 07, 2010 2:31 am

Graphical glitches such as this are usually driver issues. Make sure you've got the latest available drivers for your hardware, preferably from the graphics hardware manufacturer, and not Microsoft or your computer maker.

schm0
Space Krill
Posts: 3
Joined: Tue Dec 07, 2010 2:02 am

Re: Mouse and Rendering issues

#3 Post by schm0 » Tue Dec 07, 2010 5:35 am

Just updated my drivers last month... Hmmm.

User avatar
Geoff the Medio
Programming, Design, Admin
Posts: 12422
Joined: Wed Oct 08, 2003 1:33 am
Location: Munich

Re: Mouse and Rendering issues

#4 Post by Geoff the Medio » Tue Dec 07, 2010 5:37 am

The drivers may just not work well with OpenGL, or the specific bits and way of using the bits that FreeOrion (and its dependencies) needs.

It might help to switch between fullscreen and windowed modes.

schm0
Space Krill
Posts: 3
Joined: Tue Dec 07, 2010 2:02 am

Re: Mouse and Rendering issues

#5 Post by schm0 » Wed Dec 08, 2010 4:59 pm

Yeah, not sure... the problem exists in both versions.

Oh, well, I'll try updating my drivers again and if not just wait for the next version of FO to come out.

redhound
Space Krill
Posts: 7
Joined: Sat Dec 24, 2011 5:30 pm

Re: Mouse and Rendering issues

#6 Post by redhound » Sun Dec 25, 2011 5:59 pm

Have a similar issues with Linux version, builded from svn on Ubuntu 11.10 x86_64. I'm using latest proprietary Catalyst drivers (11.12). Fullscreen / windowed mode doesn't matter.

Static build of freeorion 0.3.15 for Linux does not have this issues.

Post Reply