AIs forgot how to capiture planets?

Describe your experience with the latest version of FreeOrion to help us improve it.
Forum rules
Always mention the exact version of FreeOrion you are testing.

When reporting an issue regarding the AI, if possible provide the relevant AI log file and a save game file that demonstrates the issue.
Post Reply
Message
Author
Brandon
Space Krill
Posts: 1
Joined: Mon Aug 01, 2016 6:22 am

AIs forgot how to capiture planets?

#1 Post by Brandon » Mon Aug 01, 2016 6:32 am

Hi all,

I have been playing Free Orion once or twice a few times a year. I love the direction you have taken with it and I am liking how the tech tree is filling out with some amazing tech ideas and near as i can tell most of them work.

On this last play through I was having a whole lot of fun with stealth. Get some stealth and and mine tech I no longer need to worry about defense it is wonderful.

On a side note I played a few different games recently for testing and I noticed that the AIs seem to have forgotten how to capture planets. This is when they can see me, or even against other AIs. Assuming the stats reflect what really is happening it looks like a few AIs can figure out how to capture 1 or at most 2 planets each early in the game. At a certain point it looks like something changes and they are unable to figure out how.(This is with the highest AI aggression settings)

Looking at them trying to attack me it looks like they have the troops, they just never move them to the front lines anymore.

Anyhow a lot of fun as always and loving to see how the tech has been filling out. Also love to see the new stuff for the core slots :)

User avatar
Vezzra
Release Manager, Design
Posts: 4666
Joined: Wed Nov 16, 2011 12:56 pm
Location: Sol III

Re: AIs forgot how to capiture planets?

#2 Post by Vezzra » Mon Aug 01, 2016 9:16 am

There has been a (recently introduced) bug which prevented the AI from invading, which has been fixed just yesterday. Next Tuesdays test builds will already contain that fix. Try again with the new build once it is out, and see if that fixes the problem for you. If not, please report back.

Post Reply