Unknown source for wasted PPs

Describe your experience with the latest version of FreeOrion to help us improve it.
Forum rules
Always mention the exact version of FreeOrion you are testing.

When reporting an issue regarding the AI, if possible provide the relevant AI log file and a save game file that demonstrates the issue.
Post Reply
Message
Author
User avatar
Oberlus
Vacuum Dragon
Posts: 662
Joined: Mon Apr 10, 2017 4:25 pm

Unknown source for wasted PPs

#1 Post by Oberlus » Mon Apr 24, 2017 7:49 am

Hi,

In my current game I got some red PPs of unknown procedence. I mean, I checked every system, one by one. I only have one system blockaded, in frontline, in which I'm making some comsats for cannon fodder and 5 PPs are wasted in there. Rest of my systems are in one single supply group, each one showing 0.00 PPs wasted. Yet I get a total wasted points of 25.7. I examined the whole map looking for the contrasting colors in the supply lines and also I used the top-right button of the planets panel to scroll through all the systems, noting wasted PPs for each one. I can't find the source of those misterious 20.7 PPs.

I attach a save file just in case.

PS: after clicking on "next turn", the unknown wasted PPs are gone.
Attachments

[The extension sav has been deactivated and can no longer be displayed.]


User avatar
Dilvish
AI Lead, Programmer
Posts: 4683
Joined: Sat Sep 22, 2012 6:25 pm

Re: Unknown source for wasted PPs

#2 Post by Dilvish » Mon Apr 24, 2017 9:05 am

It's all wasted at that Schmidt system that you are brought to by clicking the wasted PP icon. The problem is in the summary of wasted points in the Production Queue top panel -- the "Points Available Here" and the "Wasted Points" [Here] won't update just by changing the selected planet, although when the system is blockaded like that each planet is a separate Resource Group. To get it to update, close and reopen the Production Window each time after selecting a new planet in the system. You'll see that Schmidt I is using all its 5 points, Schmidt II is wasting 20.7 and Schmidt III is wasting 5, for the total of 25.7.

Looking at the code a bit, it seems that the various PlanetSelectedSignal (s) are not sufficiently connected to take care of this to update that info panel when the planet selection changes. I'll see if I can figure out an expeditious connection to make to solve this problem.
If I provided any code, scripts or other content here, it's released under GPL 2.0 and CC-BY-SA 3.0

User avatar
Dilvish
AI Lead, Programmer
Posts: 4683
Joined: Sat Sep 22, 2012 6:25 pm

Re: Unknown source for wasted PPs

#3 Post by Dilvish » Mon Apr 24, 2017 9:44 am

I've now put up a PR with a fix.
If I provided any code, scripts or other content here, it's released under GPL 2.0 and CC-BY-SA 3.0

User avatar
Oberlus
Vacuum Dragon
Posts: 662
Joined: Mon Apr 10, 2017 4:25 pm

Re: Unknown source for wasted PPs

#4 Post by Oberlus » Mon Apr 24, 2017 4:17 pm

Well done :D

Post Reply