Starlane crosses over system (Experimentors)

Describe your experience with the latest version of FreeOrion to help us improve it.
Forum rules
Always mention the exact version of FreeOrion you are testing.

When reporting an issue regarding the AI, if possible provide the relevant AI log file and a save game file that demonstrates the issue.
Post Reply
Message
Author
User avatar
Oberlus
Juggernaut
Posts: 764
Joined: Mon Apr 10, 2017 4:25 pm

Starlane crosses over system (Experimentors)

#1 Post by Oberlus » Thu May 11, 2017 10:56 pm

See the attached image.
starlane_crossing_over_system.jpg
starlane_crossing_over_system.jpg (152.94 KiB) Viewed 319 times
I attach the save game and the logs just in case this is something that must be dealed with.
Even if the starlane thing is not relevant, it may be interesting to check AI4 and AI5 logs. They are cluttered of "[error] ai : Pathfinder.cpp:1100 : Passed invalid system id: -1" messages (tens of them for each millisecond). AI_5.log has near 7k lines (I guess 99.9% is that error message) for a session of about 5 turns of playing since I started FO and loaded previous game.
Attachments
freeorion_and_ai_logs.zip
(11.79 KiB) Downloaded 4 times
laenfa_experimentors_269.sav.zip.002.zip
Compressed with 7z, zip format. Remove last ".zip" from filename (added to bypass PHP filter)
(1.48 MiB) Downloaded 4 times
laenfa_experimentors_269.sav.zip.001.zip
Compressed with 7z, zip format. Remove last ".zip" from filename (added to bypass PHP filter)
(3 MiB) Downloaded 6 times

User avatar
Vezzra
Release Manager, Design
Posts: 4696
Joined: Wed Nov 16, 2011 12:56 pm
Location: Sol III

Re: Starlane crosses over system (Experimentors)

#2 Post by Vezzra » Fri May 12, 2017 8:23 am

Hm, that's definitely an issue. Not a really serious one (doesn't break anything), but still shouldn't be happening. The other thing with those error messages in the AI logs is a completely unrelated, separate issue, which also needs to be investigated.

Can you open two issues on github for these?

User avatar
Oberlus
Juggernaut
Posts: 764
Joined: Mon Apr 10, 2017 4:25 pm

Re: Starlane crosses over system (Experimentors)

#3 Post by Oberlus » Fri May 12, 2017 12:49 pm


User avatar
Vezzra
Release Manager, Design
Posts: 4696
Joined: Wed Nov 16, 2011 12:56 pm
Location: Sol III

Re: Starlane crosses over system (Experimentors)

#4 Post by Vezzra » Fri May 12, 2017 1:35 pm

Thanks!

User avatar
Oberlus
Juggernaut
Posts: 764
Joined: Mon Apr 10, 2017 4:25 pm

Re: Starlane crosses over system (Experimentors)

#5 Post by Oberlus » Fri May 12, 2017 2:33 pm

You're more than welcome.

User avatar
Dilvish
AI Lead, Programmer
Posts: 4749
Joined: Sat Sep 22, 2012 6:25 pm

Re: Starlane crosses over system (Experimentors)

#6 Post by Dilvish » Fri May 12, 2017 8:44 pm

The AI error is sounding like some trouble that had started with some recent changes I made, which I had thought I had gotten all tamped down but perhaps not; I'll follow up on it.
If I provided any code, scripts or other content here, it's released under GPL 2.0 and CC-BY-SA 3.0

Post Reply