0.4.7 ship not being repaired with orbital drydock

Describe your experience with the latest version of FreeOrion to help us improve it.
Forum rules
Always mention the exact version of FreeOrion you are testing.

When reporting an issue regarding the AI, if possible provide the relevant AI log file and a save game file that demonstrates the issue.
Post Reply
Message
Author
tarski
Space Krill
Posts: 3
Joined: Mon May 29, 2017 9:13 pm

0.4.7 ship not being repaired with orbital drydock

#1 Post by tarski » Mon May 29, 2017 9:21 pm

Hi guys,

My Frigate at Lemaitre isn't being repaired by the orbital drydock there. I'm not sure why (maybe it's a bug). The happiness is 25 and there's a shipyard + drydock at the system, no combat, no movement so I'm baffled as to why it isn't working.

If anyone can figure it out please let me know!

Thanks,

p.s. i'm really enjoying the game
Attachments
Screen Shot 2017-05-29 at 22.12.39 1.png
Screen Shot 2017-05-29 at 22.12.39 1.png (887.95 KiB) Viewed 280 times

[The extension sav has been deactivated and can no longer be displayed.]


User avatar
MatGB
Creative Contributor
Posts: 3310
Joined: Fri Jun 28, 2013 11:45 pm

Re: 0.4.7 ship not being repaired with orbital drydock

#2 Post by MatGB » Mon May 29, 2017 10:19 pm

Screenshot shows a drydock that hasn't been built yet, I'm testing some new code that breaks old saves, can you confirm if that's the case to save me recompiling?
Mat Bowles

Any code or patches in anything posted here is released under the CC and GPL licences in use for the FO project.

User avatar
Geoff the Medio
Programming, Design, Admin
Posts: 12268
Joined: Wed Oct 08, 2003 1:33 am
Location: Munich

Re: 0.4.7 ship not being repaired with orbital drydock

#3 Post by Geoff the Medio » Tue May 30, 2017 7:24 am

MatGB wrote:Screenshot shows a drydock that hasn't been built yet...
Seems to be correct. Move it up the production queue, and on the turn it finishes, the ship is repaired.

Post Reply