Bug Complaint [Moved]

Describe your experience with the latest version of FreeOrion to help us improve it.
Forum rules
Always mention the exact version of FreeOrion you are testing.

When reporting an issue regarding the AI, if possible provide the relevant AI log file and a save game file that demonstrates the issue.
Post Reply
Message
Author
defaultuser
Vacuum Dragon
Posts: 566
Joined: Wed Aug 26, 2015 6:15 pm

Bug Complaint [Moved]

#1 Post by defaultuser » Mon Jun 19, 2017 5:05 pm

When it comes to bugs, this one is the biggest problem for me:

https://github.com/freeorion/freeorion/issues/676

dbenage-cx
Programmer
Posts: 389
Joined: Sun Feb 14, 2016 12:08 am

Re: Bug Complaint [Moved]

#2 Post by dbenage-cx » Tue Jun 20, 2017 10:48 pm

Hi defaultuser,

I posted a reply to the thread for the linked issue, so that the information is less scattered.
Any content posted should be considered licensed GNU GPL 2.0 and/or CC-BY-SA 3.0 as appropriate.

defaultuser
Vacuum Dragon
Posts: 566
Joined: Wed Aug 26, 2015 6:15 pm

Re: Bug Complaint [Moved]

#3 Post by defaultuser » Wed Jun 21, 2017 1:56 am

Yes, I have seen it. This was originally just a reminder in the bug discussion that there is one that for a few souls is a game-breaker.

User avatar
Vezzra
Release Manager, Design
Posts: 4666
Joined: Wed Nov 16, 2011 12:56 pm
Location: Sol III

Re: Bug Complaint [Moved]

#4 Post by Vezzra » Wed Jun 21, 2017 1:32 pm

defaultuser wrote:This was originally just a reminder in the bug discussion that there is one that for a few souls is a game-breaker.
Unfortunately I fear it's more than just a few souls who suffer from this bug. Systems with Intel integrated graphics aren't exactly a rare, exotic setup.

However, unless one of the devs (who is capable of troubleshooting the code parts in question) is able to reliably reproduce that buggy behaviour, chances of fixing this are slim... :(

defaultuser
Vacuum Dragon
Posts: 566
Joined: Wed Aug 26, 2015 6:15 pm

Re: Bug Complaint [Moved]

#5 Post by defaultuser » Wed Jun 21, 2017 4:46 pm

I could get set up to build and I am a software engineer, but trouble-shooting graphics is likely not going to be a "shallow dive".

User avatar
Vezzra
Release Manager, Design
Posts: 4666
Joined: Wed Nov 16, 2011 12:56 pm
Location: Sol III

Re: Bug Complaint [Moved]

#6 Post by Vezzra » Thu Jun 22, 2017 3:02 pm

defaultuser wrote:trouble-shooting graphics is likely not going to be a "shallow dive".
Your assessment is very likely spot on. Which is why it would be ideal if one of the devs familiar with the GG code could reproduce and troubleshoot that issue.

However, if you could get set up to build you could try to narrow down which commit introduced the issue, that would probably help a lot I guess (Geoff?). Probably going to be a thoroughly tedious git bisect operation, but might be worth it.

User avatar
Oberlus
Small Juggernaut
Posts: 704
Joined: Mon Apr 10, 2017 4:25 pm

Re: Bug Complaint [Moved]

#7 Post by Oberlus » Thu Jun 22, 2017 3:17 pm

Given that many people in many applications has or have had problems of mouse disappearance and screen flickering in Windows as well as Linux (many distributions) with Intel Integrated Graphics, might it be that the problem was introduced by some version of the GPU graphics or some of the libraries used in FO?

defaultuser
Vacuum Dragon
Posts: 566
Joined: Wed Aug 26, 2015 6:15 pm

Re: Bug Complaint [Moved]

#8 Post by defaultuser » Thu Jun 22, 2017 3:32 pm

In this thread, I have documented some data I have accumulated:

http://www.freeorion.org/forum/viewtopi ... =25&t=9768

It's possible that analysis of windows that cause the mouse to disappear and those that don't could provide some insight.

I will take a look at getting set up for build, but I make no promises. I had planned to do that AR (after retirement) which has been stretching on a bit as there are things I want to finish up at work and personally before I "pull the plug".

User avatar
EricF
Space Dragon
Posts: 270
Joined: Fri Jul 29, 2016 10:12 am

Re: Bug Complaint [Moved]

#9 Post by EricF » Wed Jul 05, 2017 6:40 am

I have a new windows 10 machine and don't have any of these problems.
Would info about my box to compare to one that has problems be helpful?
I'll be happy to oblige.

User avatar
EricF
Space Dragon
Posts: 270
Joined: Fri Jul 29, 2016 10:12 am

Re: Bug Complaint [Moved]

#10 Post by EricF » Wed Jul 05, 2017 6:44 am

Vezzra wrote:
defaultuser wrote:This was originally just a reminder in the bug discussion that there is one that for a few souls is a game-breaker.
Unfortunately I fear it's more than just a few souls who suffer from this bug. Systems with Intel integrated graphics aren't exactly a rare, exotic setup.

However, unless one of the devs (who is capable of troubleshooting the code parts in question) is able to reliably reproduce that buggy behaviour, chances of fixing this are slim... :(
I do not have Intel integrated graphics.

User avatar
Oberlus
Small Juggernaut
Posts: 704
Joined: Mon Apr 10, 2017 4:25 pm

Re: Bug Complaint [Moved]

#11 Post by Oberlus » Wed Jul 05, 2017 7:38 am

EricF wrote:I do not have Intel integrated graphics.
Me neither. It's in Intel drivers where the issue lies.

Post Reply