Game crashes issue 1680

Describe your experience with the latest version of FreeOrion to help us improve it.
Forum rules
Always mention the exact version of FreeOrion you are testing.

When reporting an issue regarding the AI, if possible provide the relevant AI log file and a save game file that demonstrates the issue.
Message
Author
User avatar
EricF
Space Dragon
Posts: 266
Joined: Fri Jul 29, 2016 10:12 am

Game crashes issue 1680

#1 Post by EricF » Wed Aug 16, 2017 2:15 pm

https://github.com/freeorion/freeorion/issues/1680

Playing latest test build; FreeOrion_2017-08-15.03fa4c6_Test_Win32_Setup
on Windows 10.

Not sure if any of this is related but, when I double clicked the installer Windows Defender
(MS new built in malware software for Win10) tried to block it from running. This has never
happened before. The last three or four installs the last couple months I installed fine
without Windows Defender complaining. Something new in the installer? I instructed
WD to let it run. It seemed to install fine.

Started a new game. When trying to add Techs or ships to the build queue the game crashes.
Tried four new games. All crashed before I could complete a turn.
I've never had the game crash like this before.
Last edited by EricF on Sat Aug 19, 2017 6:30 am, edited 1 time in total.

User avatar
MatGB
Creative Contributor
Posts: 3310
Joined: Fri Jun 28, 2013 11:45 pm

Re: Game crashes

#2 Post by MatGB » Wed Aug 16, 2017 2:30 pm

Can you grab the log files as well?

Also, if Win Defender has updated it might be being more picky about the firewall exclusion needed, and while that's in theory disabled for single player now there might be a weird interaction. Beyond that I can't really help, I'll try to test it on my laptop later to confirm.
Mat Bowles

Any code or patches in anything posted here is released under the CC and GPL licences in use for the FO project.

User avatar
Vezzra
Release Manager, Design
Posts: 4605
Joined: Wed Nov 16, 2011 12:56 pm
Location: Sol III

Re: Game crashes

#3 Post by Vezzra » Thu Aug 17, 2017 7:08 am

@ EricF, if you haven't already done so, please open an issue on github.

User avatar
EricF
Space Dragon
Posts: 266
Joined: Fri Jul 29, 2016 10:12 am

Re: Game crashes

#4 Post by EricF » Thu Aug 17, 2017 9:46 am

Logs. Not sure what the issue is to open an issue about.
Game crashes when double click adding items to build or tech queue?
freeoriond.log
(177.8 KiB) Downloaded 3 times
freeorion.log
(32.03 KiB) Downloaded 4 times
It very well may be a Win Defender issue. I'll play around with that some more.

User avatar
EricF
Space Dragon
Posts: 266
Joined: Fri Jul 29, 2016 10:12 am

Re: Game crashes

#5 Post by EricF » Thu Aug 17, 2017 10:19 am

OK, I turned Win Defender off and left it off. Uninstalled and reinstalled the game several times. Changed some settings, left all default settings, started a quick game. Same thing happens. Whenever I try to add an outpost ship to the build queue by double clicking it I get a dialog box telling me the game has stop working and needs to be closed. When I add some techs to the tech queue it will let me add three techs, but as soon as I try to add a fourth the game stops working again.
Am I the only one with this problem? :(

User avatar
Geoff the Medio
Programming, Design, Admin
Posts: 12243
Joined: Wed Oct 08, 2003 1:33 am
Location: Munich

Re: Game crashes

#6 Post by Geoff the Medio » Thu Aug 17, 2017 10:53 am

Does it crash if you click the pedia button on the intro screen menu?

If so, it's probably the same issue as here: https://github.com/freeorion/freeorion/issues/1680

User avatar
Vezzra
Release Manager, Design
Posts: 4605
Joined: Wed Nov 16, 2011 12:56 pm
Location: Sol III

Re: Game crashes

#7 Post by Vezzra » Thu Aug 17, 2017 1:02 pm

EricF wrote:Logs. Not sure what the issue is to open an issue about.
Game crashes when double click adding items to build or tech queue?
Something along these lines, yes.

Does the crash only occur when adding items by double click, or regardless how you add them (e.g. also via the context menu)? In the latter case the issue would be: Game crashes when adding items to build and research queues.

User avatar
Vezzra
Release Manager, Design
Posts: 4605
Joined: Wed Nov 16, 2011 12:56 pm
Location: Sol III

Re: Game crashes

#8 Post by Vezzra » Thu Aug 17, 2017 1:05 pm

Geoff the Medio wrote:Does it crash if you click the pedia button on the intro screen menu?

If so, it's probably the same issue as here: https://github.com/freeorion/freeorion/issues/1680
Quite likely, but it could be an unrelated issue, so I still suggest to open a separate issue (and put a note there: "possibly related to #1680").

User avatar
EricF
Space Dragon
Posts: 266
Joined: Fri Jul 29, 2016 10:12 am

Re: Game crashes

#9 Post by EricF » Thu Aug 17, 2017 1:45 pm

Yes, clicking the Pedia button on the main menu crashes the game as well.
And adding an outpost ship to the build queue by right clicking and selecting Add to queue also crashes the game.
But adding Techs to the queue by right click does not crash the game.

User avatar
MatGB
Creative Contributor
Posts: 3310
Joined: Fri Jun 28, 2013 11:45 pm

Re: Game crashes

#10 Post by MatGB » Thu Aug 17, 2017 2:41 pm

Right clicking a tech doesn't open the Pedia entry for it, right clicking a production item does. So all instances of the crash happen when the pedia is triggered, I suspect Geoff is right.
Mat Bowles

Any code or patches in anything posted here is released under the CC and GPL licences in use for the FO project.

User avatar
Vezzra
Release Manager, Design
Posts: 4605
Joined: Wed Nov 16, 2011 12:56 pm
Location: Sol III

Re: Game crashes

#11 Post by Vezzra » Fri Aug 18, 2017 1:53 pm

MatGB wrote:I suspect Geoff is right.
Pretty much. Just tried a few things, which confirm this theory: On OSX, when I open the production screen and just click on a build item, the game crashes. If I close the pedia window first, I can click on items and also queue them. When I go to the tech screen then, the game crashes. If I go to the tech screen first and close the pedia window there, I can queue techs via double click as usual. When I go to the production screen then, the game does not crash, and I can close the pedia window there too, and afterwards queue items without issues.

Which strongly indicates the pedia is the real issue here.

@EricF: This means it's not necessary to open a separate issue on the github tracker.

ghealy
Space Kraken
Posts: 127
Joined: Sat Jun 06, 2015 2:06 pm

Game crash

#12 Post by ghealy » Sun Aug 20, 2017 9:21 pm

Playing latest test build; FreeOrion_2017-08-15.03fa4c6_Test_Win32_Setup
on Windows 10.

Had same problem starting anew game as stated in this thread http://www.freeorion.org/forum/viewtopi ... 28&t=10677

But after a few crashes I was able to start the game. Everything ran fine until I went t5o custom build a ship, Double-clicking on or dragging a hull into the build window causes the game to crash.

Have attached the two log files I found. Hopefully they shed some light into what happened.

Regards,

Gene
Attachments
freeoriond.log
(24.47 KiB) Downloaded 2 times
freeorion.log
(846.04 KiB) Downloaded 2 times

User avatar
EricF
Space Dragon
Posts: 266
Joined: Fri Jul 29, 2016 10:12 am

Re: Game crashes issue 1680

#13 Post by EricF » Tue Aug 22, 2017 9:30 pm

Bump.
FreeOrion_2017-08-21.7ca62b4_Test_Win32_Setup
has same issue.
Game is unplayable in this state.

User avatar
Vezzra
Release Manager, Design
Posts: 4605
Joined: Wed Nov 16, 2011 12:56 pm
Location: Sol III

Re: Game crashes issue 1680

#14 Post by Vezzra » Thu Aug 24, 2017 7:59 am

A fix (PR#1689) has been attempted and merged, and obviously works for Geoff. For those of you who can compile FO on their systems, can you test if the fix solved the problem for you?

There won't be new test builds next week (due to me travelling), so it will take some time until test builds with that fix are available.

User avatar
Geoff the Medio
Programming, Design, Admin
Posts: 12243
Joined: Wed Oct 08, 2003 1:33 am
Location: Munich

Re: Game crashes issue 1680

#15 Post by Geoff the Medio » Thu Aug 24, 2017 8:04 am

Vezzra wrote:There won't be new test builds next week (due to me travelling)...
Have you left yet? If not, and the issue is resolved for all, an early / out of cycle build would probably be appreciated.

Post Reply