How to Enable Experimentor Always?

Describe your experience with the latest version of FreeOrion to help us improve it.
Forum rules
Always mention the exact version of FreeOrion you are testing.

When reporting an issue regarding the AI, if possible provide the relevant AI log file and a save game file that demonstrates the issue.
Post Reply
Message
Author
User avatar
EnLightning
Krill Swarm
Posts: 13
Joined: Fri Dec 01, 2017 2:32 am

How to Enable Experimentor Always?

#1 Post by EnLightning » Sat Feb 03, 2018 3:09 am

After played around 10 games I only encountered the Experimentor once, and as you developers see, I also caught a bug and reported it in GitHub.

So question is, is there a config option to enable it always to make each game more challenging?
疾如風,徐如林,侵掠如火,不動如山,難知如陰,動如雷震

User avatar
Oberlus
Vacuum Dragon
Posts: 669
Joined: Mon Apr 10, 2017 4:25 pm

Re: How to Enable Experimentor Always?

#2 Post by Oberlus » Sat Feb 03, 2018 8:00 pm

Hi,

AFAIK, Experimentors are enabled by default. They will, though, not appear until relatively late game (after turn 250 or so), and they may not appear at all under certain circumstances that I don't know. However, I have always find Experimentors in every game I've played with standard or bigger map sizes.

User avatar
Vezzra
Release Manager, Design
Posts: 4609
Joined: Wed Nov 16, 2011 12:56 pm
Location: Sol III

Re: How to Enable Experimentor Always?

#3 Post by Vezzra » Sun Feb 04, 2018 11:10 am

EnLightning wrote:So question is, is there a config option to enable it always to make each game more challenging?
Assuming you mean an option that will guarantee that the Experimentors will be spawned in a game, the answer is no. The option currently available under the game rules actually works the other way round: if it is disabled, no Experimentors will be spawned. If it is enabled, you have a certain chance (depending on the game settings, map size and monster frequency the most important one AFAIK) that you'll get them in your game.

Changing that so Experimentors will always be spawned when this option is enabled might make sense. If you want that, please open a respective request on our github issue tracker.

Thats said, the whole Experimentor feature needs a revision anyway.

User avatar
Geoff the Medio
Programming, Design, Admin
Posts: 12249
Joined: Wed Oct 08, 2003 1:33 am
Location: Munich

Re: How to Enable Experimentor Always?

#4 Post by Geoff the Medio » Sun Feb 04, 2018 12:00 pm

Vezzra wrote:Changing that so Experimentors will always be spawned when this option is enabled might make sense.
Aren't there also some requirements for where they can be spawned? Assuming yes, it may not be possible in all universes to spawn them.

LGM-Doyle
Programmer
Posts: 219
Joined: Mon Feb 29, 2016 8:37 pm

Re: How to Enable Experimentor Always?

#5 Post by LGM-Doyle » Sun Feb 04, 2018 1:04 pm

The Experimentors are placed after the empire homeworlds are placed and have a requirement that they be 6 hops from any homeworld. In order to make it more likely that you have Experimentors in a game, you will need a large galaxy with a lower number of empires.

User avatar
Vezzra
Release Manager, Design
Posts: 4609
Joined: Wed Nov 16, 2011 12:56 pm
Location: Sol III

Re: How to Enable Experimentor Always?

#6 Post by Vezzra » Sun Feb 04, 2018 6:36 pm

Geoff the Medio wrote:Aren't there also some requirements for where they can be spawned? Assuming yes, it may not be possible in all universes to spawn them.
That's right, and in order to make sure Experimentors are spawned we'd have to change those requirements accordingly. You just need to be aware that if you enable the Experimentors on a 20 system map with 4 players you can't expect them to be 6 jumps away from all homeworlds...

User avatar
EnLightning
Krill Swarm
Posts: 13
Joined: Fri Dec 01, 2017 2:32 am

Re: How to Enable Experimentor Always?

#7 Post by EnLightning » Sun Feb 04, 2018 8:01 pm

Thank Dev team for the clarification, I'm going to re-think about it and may do some constructive proposal later.
疾如風,徐如林,侵掠如火,不動如山,難知如陰,動如雷震

Post Reply