[6839] feedback

Describe your experience with the latest version of FreeOrion to help us improve it.
Forum rules
Always mention the exact version of FreeOrion you are testing.

When reporting an issue regarding the AI, if possible provide the relevant AI log file and a save game file that demonstrates the issue.
Post Reply
Message
Author
User avatar
Dilvish
AI Lead, Programmer
Posts: 4707
Joined: Sat Sep 22, 2012 6:25 pm

[6839] feedback

#1 Post by Dilvish » Thu Feb 06, 2014 3:45 am

this is probably related to the other recent meter bugs, but is new/different so I'm starting a new thread. The good news is that [6839] does appear to have fixed the ship meter problems, at least as far as I've been able to test. The bad news is that now my planet meters don't update (which they were doing before). This is on a fully clean build, SVN 6839. Meters just sit flat from turn to turn, even when targets are higher or lower. Start a new colony and the pop sits flat at 1 whether the target pop is 12 or -6, and the other meters just sit at zero.

Toggling the focus setting does cause a point of loss, that seems to be the only way to get a meter to change. Unfortunately, that is also now happening if you temporarily change focus and then change it back in the same turn (like just to see what the other targets would be); I think that behavior just started also.

I haven't gotten any farther in testing.
If I provided any code, scripts or other content here, it's released under GPL 2.0 and CC-BY-SA 3.0

Post Reply