Page 1 of 1

Two things found

Posted: Sat Feb 27, 2016 11:43 pm
by Scara
on build.83d4257

Hello!

1. It seems the effect of Nascent Artificial Intelligence isn't active on planets that have a estimated population of 0, but haven't reached it yet.
I noticed on a poor planet I populated, when I was late researching symbiotic biology. As soon the planets est. pop went to 2, NAI kicked in.
Pedia says population should have no effect on the bonus.

2. In the research section, some techs seem to be not properly connected...
It's some kind wierd as it sometime would appear correctly.
Bildschirmfoto206.jpg
Bildschirmfoto206.jpg (49 KiB) Viewed 301 times

Re: Two things found

Posted: Sun Feb 28, 2016 12:19 am
by MatGB
For the former, yes, had never noticed before

Code: Select all

Tech
    name = "LRN_ARTIF_MINDS"
    description = "LRN_ARTIF_MINDS_DESC"
    short_description = "RESEARCH_SHORT_DESC"
    category = "LEARNING_CATEGORY"
    researchcost = 25 * [[TECH_COST_MULTIPLIER]]
    researchturns = 4
    prerequisites = "LRN_ALGO_ELEGANCE"
    effectsgroups = [
        EffectsGroup
            scope = And [
                ProductionCenter
                OwnedBy empire = Source.Owner
                NOT TargetPopulation low = 0 high = 0
            ]
            effects = SetTargetResearch value = Value + 10 * [[RESEARCH_PER_POP]]
    ]
    graphic = "icons/tech/basic_autolabs.png"
I have zero clue why it would be gated by target population not current, nor why it would have low/high both 0, that's weird.

Anyone remember why that was done? Can it be rewritten to be clearer?

Re the second, Geoff's in the process of doing some work on the tech tree, it's all very new, what were your display options? The new 'partial unlocked' filter is doing strange things that I don't yet understand but will ask for explanations of when it's finished.

Re: Two things found

Posted: Sun Feb 28, 2016 9:40 am
by Vezzra
MatGB wrote:Anyone remember why that was done? Can it be rewritten to be clearer?
If no one can remember why it's there in the first place, just kick it out.

Re: Two things found

Posted: Sun Feb 28, 2016 9:34 pm
by Geoff the Medio
Scara wrote:2. In the research section, some techs seem to be not properly connected...
It's some kind wierd as it sometime would appear correctly.
Bildschirmfoto206.jpg
You've hidden partially unlocked techs, but have shown locked techs. You've researched Algorithmic Elegance, but not The Physical Brain, so Translinguistics has one (but not both) prerequisites researched, so is considered partially unlocked, and not shown. Psionics has no researched prerequisites, so is locked, so is shown as requested by your settings.