Can't compile boost

Programmers discuss here anything related to FreeOrion programming. Primarily for the developers to discuss.

Moderators: Committer, Committer

Post Reply
Message
Author
sbowyer
Space Krill
Posts: 3
Joined: Mon Aug 22, 2005 9:48 pm
Location: Orlando, FL

Can't compile boost

#1 Post by sbowyer » Mon Sep 05, 2005 12:56 am

I was greatly impressed with the beautiful appearance of FreeOrion 0.2, and went to the wiki page to download it:

http://www.freeorion.org/index.php/Compile

I saw that it comes with a rather daunting list of packages, so I figured
I'd start by trying to build boost. I'm working under windows XP.

A. Is there more complete directions for building FreeOrion than the link above. Something more than "Compile Boost"? (as though I know anything about boost)

I downloaded and installed Visual C++ 2003 Toolkit as listed, used the command prompt shortcut for it and successfully built the conformance sample. Compiler seems to be fine.

I downloaded boost_1_33_0 from the site, unzipped it into my
\freeorion\boost-scott\boost_1_33_0 directory, and downloaded &
unzipped the custom jam package as listed into same directory.

I then did:

bjam "-sTOOLS=vc-7_1" install > t

Lots of "The system cannot find the path specified" messages came out
to my screen. I examined the output file "t" and there is a huge amount
of output. At the top of the file it mentions something about skipping Python, I don't have that.

At the end of the file it says:

...failed updating 954 targets...
...skipped 412 targets...
...updated 3574 targets...

The result seems to be a lot of stuff in \boost\include, and nothing in
\boost\lib.

B. Is my bjam command above correct? Is there a way of redirecting
error and normal output to the same file in Windows? If I were in Unix,
I'd do something like: > t 2>&1 , but I wouldn't think the Command prompt would work that way.

C. Is there any more pre-requisites for Boost?

I'm stuck at square 1 and appreciate any help I can get.

User avatar
tzlaine
Programming Lead Emeritus
Posts: 1092
Joined: Thu Jun 26, 2003 1:33 pm

#2 Post by tzlaine » Mon Sep 05, 2005 11:40 pm

boost.org has an entire page on building boost. All you need to know is there. Simplified directions can be found in the GG documentation, which is linked on the gigi website (http://gigi.sf.net/doxygen/building.html)

And the requirements state that you need to use boost 1.32. 1.33 does not work, and won't be supported until 1.33.1 comes out and fixes a few critical bugs in a couple of weeks or so.

sbowyer
Space Krill
Posts: 3
Joined: Mon Aug 22, 2005 9:48 pm
Location: Orlando, FL

#3 Post by sbowyer » Mon Sep 12, 2005 1:09 pm

Actually, the FreeOrion compile page says to use "1.32.0 or later", so
I used 1.33.0, but thanks for the tip.

I downloaded 1.32.0, got exactly the same errors as 1.33.0 . I got
suspicious when executing the GiGi simplified command:

cd [BOOST_DIR]\tools\build\jam_src
build.bat

and it complains, "windows.h not found". and I looked in Visual C++'s
include directory, and sure enough, no windows.h (you getting enough sleep, Bill G?).

At this point, I took a hunch and went over to my other XP box, where I've been using the Borland Free C++ compiler for years, and downloaded FreeOrion and Boost there.

Just running build.bat with my Borland compiler went perfectly. I then
went up a few directories (GiGi instructions have one too many ".."), and did:

bjam "-sTOOLS=borland" install > t

and about 20 minutes later, there is all sorts of libraries compiled with
about 4 errors recorded in the output file "t". I don't know if they are significant.

So for now, I guess I'm ready to head off to the next step, building GiGi.
Moral of this story: don't use Visual C++ Toolkit to compile boost, even though that's what the compile page suggests.

User avatar
noelte
Juggernaut
Posts: 872
Joined: Fri Dec 26, 2003 12:42 pm
Location: Germany, Berlin

#4 Post by noelte » Mon Sep 12, 2005 1:54 pm

I'm not sure, but maybe you will run into another problem when using MSVC fo-projects with borland builded libs.
Press any key to continue or any other key to cancel.
Can COWs fly?

dstjames
Space Floater
Posts: 24
Joined: Fri Dec 12, 2003 3:31 pm
Location: Detroit MI USA

I cant get boost to work either

#5 Post by dstjames » Mon Oct 24, 2005 4:58 pm

I am trying to get it installed on Suse 10.0 and cant get it to work. When I run the command: bjam "-sTOOLS=gcc" install I get into a loop where it keeps telling me I have an unknown compiler version. I have GCC version 4.0.2_20050901-3 installed.

Any help appritiated.

Thanks

User avatar
tzlaine
Programming Lead Emeritus
Posts: 1092
Joined: Thu Jun 26, 2003 1:33 pm

#6 Post by tzlaine » Thu Oct 27, 2005 5:00 pm

Any help you need with building boost can probably be found on the boost-users mailing list.

Post Reply