Statically linked Linux-version

Programmers discuss here anything related to FreeOrion programming. Primarily for the developers to discuss.

Moderator: Committer

Message
Author
pallinger
Space Krill
Posts: 5
Joined: Tue Sep 21, 2010 11:35 am

Re: Statically linked Linux-version

#106 Post by pallinger » Thu Sep 23, 2010 10:28 am

Geoff the Medio wrote:According to the log file you posted, the client is crashing when setting up map rendering. That suggests there's a graphics driver problem.
Indeed. I suspect that the opengl drivers are 64bit, so if they meet with 32-bit calls, they just run amok.
Geoff the Medio wrote:What version of OpenGL does your system support?
I attached glxinfo's output, but the most important line seems to be "OpenGL version string: 3.2.0 NVIDIA 195.36.24".
Geoff the Medio wrote:Does anything change if you disable all the rendering options on the galaxy map tab of the options screen before starting a game?
I would sure like to do that, but I do not see a single glimpse of the UI before the program segfaults.
Attachments
glxinfo.txt
glxinfo's output
(24.16 KiB) Downloaded 83 times

pallinger
Space Krill
Posts: 5
Joined: Tue Sep 21, 2010 11:35 am

Re: Statically linked Linux-version

#107 Post by pallinger » Thu Sep 23, 2010 2:42 pm

I have at last tried to run it on a 32-bit virtual machine. It goes further (puts up a blank window), but it also segfaults.
The last lines in the debug log are:

Code: Select all

OpenGL Version Number: 2.1
(HumanClientFSM) IntroMenu
(HumanClientFSM) IntroMenuIdle
It also complains about python 2.5 not being there (true, ubuntu 10.4 has only python 2.6), but seems to continue after noticing that. It also complains about having no sound card (also true, as there is none in the VM), but that should not be fatal.
I will try some other settings on the VM, and check back if something works.

User avatar
Geoff the Medio
Programming, Design, Admin
Posts: 12249
Joined: Wed Oct 08, 2003 1:33 am
Location: Munich

Re: Statically linked Linux-version

#108 Post by Geoff the Medio » Thu Sep 23, 2010 6:50 pm

pallinger wrote:I have at last tried to run it on a 32-bit virtual machine. It goes further (puts up a blank window), but it also segfaults.
The last lines in the debug log are:

Code: Select all

OpenGL Version Number: 2.1
(HumanClientFSM) IntroMenu
(HumanClientFSM) IntroMenuIdle
Hmm. If you've got GL 2.1 and are still getting segfaults before anything gets rendered on a 32-bit machine... I'm not sure what the problem might be. Trying gdb as mentioned earlier might be helpful.
It also complains about python 2.5 not being there (true, ubuntu 10.4 has only python 2.6), but seems to continue after noticing that.
That shouldn't be a problem.
pallinger wrote:
Geoff the Medio wrote:Does anything change if you disable all the rendering options on the galaxy map tab of the options screen before starting a game?
I would sure like to do that, but I do not see a single glimpse of the UI before the program segfaults.
Ah... looking at your log file again, I note that it's dated August 31. I assumed you were getting into the actual game and crashing when rendering the map, not crashing at the start menu. This suggests you're not even writing the log file before the crash happens... And it's possible the log file not being writable is part of the problem. When you installed, did you do so as root, and then immediately run freeorion as root? If so, you might have created a root-owned log file that can't be overwritten by a non-root user. Deleting that and making sure it's writable might help with the crash on the 64-bit system.

Why you also get crashes on the 32-bit system I'm not sure... Is the log file you're quoting for that system actually created when you're running the program now, and definitely not an old log file that can't be overwritten?

pallinger
Space Krill
Posts: 5
Joined: Tue Sep 21, 2010 11:35 am

Re: Statically linked Linux-version

#109 Post by pallinger » Tue Oct 12, 2010 8:16 am

Geoff the Medio wrote: Hmm. If you've got GL 2.1 and are still getting segfaults before anything gets rendered on a 32-bit machine... I'm not sure what the problem might be. Trying gdb as mentioned earlier might be helpful.

OK, I will try gdb when I have the time.
Geoff the Medio wrote:
It also complains about python 2.5 not being there (true, ubuntu 10.4 has only python 2.6), but seems to continue after noticing that.
That shouldn't be a problem.
Still, I installed python 2.5 from the ubuntu-deadsnakes repo, but the problem persists.
Geoff the Medio wrote:Ah... looking at your log file again, I note that it's dated August 31. I assumed you were getting into the actual game and crashing when rendering the map, not crashing at the start menu. This suggests you're not even writing the log file before the crash happens... And it's possible the log file not being writable is part of the problem. When you installed, did you do so as root, and then immediately run freeorion as root? If so, you might have created a root-owned log file that can't be overwritten by a non-root user. Deleting that and making sure it's writable might help with the crash on the 64-bit system.
I checked that, but I'm pretty sure I installed it as an ordinary user, and the directory listing supports that:

Code: Select all

drwxr-xr-x   4 pallinger pallinger  120 2010-10-12 09:38 .
-rw-r--r--   1 pallinger pallinger  9075 2010-08-31 12:50 freeoriond.log
-rw-r--r--   1 pallinger pallinger 23494 2010-08-31 12:50 freeorion.log
-rw-r--r--   1 pallinger pallinger 4173 2010-10-12 09:38 ogre.log
However, I noticed that only ogre.log was being written. Still, I tried deleting (more precisely moving away) the old log files, and re-running. The result was that only the ogre.log was being recreated. I do not know how the old freeorion log was created at all, maybe the previous version could go as far as to create it... (I will attach ogre.log, it may help...)
Geoff the Medio wrote:Why you also get crashes on the 32-bit system I'm not sure... Is the log file you're quoting for that system actually created when you're running the program now, and definitely not an old log file that can't be overwritten?
Yes, it is created there. Moreover, there are three Impostor.TFBWGKBLLHEOUXDZ.........128.png files that were created during the last run on the 32-bit system (They contain some meteorite textures or sprites or renderings from different angles). Funny thing is that they are not being recreated if I move them away and re-run freeorion, but they are created if I move them away and run freeorion-start --tech-demo (with 512MB RAM).
Also running with --tech-demo is not segfaulting with 512MB RAM, but (after putting up a blank screen and working the CPU hard for a minute) being killed. However, It segfaults (after approximately 10 seconds) if it gets 1024MB RAM.

I will try to run freeorion in debug mode later. Meanwhile, I would appreciate if somebody had an ubuntu-specific build of freeorion, or at least ubuntu builds of all the dependencies.
Attachments
ogre.log
ogre.log before segfault on 64-bit ubuntu jaunty
(4.08 KiB) Downloaded 81 times

User avatar
Geoff the Medio
Programming, Design, Admin
Posts: 12249
Joined: Wed Oct 08, 2003 1:33 am
Location: Munich

Re: Statically linked Linux-version

#110 Post by Geoff the Medio » Tue Oct 12, 2010 9:03 am

pallinger wrote:Moreover, there are three Impostor.TFBWGKBLLHEOUXDZ.........128.png files that were created during the last run on the 32-bit system (They contain some meteorite textures or sprites or renderings from different angles). Funny thing is that they are not being recreated if I move them away and re-run freeorion, but they are created if I move them away and run freeorion-start --tech-demo (with 512MB RAM).
I believe those files are created as part of the paged geometry stuff in the 3D rendering system, which is only used in the tech demo. They should be created somewhere other than in the binary directory, but the code that determines their location doesn't respect such things (yet?).

User avatar
Geoff the Medio
Programming, Design, Admin
Posts: 12249
Joined: Wed Oct 08, 2003 1:33 am
Location: Munich

Re: Statically linked Linux-version

#111 Post by Geoff the Medio » Tue Jan 17, 2012 10:56 am

Reportedly the latest Linux static build is not working well on Xubuntu. I've gotten a report that running the application by double clicking result in no apparent response to the attempt. Running from the console is a bit more revealing:

Code: Select all

./freeorion
./freeorion: error while loading shared libraries: libCg.so: cannot open shared object file: No such file or directory
So, it appears that there's a dependency on the Nvidia CG library (nvidia-cg-toolkit) in that build. The CG library isn't actually used in FreeOrion, but it was erroneously marked as a dependency some time ago, so apparently was linked to that binary.

Reportedly just installing the nvidia-cg-toolkit might not work, as another error could then result:

Code: Select all

./freeorion: error while loading shared libraries: libCg.so: wrong ELF class: ELFCLASS64
Google suggests this might be a 64 bit / 32 bit issue. So, running the available build of FreeOrion v0.3.15 for Linux on a 64 bit system may be problematic.

flurdy
Space Krill
Posts: 2
Joined: Fri Aug 06, 2004 11:55 am

Re: Statically linked Linux-version

#112 Post by flurdy » Thu Aug 02, 2012 4:42 pm

Note for more up to date distros and newer freeorion version, the older static ones are a bit out-dated for Linux.

Instead you need to compile it yourself. Instructions :
http://www.freeorion.org/index.php/Compile_In_Linux
http://www.freeorion.org/index.php/Talk ... _In_Linux2

Cheers,
flurdy

Post Reply