Ogre-integration

Programmers discuss here anything related to FreeOrion programming. Primarily for the developers to discuss.

Moderators: Committer, Committer

Post Reply
Message
Author
User avatar
MareviQ
Space Kraken
Posts: 100
Joined: Tue Aug 09, 2005 6:47 pm
Location: Somewhere in Poland

Ogre-integration

#1 Post by MareviQ » Mon Mar 03, 2008 12:11 am

:!: Problem:
On Linux (possibly also MacOS) with some card/driver combinations Ogre will hang up during initialisation of app window (displays the window and stops responding)
:idea: Solution
add

Code: Select all

root->getRenderSystem()->setConfigOption("RTT Preferred Mode", "PBuffer");
before calling

Code: Select all

RenderWindow* window = root->initialise(true, "FreeOrion " + FreeOrionVersionString());
:arrow: this happened to me in another project using Ogre that I'm involved in
abs(imag(ME) / abs(ME)) = exp(PI) - PI - 19;

User avatar
loonycyborg
Compilation Expert
Posts: 219
Joined: Thu Jul 06, 2006 10:30 pm
Location: Russia/Moscow

Re: Ogre-integration

#2 Post by loonycyborg » Mon Mar 03, 2008 10:15 am

I too had this issue when I was running Ogre samples with nvidia's beta driver. When I downgraded nvidia's driver to 100.14.19 this issue went away, even in FBO RTT mode.
In Soviet Russia, forum posts YOU!!

User avatar
tzlaine
Programming Lead Emeritus
Posts: 1092
Joined: Thu Jun 26, 2003 1:33 pm

Re: Ogre-integration

#3 Post by tzlaine » Mon Mar 03, 2008 3:08 pm

Could you elaborate a bit? What does this option do, and what problem does it fix? Is there a link to something on the Ogre ste I could read about this? Ogre docs are usually not very good when it comes to string-based options -- it's hard to find out what such strings do.

User avatar
loonycyborg
Compilation Expert
Posts: 219
Joined: Thu Jul 06, 2006 10:30 pm
Location: Russia/Moscow

Re: Ogre-integration

#4 Post by loonycyborg » Mon Mar 03, 2008 3:39 pm

This option sets the preferred render to texture(RTT) method: Copy, PBuffer or FBO.
tzlaine wrote:Is there a link to something on the Ogre site I could read about this?
http://www.ogre3d.org/phpBB2/viewtopic. ... 6f4e2718c6
Last edited by loonycyborg on Mon Mar 17, 2008 10:35 am, edited 1 time in total.
In Soviet Russia, forum posts YOU!!

User avatar
MareviQ
Space Kraken
Posts: 100
Joined: Tue Aug 09, 2005 6:47 pm
Location: Somewhere in Poland

Re: Ogre-integration

#5 Post by MareviQ » Tue Mar 04, 2008 7:50 am

tzlaine wrote:Could you elaborate a bit? What does this option do, and what problem does it fix? Is there a link to something on the Ogre ste I could read about this? Ogre docs are usually not very good when it comes to string-based options -- it's hard to find out what such strings do.
It's due to buggy drivers. Apple's OpenGL implementation is known to have problems with FBO for example, and most OS X Ogre tutorials suggest using this option
:arrow: http://will.thimbleby.net/ogre/tutorial1.html
:arrow: http://wiki.python-ogre.org/index.php/O ... _the_Demos
:arrow: http://www.ogre3d.org/index.php?option= ... &Itemid=97 (see OSX-related notes)
Recently I've noticed that my own Ogre programs do not start anymore, and hang just after showing the window (same bug as discussed in the thread linked by loonycyborg). By pure luck I googled it, didn't notice that the solution wasn't refering to my problem but the OS X problem, and applied it ... with positive results. I guess nvidia broke their recent linux drivers in that respect.
abs(imag(ME) / abs(ME)) = exp(PI) - PI - 19;

User avatar
tzlaine
Programming Lead Emeritus
Posts: 1092
Joined: Thu Jun 26, 2003 1:33 pm

Re: Ogre-integration

#6 Post by tzlaine » Tue Mar 04, 2008 8:12 pm

Thanks for the heads up. I have yet to see any problem like this, probably because I have not-too-recent NVidia drivers.

Post Reply