Compile error

Programmers discuss here anything related to FreeOrion programming. Primarily for the developers to discuss.

Moderators: Committer, Committer

Post Reply
Message
Author
User avatar
mugsy69
Krill Swarm
Posts: 11
Joined: Sat Oct 25, 2003 2:05 am
Location: Austin, Texas

Compile error

#1 Post by mugsy69 » Tue Oct 28, 2003 5:35 am

I am getting the following error when trying to compile server.dev:

Compiler: Default compiler
Building Makefile: "E:\FreeOrion\server\Makefile.win"
Executing make...
make.exe -f "E:\FreeOrion\server\Makefile.win" all
make.exe: *** No rule to make target `all'. Stop.

Execution terminated


Any ideas? Am I missing something?

Thanks,
Jon

User avatar
mugsy69
Krill Swarm
Posts: 11
Joined: Sat Oct 25, 2003 2:05 am
Location: Austin, Texas

Solved

#2 Post by mugsy69 » Tue Oct 28, 2003 6:23 am

Scratch this question. Figured it out.

modulus
Space Floater
Posts: 22
Joined: Fri Oct 24, 2003 9:19 pm
Location: Houston

Got that one too

#3 Post by modulus » Tue Oct 28, 2003 3:06 pm

Got it too. What did you do to fix it (I can't remember) so that future people have it as a reference.
Tim

User avatar
mugsy69
Krill Swarm
Posts: 11
Joined: Sat Oct 25, 2003 2:05 am
Location: Austin, Texas

My fix.

#4 Post by mugsy69 » Tue Oct 28, 2003 4:39 pm

My problem had to do with my unfamiliarity with Dev C++ (and maybe the fact that it is still a beta release). The fix was actually kind of silly. When I went to Tools\Compiler Options\Programs I had to manually reselect Make.exe from the list of programs and then bam it worked. Go figure. I tried to think if I had done anything else in that troubleshooting run, but I didn't. I thought there is no way that is the fix. :D

Thanks,
Jon

Post Reply