Back from the shadows...

Programmers discuss here anything related to FreeOrion programming. Primarily for the developers to discuss.

Moderators: Committer, Committer

Post Reply
Message
Author
gralves
Space Floater
Posts: 17
Joined: Thu Oct 16, 2003 1:01 am

Back from the shadows...

#1 Post by gralves » Tue Nov 04, 2003 12:28 am

Hi all! For the ones who remember me, I'm back, for the ones who don't my name is Gustavo, I'm from Brazil, and I'd like to help on programming. I leaved the project sometime ago because I was short on time but now I got some free time I could spend on it.

I'm trying to compile the code for sometime now and I'm having some trouble with it, maybe someone can help (Tyreth just gave me a hand by ICQ, I wasn't even being able to log in in the forums due to a inactive user status.)

I was having some trouble with the includes in some files being like this:

Code: Select all

#include "fastevents.h"
when for my computer to understand them they should be like this:

Code: Select all

#include <net/fastevents.h>
rigth now I'm getting this error:

Code: Select all

if g++ -DHAVE_CONFIG_H -I. -I. -I..  -I/usr/include/SDL -D_REENTRANT -I/usr/include/SDL -D_REENTRANT -I/usr/include/SDL -D_REENTRANT -I/usr/include/freetype2 -DFREEORION_LINUX  -I/usr/local/include/GG/ -g3 -Wall  -MT ServerEmpireManager.o -MD -MP -MF ".deps/ServerEmpireManager.Tpo" \
  -c -o ServerEmpireManager.o `test -f '../Empire/ServerEmpireManager.cpp' || echo './'`../Empire/ServerEmpireManager.cpp; \
then mv -f ".deps/ServerEmpireManager.Tpo" ".deps/ServerEmpireManager.Po"; \
else rm -f ".deps/ServerEmpireManager.Tpo"; exit 1; \
fi
In file included from ../server/ServerApp.h:14,
                 from ../Empire/ServerEmpireManager.cpp:4:
../network/ServerNetworkCore.h:1: syntax error before `<<' token
In file included from /usr/include/SDL/SDL.h:34,
                 from ../network/NetworkCore.h:9,
                 from ../network/ServerNetworkCore.h:7,
                 from ../server/ServerApp.h:14,
                 from ../Empire/ServerEmpireManager.cpp:4:
/usr/include/SDL/SDL_types.h:40: ISO C++ forbids declaration of `SDL_bool' with
   no type
In file included from /usr/include/SDL/SDL.h:38,
                 from ../network/NetworkCore.h:9,
                 from ../network/ServerNetworkCore.h:7,
                 from ../server/ServerApp.h:14,
                 from ../Empire/ServerEmpireManager.cpp:4:
/usr/include/SDL/SDL_timer.h:110: syntax error before `(' token
In file included from /usr/include/SDL/SDL_mouse.h:34,
                 from /usr/include/SDL/SDL_events.h:36,
                 from /usr/include/SDL/SDL.h:42,
                 from ../network/NetworkCore.h:9,
                 from ../network/ServerNetworkCore.h:7,
                 from ../server/ServerApp.h:14,
                 from ../Empire/ServerEmpireManager.cpp:4:
/usr/include/SDL/SDL_video.h:602: syntax error before `(' token
In file included from ../network/ServerNetworkCore.h:7,
                 from ../server/ServerApp.h:14,
                 from ../Empire/ServerEmpireManager.cpp:4:
../network/NetworkCore.h:74: syntax error before `==' token
In file included from ../server/ServerApp.h:14,
                 from ../Empire/ServerEmpireManager.cpp:4:
../network/ServerNetworkCore.h:75: syntax error before `==' token
In file included from ../server/ServerApp.h:18,
                 from ../Empire/ServerEmpireManager.cpp:4:
../util/Process.h:36: ISO C++ forbids declaration of `Process' with no type
../util/Process.h:40: non-member function `bool Empty()' cannot have `const'
   method qualifier
../util/Process.h: In function `bool Empty()':
../util/Process.h:40: `m_empty' undeclared (first use this function)
../util/Process.h:40: (Each undeclared identifier is reported only once for
   each function it appears in.)
../util/Process.h: At global scope:
../util/Process.h:49: syntax error before `private'
../util/Process.h:54: destructors must be member functions
../util/Process.h:56: syntax error before `private'
../util/Process.h:65: type/value mismatch at argument 1 in template parameter
   list for `template<class T> class boost::shared_ptr'
../util/Process.h:65:   expected a type, got `ProcessImpl()'
../util/Process.h:65: ISO C++ forbids declaration of `m_impl' with no type
../util/Process.h:66: `bool m_empty' used prior to declaration
../util/Process.h:67: syntax error before `}' token
In file included from ../Empire/ServerEmpireManager.cpp:4:
../server/ServerApp.h:137: type/value mismatch at argument 1 in template
   parameter list for `template<class _Tp, class _Alloc> class std::vector'
../server/ServerApp.h:137:   expected a type, got `Process(const std::string&,
   const std::vector<std::string, std::allocator<std::string> >&)'
../server/ServerApp.h:137: template argument 2 is invalid
../server/ServerApp.h:137: ISO C++ forbids declaration of `m_ai_clients' with
   no type
make[2]: *** [ServerEmpireManager.o] Error 1
make[2]: Leaving directory `/home/gralves/freeorion/FreeOrion/Empire'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/gralves/freeorion/FreeOrion'
make: *** [all] Error 2
I'm using a gentoo linux system to try to compile it.

Thanks in advance for any hell,

Gustavo
[/code]

User avatar
tzlaine
Programming Lead Emeritus
Posts: 1092
Joined: Thu Jun 26, 2003 1:33 pm

#2 Post by tzlaine » Tue Nov 04, 2003 11:44 am

Gustavo, welcome back! Sorry I removed you from the Sourceforge project; I thought you had left permanently.

I'm pretty confused at the errors above, especially the first one. Line 1 of ServerNetworkCore.h doesn't have any '<<' token, and there is no such token in the first 10 lines or so. I have no explanation for that. My only advice is to make sure you have all the latest versions of things (SDL v1.2.5, boost 1.31.2, etc.), and try to use the hand-built Makefiles and see if they work better for you than the autotools build system.

gralves
Space Floater
Posts: 17
Joined: Thu Oct 16, 2003 1:01 am

#3 Post by gralves » Tue Nov 04, 2003 12:42 pm

found the error. ServerNetworkCore.h reads :

Code: Select all

<<<<<<< ServerNetworkCore.h
// -*- C++ -*-
#ifndef _ServerNetworkCore_h_
#define _ServerNetworkCore_h_
                                                                                
#ifndef _NetworkCore_h_
#include "NetworkCore.h"
#endif
                                                                                
#ifndef _NET2_H_
#include <net/net2.h>
#endif
                                                                                
#include <map>
#include <string>
#include <vector>
I'll change it in my version to see if it compiles. Someone please put a // before the first line ( <<<<<<< ServerNetworkCore.h ) it in the CVS.

Thanks,

Gustavo

User avatar
tzlaine
Programming Lead Emeritus
Posts: 1092
Joined: Thu Jun 26, 2003 1:33 pm

#4 Post by tzlaine » Tue Nov 04, 2003 1:07 pm

There's no such line in the checked-in version. That's what CVS puts into a file that had conflicts that must be manually fixed. It probably has to do with how you updated your local copy of the project. You should re-checkout the entire project, or do a "cvs update -C" (the -C ensures you get a clean copy).

gralves
Space Floater
Posts: 17
Joined: Thu Oct 16, 2003 1:01 am

#5 Post by gralves » Tue Nov 04, 2003 1:12 pm

:oops: New to command line cvs :)

Thanks! It seems to be working now

gralves
Space Floater
Posts: 17
Joined: Thu Oct 16, 2003 1:01 am

#6 Post by gralves » Tue Nov 04, 2003 3:03 pm

Still having some trouble :

after running freeorion.exe

Code: Select all

1067959601 DEBUG  : Inserted(SITREP_TECH_RESEARCHED, The technology %m_tech% has been discovered.)
1067959601 DEBUG  : Inserted(SITREP_BASE_BUILT, The planet %m_planet% in system %m_system% has completed a defence base.)
1067959601 FATAL  : GG::GGException (subclass FontException) caught in App::Run(): Face object created from 'arial.ttf' was invalid
1067959601 FATAL  : Initiating Exit (code 1 - error termination)
1067959601 DEBUG  : SDLQuit() complete.
Edit:

Found the arial.ttf file on WindowsKit.zip, unziped it to current directory.

When I start: ./freeoriond.exe everything seems allright. If I start ./freeorionca.exe, freeoriond.exe gets a segfault but freeorionca.exe keeps runing.
./freeorion.exe segfaults (independently of starting or not freeoriond) whit this error:

Code: Select all

gralves@gustavo][~/freeorion/FreeOrion]$ ./freeorion.exe
1067967330 DEBUG  : freeorion logger initialized.
1067967330 DEBUG  : SDLInit() complete.
1067967330 DEBUG  : GLInit() complete.
1067967330 DEBUG  : Inserted(APPNAME, FreeOrion)
1067967330 DEBUG  : Inserted(BROWSE_BTN, Browse...)
1067967330 DEBUG  : Inserted(OK, OK)
1067967330 DEBUG  : Inserted(CANCEL, Cancel)
1067967330 DEBUG  : Inserted(DONE, Done)
1067967330 DEBUG  : Inserted(LOAD, Load)
1067967330 DEBUG  : Inserted(SAVE, Save)
1067967330 DEBUG  : Inserted(SERVER_TIMEOUT, The server is not responding)
1067967330 DEBUG  : Inserted(INTRO_WINDOW_TITLE, FreeOrion Main Menu)
1067967330 DEBUG  : Inserted(INTRO_BTN_SINGLE_PLAYER, Single Player)
1067967330 DEBUG  : Inserted(INTRO_BTN_MULTI_PLAYER, Multi Player)
1067967330 DEBUG  : Inserted(INTRO_BTN_OPTIONS, Options)
1067967330 DEBUG  : Inserted(INTRO_BTN_ABOUT, About)
1067967330 DEBUG  : Inserted(INTRO_BTN_EXIT, Exit)
1067967330 DEBUG  : Inserted(ERR_CONNECT_TIMED_OUT, Timed out while attempting to connect to server)
1067967330 DEBUG  : Inserted(SCONNECT_WINDOW_TITLE, Connect to Server)
1067967330 DEBUG  : Inserted(LAN_GAME_LABEL, Lan game at:)
1067967330 DEBUG  : Inserted(INTERNET_GAME_LABEL, Internet game at:)
1067967330 DEBUG  : Inserted(PLAYER_NAME_LABEL, Player name:)
1067967330 DEBUG  : Inserted(HOST_GAME_BN, Host a new game)
1067967330 DEBUG  : Inserted(JOIN_GAME_BN, Join a game)
1067967330 DEBUG  : Inserted(REFRESH_LIST_BN, Refresh list)
1067967330 DEBUG  : Inserted(MPLOBBY_WINDOW_TITLE, Multiplayer Setup)
1067967330 DEBUG  : Inserted(MPLOBBY_HOST_ABORTED_GAME, The host player has terminated this game setup.)
1067967330 DEBUG  : Inserted(START_GAME_BN, Start game)
1067967330 DEBUG  : Inserted(GSETUP_WINDOW_TITLE, Galaxy Setup)
1067967330 DEBUG  : Inserted(GSETUP_GRAPHICS_FILES, Graphics Files)
1067967330 DEBUG  : Inserted(GSETUP_VERYSMALL, Very Small (50 Stars))
1067967330 DEBUG  : Inserted(GSETUP_SMALL, Small (100 Stars))
1067967330 DEBUG  : Inserted(GSETUP_MEDIUM, Medium (150 Stars))
1067967330 DEBUG  : Inserted(GSETUP_LARGE, Large (200 Stars))
1067967330 DEBUG  : Inserted(GSETUP_VERYLARGE, Very Large (250 Stars))
1067967330 DEBUG  : Inserted(GSETUP_ENORMOUS, Enormous (300 Stars))
1067967330 DEBUG  : Inserted(GSETUP_2ARM, Spiral, 2-arm)
1067967330 DEBUG  : Inserted(GSETUP_3ARM, Spiral, 3-arm)
1067967330 DEBUG  : Inserted(GSETUP_4ARM, Spiral, 4-arm)
1067967330 DEBUG  : Inserted(GSETUP_CLUSTER, Cluster)
1067967330 DEBUG  : Inserted(GSETUP_FROMFILE, From file...)
1067967330 DEBUG  : Inserted(GSETUP_ELLIPTICAL, Elliptical)
1067967330 DEBUG  : Inserted(GSETUP_IRREGULAR, Irregular)
1067967330 DEBUG  : Inserted(GSETUP_ERR_NOEXIST, does not exist.)
1067967330 DEBUG  : Inserted(GSETUP_ERR_INVALID_GRAPHICS, is not a valid graphics file.)
1067967330 DEBUG  : Inserted(ESELECT_WINDOW_TITLE, Empire Selection)
1067967330 DEBUG  : Inserted(ESELECT_EMPIRE_NAME, Empire Name:)
1067967330 DEBUG  : Inserted(LICENSE, License)
1067967330 DEBUG  : Inserted(ABOUT_WINDOW_TITLE, About FreeOrion v0.1a)
1067967330 DEBUG  : Inserted(CREDITS, Credits)
1067967330 DEBUG  : Inserted(INGAMEOPTIONS_WINDOW_TITLE, Options)
1067967330 DEBUG  : Inserted(INGAMEOPTIONS_SAVE, Save Game)
1067967330 DEBUG  : Inserted(INGAMEOPTIONS_LOAD, Load Game)
1067967330 DEBUG  : Inserted(INGAMEOPTIONS_QUIT, Quit Game)
1067967330 DEBUG  : Inserted(MAP_BTN_TURN_UPDATE, Turn )
1067967330 DEBUG  : Inserted(SIDE_PANEL, Side Panel)
1067967330 DEBUG  : Inserted(PLANET_PANEL, Planet Panel)
1067967330 DEBUG  : Inserted(PL_SZ_TINY, Tiny)
1067967330 DEBUG  : Inserted(PL_SZ_SMALL, Small)
1067967330 DEBUG  : Inserted(PL_SZ_MEDIUM, Medium)
1067967330 DEBUG  : Inserted(PL_SZ_LARGE, Large)
1067967330 DEBUG  : Inserted(PL_SZ_HUGE, Huge)
1067967330 DEBUG  : Inserted(PL_TOXIC, Toxic)
1067967330 DEBUG  : Inserted(PL_RADIATED, Radiated)
1067967330 DEBUG  : Inserted(PL_BARREN, Barren)
1067967330 DEBUG  : Inserted(PL_DESERT, Desert)
1067967330 DEBUG  : Inserted(PL_TUNDRA, Tundra)
1067967330 DEBUG  : Inserted(PL_OCEAN, Ocean)
1067967330 DEBUG  : Inserted(PL_TERRAN, Terran)
1067967330 DEBUG  : Inserted(PL_GAIA, Gaia)
1067967330 DEBUG  : Inserted(TURN_PROGRESS_WND, Turn Progress)
1067967330 DEBUG  : Inserted(TURN_PROGRESS_PHASE_FLEET_MOVEMENT, Fleet Movement)
1067967330 DEBUG  : Inserted(TURN_PROGRESS_PHASE_COMBAT, Resolving Combat)
1067967330 DEBUG  : Inserted(TURN_PROGRESS_PHASE_EMPIRE_GROWTH, Production And Growth)
1067967330 DEBUG  : Inserted(TURN_PROGRESS_PHASE_WAITING, Waiting for Players to End Turn)
1067967330 DEBUG  : Inserted(TURN_PROGRESS_PHASE_ORDERS, Executing Orders)
1067967330 DEBUG  : Inserted(SITREP_PANEL_TITLE, Situation Report)
1067967330 DEBUG  : Inserted(SITREP_PANEL_CLOSE, Close)
1067967330 DEBUG  : Inserted(SITREP_MAX_INDUSTRY, The planet %m_planet% in system %m_system% has reached it's maximum production.)
1067967330 DEBUG  : Inserted(SITREP_SHIP_BUILT, A new ship %m_ship% is now orbiting planet %m_planet%.)
1067967330 DEBUG  : Inserted(SITREP_TECH_RESEARCHED, The technology %m_tech% has been discovered.)
1067967330 DEBUG  : Inserted(SITREP_BASE_BUILT, The planet %m_planet% in system %m_system% has completed a defence base.)
Segmentation fault


gralves
Space Floater
Posts: 17
Joined: Thu Oct 16, 2003 1:01 am

#7 Post by gralves » Wed Nov 05, 2003 1:22 am

Recompiled and it worked. I just have one word to describe it: WOW (Using Neo voice :) )

User avatar
Tyreth
FreeOrion Lead Emeritus
Posts: 885
Joined: Thu Jun 26, 2003 6:23 am
Location: Australia

#8 Post by Tyreth » Wed Nov 05, 2003 3:05 am

gralves wrote:Recompiled and it worked. I just have one word to describe it: WOW (Using Neo voice :) )
Speaking of which, I am going to see all three of the movies tonight for a movie marathon. Hopefully I don't get restless, should be good. At last, the story shall be completed!

Stay tuned for spoilers on the forums tomorrow, where I can ruin your matrix experience :wink:

gralves
Space Floater
Posts: 17
Joined: Thu Oct 16, 2003 1:01 am

#9 Post by gralves » Wed Nov 05, 2003 3:31 am

I will have to stay away from the forums then... I only got tickets for thursday evening here in Brazil... :(

User avatar
kroddn
Static Linker
Posts: 347
Joined: Thu Jun 28, 2007 10:28 am

Re: Back from the shadows...

#10 Post by kroddn » Thu May 27, 2010 2:36 pm

A player hat trouble when executing FreeOrion while "utorrent" was running. If you are used to run utorrent too, then try disabling that.

Post Reply