0.3.14 can't start arch linux

Problems and solutions for installing or running FreeOrion, including discussion of bugs if needed before posting a bug report. For problems building from source, post in Compile.

Moderators: Oberlus, Oberlus

Message
Author
elmariachi
Space Krill
Posts: 6
Joined: Tue Jun 08, 2010 7:59 pm

0.3.14 can't start arch linux

#1 Post by elmariachi » Thu Jun 24, 2010 9:13 am

Downloaded the latest package. Using just the symlink to start the game didn't work so I tried using the command-line:

Code: Select all

[email protected] ~/jogos/freeorion/freeorion % ./freeorion                  <10:12>
Following into my basedir
CWD: /home/mariachi/jogos/freeorion/freeorion/application
python2.5 found. Using it.
./freeorion: line 61:  7285 Segmentation fault      ${STRACE} ./freeorion --settings-dir ./default [email protected]
what does this mean?

thank you

User avatar
Geoff the Medio
Programming, Design, Admin
Posts: 12487
Joined: Wed Oct 08, 2003 1:33 am
Location: Munich

Re: 0.3.14 can't start arch linux

#2 Post by Geoff the Medio » Thu Jun 24, 2010 4:43 pm

Have you previously had any other versions of freeorion on that system?

Are there any .log files in ~/.freeorion/ and if so could you post them?

elmariachi
Space Krill
Posts: 6
Joined: Tue Jun 08, 2010 7:59 pm

Re: 0.3.14 can't start arch linux

#3 Post by elmariachi » Thu Jun 24, 2010 6:57 pm

I had a working version, not sure which, maybe the previous one or the one before.
Only one log in .freeorion, ogre.log
http://pastebin.com/vTW5w9te

User avatar
Geoff the Medio
Programming, Design, Admin
Posts: 12487
Joined: Wed Oct 08, 2003 1:33 am
Location: Munich

Re: 0.3.14 can't start arch linux

#4 Post by Geoff the Medio » Thu Jun 24, 2010 7:18 pm

Looks like this might be the problem:
17:05:43: OGRE EXCEPTION(6:FileNotFoundException): '/home/mariachi/freeorion/application/ogre_plugins.cfg' file not found! in ConfigFile::load at OgreConfigFile.cpp (line 84)
17:05:43: /home/mariachi/freeorion/application/ogre_plugins.cfg not found, automatic plugin loading disabled.
Is that file located somewhere on your system? I'm not sure how the linux version is set up, but on Windows it's in the main FreeOrion directory where the executables are located.

Could you make sure you delete everything, including any subdirectories or hidden files, in ~/.freeorion/ and try again? Also make sure there's no other versions of freeorion around that might get run instead of the new one you've downloaded.

elmariachi
Space Krill
Posts: 6
Joined: Tue Jun 08, 2010 7:59 pm

Re: 0.3.14 can't start arch linux

#5 Post by elmariachi » Thu Jun 24, 2010 8:24 pm

that file is nowhere in my system. I don't have OGRE installed, although I had before and I still couldn't play. I'll install it again and look for that file and copy it to the binaried folder.

I'm using the latest tarball, maybe someone forgot to package it, but if that would be the case more people would complain no? :cry:

User avatar
Geoff the Medio
Programming, Design, Admin
Posts: 12487
Joined: Wed Oct 08, 2003 1:33 am
Location: Munich

Re: 0.3.14 can't start arch linux

#6 Post by Geoff the Medio » Thu Jun 24, 2010 9:19 pm

ogre_plugins.cfg is a file that comes with FreeOrion, not with Ogre (or if it does come with Ogre, it's not necessarily the same version as comes with FreeOrion), and you shouldn't need Ogre installed for that file (or to run FreeOrion).

What do you mean by "latest tarball" ?

elmariachi
Space Krill
Posts: 6
Joined: Tue Jun 08, 2010 7:59 pm

Re: 0.3.14 can't start arch linux

#7 Post by elmariachi » Thu Jun 24, 2010 9:27 pm

http://freeorion.psitronic.de/download/ newest file from here.

Well my freeorion package doesn't have that file, and the others don't either. I'll download another version to see.

User avatar
kroddn
Static Linker
Posts: 347
Joined: Thu Jun 28, 2007 10:28 am

Re: 0.3.14 can't start arch linux

#8 Post by kroddn » Thu Jun 24, 2010 9:47 pm

I don't think that this error message has anything to do with the crash you experience. The plugin config is not needed, because all ogre modules are linked into the binary statically.

I think your graphic card driver is the problem - normally that's the reason for segfault crashes without any further error message.

Can you paste the output of the command "glxinfo"?

elmariachi
Space Krill
Posts: 6
Joined: Tue Jun 08, 2010 7:59 pm

Re: 0.3.14 can't start arch linux

#9 Post by elmariachi » Fri Jun 25, 2010 8:44 am

http://pastebin.com/gEfLjhu1
it has OpenGl 2.0 as far as I know, Intel card though.

User avatar
Geoff the Medio
Programming, Design, Admin
Posts: 12487
Joined: Wed Oct 08, 2003 1:33 am
Location: Munich

Re: 0.3.14 can't start arch linux

#10 Post by Geoff the Medio » Fri Jun 25, 2010 3:42 pm

elmariachi wrote:it has OpenGl 2.0 as far as I know, Intel card though.
Looks like it supports GL 2.1:
OpenGL version string: 2.1 Mesa 7.8.2
I'm not sure what else to ask about or suggest. It's apparently not getting far enough into execution to get into actual FreeOrion code... If it's not a GL version issue, then it could still be some sort of incompatibility between Ogre and your video drivers, but I'm not sure how to test that or what to change other than suggesting you try updating your video drivers.

elmariachi
Space Krill
Posts: 6
Joined: Tue Jun 08, 2010 7:59 pm

Re: 0.3.14 can't start arch linux

#11 Post by elmariachi » Sat Jun 26, 2010 12:05 pm

I already have the latest available version of the drivers.
I'll ask people with intel cards to test this to see if it's a card issue, or just something wrong with my computer.
It doesn't look like a bug though, but still I'll keep this thread updated.

athros
Krill Swarm
Posts: 11
Joined: Fri Aug 06, 2010 11:47 pm

Re: 0.3.14 can't start arch linux

#12 Post by athros » Fri Aug 06, 2010 11:58 pm

Code: Select all

Following into my basedir
CWD: /home/nsawlidi/Games/freeorion/application
python2.5 found. Using it.
./freeorion: line 143:  2127 Segmentation fault      ${FO_TRACE} ${FO_GDB_ARGS} ./freeorion --resource-dir ./default [email protected]
Same problem. Arch Linux, 64 Bit, on a laptop with a m9000 nVidia card. The fault is directly after starting the program. I don't see much else.

It is the latest version I could download.

glxinfo

Logs from ~/.freeorion should be attached. If not, I'll add them in. What else would you like from me?
Attachments
ogre.log
Log 2
(3.27 KiB) Downloaded 164 times
freeoriond.log
Log 1
(139 Bytes) Downloaded 167 times

User avatar
Geoff the Medio
Programming, Design, Admin
Posts: 12487
Joined: Wed Oct 08, 2003 1:33 am
Location: Munich

Re: 0.3.14 can't start arch linux

#13 Post by Geoff the Medio » Sat Aug 07, 2010 1:49 am

From your glxinfo:
GLX version: 1.4
That might be your problem. If so, there might be a workaround if you're willing and able to recompile FreeOrion yourself. Otherwise, you probably won't be able to run recent versions of FreeOrion on that system.

User avatar
kroddn
Static Linker
Posts: 347
Joined: Thu Jun 28, 2007 10:28 am

Re: 0.3.14 can't start arch linux

#14 Post by kroddn » Sat Aug 07, 2010 5:32 am

Please download the Debuggingsymbols for your version of freeorion from sourceforge and run:

Code: Select all

./freeorion --gdb


This loads FreeOrion inside gdb. Then type "s" + Enter, this will run the game.

When the game crashes, type "bt"+Enter and copy+paste the backtrace.

athros
Krill Swarm
Posts: 11
Joined: Fri Aug 06, 2010 11:47 pm

Re: 0.3.14 can't start arch linux

#15 Post by athros » Mon Aug 09, 2010 11:30 pm

@kroddin - I was on .14, and I could not get the ./freeorion --gdb to work. Argument d and b not found.
I'm on .15 and same problem. I'm untaring and putting the files into the application directory of freeorion, assuming that is correct. Do I need to do something else?

@Geoff the Medio - I am willing to recompile, I just need to know the libraries I need to get. I think I have the basics of what I need.

Post Reply