No game mouse and massive screenflicker on Win10

Problems and solutions for installing or running FreeOrion, including discussion of bugs if needed before posting a bug report. For problems building from source, post in Compile.
Message
Author
AndrewW
Juggernaut
Posts: 767
Joined: Mon Feb 04, 2013 10:15 pm

Re: No game mouse and massive screenflicker on Win10

#31 Post by AndrewW » Sun Oct 15, 2017 9:04 am

defaultuser wrote:I made a few brief videos, but even so they're 8MB or so. I'm not sure if they can be attached or not.
Perhaps you could upload the video's somewhere else and link them.

defaultuser
Vacuum Dragon
Posts: 566
Joined: Wed Aug 26, 2015 6:15 pm

Re: No game mouse and massive screenflicker on Win10

#32 Post by defaultuser » Sun Oct 15, 2017 4:23 pm

LGM-Doyle wrote:defaultuser, thanks for reporting this issue. It is difficult to fix as none of the devs can replicate the problem.

Can you provide answers to the following questions? It might help in understanding the problem.

Can you pull from github compile from source?

I am not set up for compiling at this time.

What operating system and version are you using?

Win 10, Version 1703.

What version of OpenGL is installed?

I don't know. The web indicates installing a third-party program to find out, which I'm not inclined to do.

What processor are you using?

Intel(R) Core(TM) i3-2100 CPU @ 3.10GHz (4 CPUs), ~3.1GHz

What video card/chip are you using?

Intel(R) HD Graphics

Please attach your logs from a game when the flickering is happening?

The logs are routine. No errors reported for anything like this.

Are all of you config settings at the defaults? Please post the "config.xml" that you are using?

It is present with the default config file. Changing settings has no effect.

Describe the flickering? Is it a fast or a slow flicker? Is it just the icons flickering? When you say icons, do you mean clickable buttons? Is the flickering of the icons/buttons synchronized; do they flicker together? Are rectangles of the screen flickering?

Flicker rate varies. It's faster when any windows (Sit Rep, Fleet, etc.) are open. Many synchronize, but others are not. It's pretty much any icon, clickable or not. I have described that in messages above. The videos would show that, but I'm not sure if those can be uploaded. What's the file limit for attachments?

I have attached a screenshot. The flickering in the fleet window does not affect the icons in the frame of it, but the ship ones ripple from top to bottom. As you can see, only one has any visible at a time.

Really, flicker (while annoying) is not that big of a hindrance to playing. The vanishing cursor is a much bigger problem. I have determined that getting it back in the game window can be done just by clicking the top menu bar when a window is open. When it's missing for a menu window, there's no getting it and you have to navigate by "feel".


Can you run games where the maximum frames per second (FPS) is clamped at 30 and then 15 FPS?
Is the problem the same at the different frame rates?

I don't know what this means.

Check the logs for you video card/chip. Is it being reset?

I don't know anything about these logs.

Thanks for the answers.
FL.jpg
FL.jpg (157.52 KiB) Viewed 421 times

dbenage-cx
Programmer
Posts: 389
Joined: Sun Feb 14, 2016 12:08 am

Re: No game mouse and massive screenflicker on Win10

#33 Post by dbenage-cx » Sun Oct 15, 2017 6:39 pm

OpenGL version should be printed near top of freeorion.log file, so no need for a special install.

The config option max-fps defines the maximum framerate, the default value is 60.
limit-fps toggles if framerate is limited by max-fps or not, default is true (1).
These can be edited in the config file, or specified as a command-line argument (e.g. --max-fps 30).
max-fps could also be adjusted at bottom of Options->Video (provided it can be navigated to).

defaultuser
Vacuum Dragon
Posts: 566
Joined: Wed Aug 26, 2015 6:15 pm

Re: No game mouse and massive screenflicker on Win10

#34 Post by defaultuser » Sun Oct 15, 2017 7:33 pm

dbenage-cx wrote:OpenGL version should be printed near top of freeorion.log file, so no need for a special install.

Got it: GL Version String: 3.1.0 - Build 9.17.10.4459

The config option max-fps defines the maximum framerate, the default value is 60.
limit-fps toggles if framerate is limited by max-fps or not, default is true (1).
These can be edited in the config file, or specified as a command-line argument (e.g. --max-fps 30).
max-fps could also be adjusted at bottom of Options->Video (provided it can be navigated to).

Not a noticeable difference at 30, although that might be perception. Flicker is slower at 15. No effect on cursor.

LGM-Doyle
Programmer
Posts: 219
Joined: Mon Feb 29, 2016 8:37 pm

Re: No game mouse and massive screenflicker on Win10

#35 Post by LGM-Doyle » Tue Oct 17, 2017 7:33 pm

dbenage-cx thanks for answering the question about how to adjust the FPS.

defaultuser, I've looked at the code and I don't see what the problem is with either the missing mouse or the flickering.

There is a FPS indicator, that can be turned on in Options->Video->Show FPS. It appears in the upper left corner of the screen.

When your max FPS is set to something normal and the FPS indicator is turned on, what FPS do you get when the flickering is happening?

I've pushed a change that should be in yesterday's weekly build that will allow you to adjust the FPS down to 1.

Could you set your max FPS to 1 and then describe what is happening with the flickering? Does the flickering also slow down to 1 flicker per second?

defaultuser
Vacuum Dragon
Posts: 566
Joined: Wed Aug 26, 2015 6:15 pm

Re: No game mouse and massive screenflicker on Win10

#36 Post by defaultuser » Wed Oct 18, 2017 12:39 am

The FPS is always 15. I had to restart the game to get that to show. A side-effect seems to be that most of the icons on the top bar don't show at all now. Only the cluster on the far right shows. That's not great. See screenshot below.

Turning off the FPS indicator restored the icons to blinking.

I will try the new build when I get a chance.
FL2.jpg
FL2.jpg (181.17 KiB) Viewed 383 times

defaultuser
Vacuum Dragon
Posts: 566
Joined: Wed Aug 26, 2015 6:15 pm

Re: No game mouse and massive screenflicker on Win10

#37 Post by defaultuser » Wed Oct 18, 2017 5:55 pm

LGM-Doyle wrote: I've pushed a change that should be in yesterday's weekly build that will allow you to adjust the FPS down to 1.

Could you set your max FPS to 1 and then describe what is happening with the flickering? Does the flickering also slow down to 1 flicker per second?
Couldn't load the latest:

http://www.freeorion.org/forum/viewtopi ... 370#p90370

Update: I got the latest binaries and copied them into my download of the test build from back in August. That ran. The blink rate at 1 FPS was very slow, probably on each two seconds with windows open, and about one every three or four seconds with no windows.

defaultuser
Vacuum Dragon
Posts: 566
Joined: Wed Aug 26, 2015 6:15 pm

Re: No game mouse and massive screenflicker on Win10

#38 Post by defaultuser » Thu Oct 19, 2017 11:59 pm

Another anomaly (as discussed in Playtesting) is that the slots for ship hulls in the design window don't show up all. No flicker or anything, just not there.

SB.jpg
SB.jpg (159.35 KiB) Viewed 358 times

defaultuser
Vacuum Dragon
Posts: 566
Joined: Wed Aug 26, 2015 6:15 pm

Re: No game mouse and massive screenflicker on Win10

#39 Post by defaultuser » Tue Nov 07, 2017 6:12 pm

Here are some brief videos with screen flicker. I couldn't do direct screen capture, so I shot video with an ipad. Not the greatest results, but you get the idea.

https://www.youtube.com/channel/UCfRe8t ... JyA/videos

LGM-Doyle
Programmer
Posts: 219
Joined: Mon Feb 29, 2016 8:37 pm

Re: No game mouse and massive screenflicker on Win10

#40 Post by LGM-Doyle » Wed Nov 08, 2017 4:16 pm

defaultuser, thanks for the videos.

I've looked at them and they are as you described. It did not clarify for me what is causing the problem.

Hopefully, someone else looks at the videos and has an aha moment.

User avatar
Ouaz
Dyson Forest
Posts: 218
Joined: Wed Aug 13, 2014 7:21 pm
Location: France

Re: No game mouse and massive screenflicker on Win10

#41 Post by Ouaz » Wed Nov 08, 2017 5:57 pm

LGM-Doyle wrote:Hopefully, someone else looks at the videos and has an aha moment.
Intel HD integrated graphic card is guilty (2000 and 3000 for sure, 4000 I don't know) .

I run FO on a laptop with switchable graphics cards: Intel HD Graphics 3000 and ATI Radeon HD 7670M.

When set to the Intel, I have the same flickering/disappearing mouse cursor or/and icons, panels, text, etc.

No problem when I switch to the Radeon.

Some reading, all reports of the same flickering UI / disappearing mouse (from most recent to older), with one point in common: Intel HD Graphics.

http://freeorion.org/forum/viewtopic.php?f=25&t=10515
http://freeorion.org/forum/viewtopic.php?f=28&t=10256
http://freeorion.org/forum/viewtopic.php?f=28&t=9825
http://freeorion.org/forum/viewtopic.php?f=28&t=9795

I can't say if updating the card's driver solves the problem, as the commutable GC system of my laptop requires a dedicated driver (i.e. I can't install the latest Intel HD Graphics 3000 driver on its own). And the last dedicated driver for Intel/Radeon dual card system is from... 2012.
I release every updated file under the CC-BY-SA 3.0 license.

defaultuser
Vacuum Dragon
Posts: 566
Joined: Wed Aug 26, 2015 6:15 pm

Re: No game mouse and massive screenflicker on Win10

#42 Post by defaultuser » Wed Nov 08, 2017 6:26 pm

Right, the Integrated Graphics was pretty well determined as the cause. There's some question as to whether Windows 10 is required or not. In my case, the switch in graphics hardware and move from 7->10 were due to the older computer suffering catastrophic failure. I installed the old drive in this computer, and can boot from it, but FO doesn't run at in that scenario, so I can't test that part.

Likely until I get to the point where I could devote the time to getting build capability and could try stuff, or a developer can borrow a system with IG, this will be as far as we go. I can of course perform any tests or investigation from a strict user perspective that would be helpful.

User avatar
Ouaz
Dyson Forest
Posts: 218
Joined: Wed Aug 13, 2014 7:21 pm
Location: France

Re: No game mouse and massive screenflicker on Win10

#43 Post by Ouaz » Sun Dec 10, 2017 6:40 pm

Update:

On v0.4.7+ [build 2017-12-04.25bd9a9] (Windows 7)

I switched back to Intel 3000 HD graphic card... and surprise!

Everything works fine: no screen/icon flickering or mouse disappearing.

@ defaultuser: can you download the latest weekly build for Windows (here), try on your side with the Intel 3000 and report if the problem is fixed?

For reference: Issue #676 - Pointer hidden and windows flicker on Win10/Intel Core i5-2430M

My previous installed build was v0.4.7+ [build 2017-09-19.c6dd5b5] > screen flickering and hidden mouse with Intel HD Grapĥics 3000
My last installed build is v0.4.7+ [build 2017-12-04.25bd9a9] > everything works fine with Intel HD Graphics 3000
I release every updated file under the CC-BY-SA 3.0 license.

defaultuser
Vacuum Dragon
Posts: 566
Joined: Wed Aug 26, 2015 6:15 pm

Re: No game mouse and massive screenflicker on Win10

#44 Post by defaultuser » Mon Dec 11, 2017 2:12 am

Sure. I'll give a report when I have had a chance to try it.

defaultuser
Vacuum Dragon
Posts: 566
Joined: Wed Aug 26, 2015 6:15 pm

Re: No game mouse and massive screenflicker on Win10

#45 Post by defaultuser » Mon Dec 11, 2017 6:37 am

Looks good. No flicker, cursor is present, ship slots are visible.

The odd things I saw off the start (I didn't spend much time) was that no saved ships loaded, and there were no error messages. I'll look into that more later.

Edit: I see that you need to click "unavailable" to see saved ships that aren't buildable yet.

Also in ship design, all parts were visible whether "unavailable" was selected or not.

Edit: I started another game, and this problem didn't show up. I will see if there is a saved from the one that did.

Post Reply