[LMDE,0.4.6] "Timed out while attempting to connect to server" on attempt to start new single player game

Problems and solutions for installing or running FreeOrion, including discussion of bugs if needed before posting a bug report on GitHub. For problems building from source, post in Compile.

Moderators: Oberlus, Oberlus

Post Reply
Message
Author
Jacob_The_Heartless
Space Krill
Posts: 7
Joined: Fri Jan 10, 2020 12:16 am

[LMDE,0.4.6] "Timed out while attempting to connect to server" on attempt to start new single player game

#1 Post by Jacob_The_Heartless » Fri Jan 10, 2020 12:45 am

Using LMDE and lastest freeorion just installed from repo (using "sudo apt-get install freeorion"). Every time I try to start new single player game, I get hit by timeout server error. I tried to start JACK server (as was mentioned somewhere on forum) but with no success. I'm aware of client-server system used even in singleplayer. Despite I know is not required for single player, I had working network connection....
My /etc/hosts:

Code: Select all

127.0.0.1	localhost
127.0.1.1	jacobmachine
# The following lines are desirable for IPv6 capable hosts
::1     localhost ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts
I have working loopback :

Code: Select all

[email protected]:~$ ifconfig lo
lo: flags=73<AKTIVOVÁNO,SMYČKA,BĚŽÍ>  mtu 65536
        inet 127.0.0.1 síťová_maska 255.0.0.0
        inet6 ::1  délka_prefixu 128  scopeid 0x10<stroj>
        loop délka_odchozí_fronty 1  (Místní smyčka)
        RX packetů 4308206  bajtů 215421404 (205,4 MiB)
        RX chyb 0  zahozeno 0  přetečení 0  rámců 0
        TX packetů 4308206  bajtů 215421404 (205,4 MiB)
        TX chyb 0  zahozeno 0  přetečení 0  přenos 0  kolizí 0
I can ping it, it responds :

Code: Select all

[email protected]:~$ ping localhost
PING localhost(localhost (::1)) 56 data bytes
64 bytes from localhost (::1): icmp_seq=1 ttl=64 time=0.036 ms
64 bytes from localhost (::1): icmp_seq=2 ttl=64 time=0.041 ms
64 bytes from localhost (::1): icmp_seq=3 ttl=64 time=0.063 ms
64 bytes from localhost (::1): icmp_seq=4 ttl=64 time=0.054 ms
I'm out of ideas and reaching for help here. I have tried everything I could think of.
The attachment Snímek obrazovky_2020-01-10_01-20-27.png is no longer available
The attachment Snímek obrazovky_2020-01-10_01-40-15.png is no longer available
I'm attaching longs too
The attachment freeorion.log is no longer available
Snímek obrazovky_2020-01-10_01-20-27.png
Error screenshot
Snímek obrazovky_2020-01-10_01-20-27.png (940.21 KiB) Viewed 1016 times
Any suggestion or idea or ritual or whatever may help gladly welcomed

User avatar
swaq
Space Dragon
Posts: 333
Joined: Tue Aug 20, 2019 1:56 pm

Re: [LMDE,0.4.6] "Timed out while attempting to connect to server" on attempt to start new single player game

#2 Post by swaq » Fri Jan 10, 2020 2:25 am

Version 0.4.6 is a pretty old version. 0.4.8 is the latest stable with 0.4.9 coming out soon. Figuring out how to get a newer version should be your first step.

Jacob_The_Heartless
Space Krill
Posts: 7
Joined: Fri Jan 10, 2020 12:16 am

Re: [LMDE,0.4.6] "Timed out while attempting to connect to server" on attempt to start new single player game

#3 Post by Jacob_The_Heartless » Fri Jan 10, 2020 9:23 am

swaq wrote:
Fri Jan 10, 2020 2:25 am
Version 0.4.6 is a pretty old version. 0.4.8 is the latest stable with 0.4.9 coming out soon. Figuring out how to get a newer version should be your first step.
Indeed. Looks like repo is behind. Installed new version from snap solved issue completely. I have mixed feelings now. On one side I'm glad it works, on other I feel stupid. Thank you for help

Post Reply